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Tutorial Outline – Day 1 
Time (Tentative!) Module Topics Presenter 

8:30-10:00 
 

1.  Installation & Overview 
2.  Eclipse Basics 

ª  Installation & Overview of Eclipse and PTP,  
Survey student expectations / Adjust agenda 

ª  Eclipse architecture & organization overview 
ª  Creating a synchronized C  project from CVS 

 
 Beth/Jay 

10:00-10:15 BREAK 

10:15-12:15 3. Editor features, MPI 
 
4. Build/run  

ª  Editor features; MPI Features 

ª  Building w/Makefile 
ª  Target configurations and launching a parallel app 
ª  Including Modules (Build Environment Mgmt) 

 

Beth 
 
 
Jay 

12:15 – 1:30 Lunch 

1:30-3:00 5. Fortran  
6. Adv. Features 
7. NCSA features 
8. Parallel Debugging 

ª  Fortran PTP/Eclipse projects, editor, features 
ª  Searching, Refactoring, NCSA features 

 
ª  Debugging an MPI Program 

Jay 
 
 
Beth 

3:00-3:15 BREAK 

 
3:15-4:45 

9/10. Performance Tuning 
& Analysis Tools 
12. gprof/gcov 
 

ª  TAU, External Tools FrameWork  
 

ª  Linux tools: Gprof/Gcov  

Wyatt  
 
Jay/Wyatt 
 
 
 



Tutorial Outline – Day 2 
Time (Tentative!) Module Topics Presenter 

8:30-10:00 
 

9/10. Perf Tools con’t 
OTHER TOPICS 

ª  Continue… 
ª  Other topics, student requests, etc. 

 
 Wyatt/Jay/Beth 

10:00-10:15 BREAK 

10:15-12:15 20. Other Tools/Wrapup ª  PTP Other tools, website, mailing lists, etc 
ª  Upcoming features 

Beth 

12:15 – 1:30 Lunch 



Final Slides, Installation 
Instructions 

ª Please go to http://
wiki.eclipse.org/PTP/tutorials/
SEA2014 for slides and installation 
instructions 

 



Installation 

ª Objective 
ª To learn how to install Eclipse and PTP 

ª Contents 
ª System Prerequisites 
ª Eclipse Download and Installation of “Eclipse for 

Parallel Application Developers” 
ª Installation Confirmation 
ª Updating the PTP within your Eclipse to the latest 

release 

Installation Install-1 



System Prerequisites 
ª Local system (running Eclipse) 

ª Linux (just about any version) 
ª MacOSX (10.5 Leopard or higher) 
ª Windows (XP on) 

ª Java: Eclipse requires Sun or IBM Java 
ª Only need Java runtime environment (JRE) 
ª Java 1.6 or higher  

ª Java 1.6 is the same as JRE 6.0 
ª The GNU Java Compiler (GCJ), which comes standard 

on Linux, will not work! 
ª OpenJDK, distributed with some Linux distributions, 

comes closer to working, but should not be used. 
ª See http://wiki.eclipse.org/PTP/installjava 
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Eclipse Packages 
ª The current version of Eclipse (4.3) is also 

known as “Kepler” 
ª Eclipse is available in a number of different 

packages for different kinds of development 
ª http://eclipse.org/downloads 

ª For PTP, we recommend the all-in-one 
download: 
ª Eclipse for Parallel Application Developers 

 
 
 
 
We often call this the “Parallel Package” 
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New! See 
next slide 
for update 



New! Parallel Package updated 
ª  The public Parallel Package on eclipse.org/downloads is 

only updated three times yearly 
ª  We are now building updated all-in-one packages with 

new releases of PTP already installed. 
ª  Go to http://eclipse.org/ptp/downloads.php 
ª  Under File Downloads: 
ª  Click on the link, and on the file downloads page, see 

Parallel Application Developers Package and 
download the appropriate file for your platform 
ª  Mac OS X 
ª  Linux X86 and X86_64 
ª  Windows x86 and x86_64 

ª  Unzip or untar it 
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Exercise 

1.  Download the “Eclipse for Parallel Application 
Developers” package to your laptop 
ª  Your tutorial instructions will provide the location of 

the package 
ª  Make sure you match the architecture with that of 

your laptop 
2.  If your machine is Linux or Mac OS X, untar 

the file 
ª  On Mac OS X you can just double-click in the Finder 

3.  If your machine is Windows, unzip the file 
4.  This creates an eclipse folder containing the 

executable as well as other support files and 
folders 
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Starting Eclipse 
ª  Linux 

ª  From a terminal window, enter 
“<eclipse_installation_path>/eclipse/eclipse &” 
 

ª  Mac OS X 
ª  From finder, open the eclipse folder where you installed 
ª Double-click on the Eclipse application 
ª Or from a terminal window 

 
ª  Windows 

ª Open the eclipse folder 
ª Double-click on the eclipse executable 
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ª Eclipse prompts for a workspace location at 
startup time 

ª The workspace contains all user-defined data 
ª Projects and resources such as folders and files 
ª The default workspace location is fine for this tutorial 

Specifying A Workspace 

The prompt can be 
turned off 
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Eclipse Welcome Page 

ª Displayed when Eclipse is run for the first time 
Select “Go to the workbench” 

Install-8 
Installation 



Checking for PTP Updates 

ª From time-to-time there may be newer PTP 
releases than the Kepler release 
ª Kepler and “Parallel package” updates are released 

only in September and February 

ª PTP maintains its own update site with the 
most recent release 
ª Bug fix releases can be more frequent than base 

Eclipse (e.g. Kepler), and what is within the parallel 
package 

ª You must enable (and install from) the PTP-
specific update site before the updates will be 
found 
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Updating PTP 
ª  Now select Help>Install New Software… 

ª  In the Work With: dropdown box, select this update site, 
or enter it: 
http://download.eclipse.org/tools/ptp/updates/kepler 
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Updating PTP (2) 

ª  Easiest option is to check everything - which updates 
existing features and adds a few more 
 
 
 
 
 
Note: for this tutorial, this installs extra features we’ll 
refer to later anyway (GEM, TAU) 

 
ª  Select Next  to continue updating PTP 
ª  Select Next  to confirm features to install 
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Updating PTP (3) 

ª  Accept the License agreement and select Finish  
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Updating PTP - restart 
 

ª  Select Yes when prompted to restart Eclipse 
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Updating Individual Features 

ª  It’s also possible (but a bit tedious) to update features 
without adding any new features 
ª  Open each feature and check the ones you want to update 
 

 
ª  Icons indicate: Grey plug: already installed 

                      Double arrow: can be updated 
                           Color plug: Not installed yet 
 

ª  Note: if network is slow, consider unchecking: 
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Restart after Install 

ª  If any new top-level features 
are installed, they will be 
shown on the welcome screen 

ª  We only updated PTP, so we 
land back at C/C++ 
Perspective  
 

Install-15 Installation 

ª  Help>About or Eclipse > About Eclipse …  
will indicate the release of PTP installed 

ª  Further Help>Check for Updates will find future updates on 
the PTP Update site 



Exercise 

1.  Launch Eclipse and select the default 
workspace 

2.  Configure Eclipse to check for PTP updates 
3.  Update all PTP features to the latest level 
4.  Install the optional features of PTP, including 

TAU and GEM 
–  Selecting all features accomplishes 3. and 4. 

5.  Restart Eclipse once the installation is 
completed 
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Intro-0 Introduction 

Introduction 

ª Objective 
ª To introduce the Eclipse platform and PTP 

ª Contents 
ª New and Improved Features 
ª What is Eclipse?  
ª What is PTP? 



Intro-1 

What is Eclipse? 

ª A vendor-neutral open-source workbench for 
multi-language development 

ª A extensible platform for tool integration 
ª Plug-in based framework to create, integrate 

and utilize software tools 

Introduction 



Intro-2 

Eclipse Features 

ª Full development lifecycle support 
ª Revision control integration (CVS, SVN, Git) 
ª Project dependency management 
ª Incremental building 
ª Content assistance 
ª Context sensitive help 
ª Language sensitive searching 
ª Multi-language support 
ª Debugging 

Introduction 
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Parallel Tools Platform (PTP) 

ª  The Parallel Tools Platform aims to provide a highly 
integrated environment specifically designed for parallel 
application development 

ª  Features include: 
ª  An integrated development environment (IDE) that 

supports a wide range of parallel architectures and runtime 
systems 

ª  A scalable parallel debugger 
ª  Parallel programming tools  

(MPI, OpenMP, UPC, etc.) 
ª  Support for the integration  

of parallel tools 
ª  An environment that simplifies the  

end-user interaction with parallel systems 
ª  http://www.eclipse.org/ptp 

Introduction 



Eclipse PTP Family of Tools 
Coding & Analysis 

(C, C++, Fortran) 

Parallel Debugging 

Launching & 
Monitoring 

Performance Tuning 
(TAU, PPW, …) Intro-4 Introduction 



How Eclipse is Used 

Intro-5 

Remote 
Source 
Code 

Introduction 

Local 
Source 
Code 

Edit/Build 

Launch/Monitor 

Debugging 

Performance Tuning 



Eclipse Basics 
ª Objective 

ª Learn about basic Eclipse workbench concepts: 
projects,  

ª Learn about projects: local, synchronized, remote 

ª Contents 
ª Workbench components: Perspectives, Views, Editors 
ª Local, remote, and synchronized projects 
ª Learn how to create and manage a C project 
ª Learn about Eclipse editing features 

Eclipse Basics Basic-0 



Eclipse Basics 
ª  A workbench contains the menus, toolbars, editors and 

views that make up the main Eclipse window 

perspective Eclipse Basics 

view 
view 

view 

editor 

ª  The workbench represents 
the desktop development 
environment 
ª  Contains a set of tools  

for resource mgmt 
ª  Provides a common way 

of navigating through  
the resources 

ª  Multiple workbenches  
can be opened at the 
same time 

ª  Only one workbench can 
be open on a workspace 
at a time 

Basic-1 



Perspectives 

ª Perspectives define the layout of views and 
editors in the workbench 

ª They are task oriented, i.e. they contain 
specific views for doing certain tasks: 
ª C/C++ Perspective for manipulating compiled code  
ª Debug Perspective for debugging applications 
ª System Monitoring Perspective for monitoring 

jobs 
ª  You can easily switch between perspectives 
ª If you are on the Welcome screen now, select 
“Go to Workbench” now  

Eclipse Basics Basic-2 



Switching Perspectives 

ª  Three ways of changing  
perspectives 

1.  Choose the Window>Open  
Perspective menu option 
Then choose Other… 

2.  Click on the Open Perspective button in the 
upper right corner of  
screen (hover over it to 
see names) 

3.  Click on a  
perspective  
shortcut button 

Eclipse Basics Basic-3 



Which Perspective? 

Eclipse Basics Basic-4 

ª The current perspective is displayed in the title 
bar 



Views 

ª The workbench window is  
divided up into Views 

ª The main purpose of a view is: 
ª To provide alternative ways of presenting information 
ª For navigation 
ª For editing and modifying information  

ª Views can have their own menus and toolbars 
ª Items available in menus and toolbars are  

available only in that view 
ª Menu actions only  

apply to the view 
ª Views can be resized 

view 

view view 
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Stacked Views 

ª Stacked views appear as tabs 
ª Selecting a tab brings that view to the 

foreground 

Eclipse Basics Basic-6 



Expand a View 

ª Double-click on a view/editor’s tab to fill the 
workbench with its content;  

ª Repeat to return to original size 
 
 
 
 
 
 
 

ª Window > Reset Perspective 
returns everything to original positions 

Basic-7 Eclipse Basics 

Double 
click 

Double 
click 



Help 

ª  To access help 
ª  Help>Help Contents 
ª  Help>Search 
ª  Help>Dynamic Help 

ª  Help Contents provides 
detailed help on different 
Eclipse features in a 
browser 

ª  Search allows you to 
search for help locally, or 
using Google or the Eclipse 
web site 

ª  Dynamic Help shows help 
related to the current 
context (perspective, view, 
etc.) 

Eclipse Basics Basic-8 



Eclipse Preferences 
ª  Eclipse Preferences allow 

customization of almost 
everything 

ª  To open use 
ª  Mac: Eclipse>Preferences… 
ª  Others: 

Window>Preferences… 
 

ª  The C/C++ preferences 
allow many options to be 
altered 

ª  In this example you can 
adjust what happens in 
the editor as you type. 
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Preferences Example 
More C/C++ preferences: 
ª In this example the 

Code Style preferences 
are shown 

ª These allow code to be 
automatically  
formatted in different 
ways 
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Exercise 
1.  Change to a different perspective 
2.  Experiment with moving and resizing views 

ª  Move a view from a stack to beside another view 
ª  Expand a view to maximize it; return to original size 

3.  Save the perspective 
4.  Reset the perspective 
5.  Open Eclipse preferences 
6.  Search for “Launching” 
7.  Make sure the “Build (if required) before 

launching” setting is disabled 
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Optional Exercise 
Best performed after learning about projects, CVS, and editors 

1.  Use source code formatting to format a source file, or a region 
of a source file 
ª  Use Source>Format menu 

2.  In Eclipse Preferences, change the C/C++ source code style 
formatter, e.g.  
ª  Change the indentation from 4 to 6 
ª  Make line wrapping not take effect until a line has a 

maximum line width of 120, instead of the default 80 
ª  Save a (new) profile with these settings 
ª  Format a source file with these settings 

3.  Revert the file back to the original – experiment with 
ª  Replace with HEAD, replace with previous from local history, 

or reformat using original style 

Eclipse Basics Basic-12 



Creating a Synchronized Project 
ª Objective 

ª Learn how to create and use synchronized projects 
ª Learn how to create a sync project  

ª From a source code repository in CVS, or 
ª Import from source on a remote machine 

ª Contents 
ª Eclipse project types 
ª Creating a synchronized project from CVS or remote dir 
ª Using synchronize filters 
ª Remote Terminal view 
ª Converting an existing project to synchronized 

Synchronized Projects Sync-0 



Project Location 
ª Local 

ª Source is located on local machine, builds happen locally 
ª This is the default Eclipse model 

ª Synchronized 
ª Source is located on both local and remote machine(s), 

then kept in synchronization by Eclipse 
ª Building and launching happens remotely 

(can also happen locally) 
ª Used mainly for scientific and supercomputing 

applications 
ª There are also remote-only projects, but these 

have limitations and are not covered here 

Synchronized Projects Sync-1 



Sync-2 

Synchronized Projects 
ª  Projects types can be: 

-2 

File	  Service	   Index	  Service	  

Launch	  Service	  

Build	  Service	  

Debug	  Service	  

Local	  source	  
code	  

Source	  code	  
copy	  

Local	   Remote	  

Run	  

Debug
	  

Compute	  

Edit	   Search/Index	  
NavigaAon	  

Synchronize	  

Executable	  

Synchronized Projects 



Revision Control Systems (RCS) 
ª Eclipse supports a range of RCS, such as CVS, 

Git, and Subversion (and others) 
ª These are distinct from synchronized projects 
ª RCS can be used in conjunction with synchronized 

projects 
ª Synchronized projects are typically not used for 

revision control 

Synchronized Projects Sync-3 



Sync-4 

Synchronized Project Creation 

ª Local -> Remote 
ª Projects start out local then are synchronized to a 

remote machine 
ª Three options 

ª Created from scratch 
ª Imported from local filesystem 
ª Imported from source code repository 

ª Remote -> Local 
ª Projects start out on remote machine then are 

synchronized to the local system 
ª Two options 

ª Already on remote system 
ª Checked out from source code repository 

 
-4 Synchronized Projects 

A 

B 

slides 

slides 
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C, C++, and Fortran Projects 
Build types 

ª Makefile-based 
ª Project contains its own makefile (or makefiles) for 

building the application – or other build command 
ª Managed 

ª Eclipse manages the build process, no makefile 
required 
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SCENARIO A: 
Check out source 
code from CVS 

repository 

Sync-6 Synchronized 
Projects 

A 



ª  Switch to CVS Repository 
Exploring perspective 
ª  Window > Open Perspective > Other… 
ª  Select CVS Repository Exploring 
ª  Select OK 

 

ª  Right click in CVS Repositories 
view and select New>Repository 
Location… 

Importing a Project from CVS 

Sync-7 

A 

Synchronized Projects 



ª  Enter Host: cvs.ncsa.uiuc.edu 
ª  Repository path: 

/CVS/ptp-samples 
 

ª  For anonymous access: 
ª  User: anonymous 
ª  No password is required 
ª  Connection type: pserver (default) 

 

ª  For authorized access: 
ª  User: your userid 
ª  Password: your password 
ª  Connection type: change to extssh 

 

ª  Select Finish 
 

Add CVS Repository 

Sync 
-8 

A 

Synchronized Projects 



ª  Expand the repository location 
ª  Expand HEAD 
ª  Expand samples 
ª  Right click on shallow and select 

Check Out As… 
ª  On Check Out As dialog, select 

Finish 

Checking out the Project 

Sync 
-9 

The default of 
“Check out as a 
project configured 
using the New 
Project Wizard” is 
what we want 

A 

Synchronized Projects 



Next: New Project Wizard 
 

Sync-10 Synchronized Projects 

ª Expand Remote 
ª Select 

Synchronized  
C/C++ Project 

ª Select Next> 
 

ª If asked to select a 
tag, select HEAD 
and hit FINISH 

A 



SCENARIO B: 
Source code on 
remote machine 

Sync-11 

B 

Synchronized Projects 



Source Code for project 

ª Source code exists on remote target  
 

Sync-12 Synchronized Projects 
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Create Synchronized Project 

ª  In the Project Explorer, right click then choose 
ª  New>Synchronized C/C++ Project if your project is C/C++ only 

ª  New>Synchronized Fortran Project if your project contains Fortran 
files 

ª  This adds a Fortran nature so you can access Fortran properties, etc. 
 

Sync-13 Synchronized Projects 

Or via menus: 
File>New>Other… 
And under Remote, choose 
Synchronized C/C++ 
Project 

B 



Synchronized Projects Sync-14 

ª  Enter the Project Name 
ª  E.g. “shallow” 

ª  The Local Directory specifies 
where the local files are located 
ª  Leave as default 

ª  The Remote Directory specifies 
where the remote files are located 
ª  Select a connection to the remote 

machine, or click on New… to create 
a new one 
  (See next slide) 
 

ª  Use Modify File Filtering… if required 
(see later slide) 

New Synchronized Project Wizard 
B 
A 



Creating a Connection 

ª In the Target Environment Configuration 
dialog 
ª Enter a Target name  

for the remote host 
ª Enter host name, user name,  

and user password or  
other credentials 

ª Select Finish 

Sync-15 Synchronized Projects 

If your machine access requires 
ssh access through a frontend/
intermediate node, use 
localhost and port – see 
alternate instructions for  
ssh tunnel 



Remote Directory for Project 
ª  After the connection has been specified, 

Browse for the directory on the remote machine 
 
 
 
 
 
 
 
 
 

ª  Select directory if it exists, or enter a new directory name 
ª  Hit OK 

Synchronized Projects Sync-16 
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ª  Choose the Project Type 
ª  This tutorial’s code has its own makefile, 

so use  
Makefile Project>Empty Project 

ª  Otherwise, choose the type of project 
you want to create 

ª  Choose the toolchain for the remote 
build 
ª  Use a toolchain that most closely 

matches the remote system 

ª  Choose a toolchain for the local 
build 
ª  This is optional if you don’t plan to build 

on the local machine 
ª  This is used for advanced editing/

searching   

ª  Use Modify File Filtering… if 
required (see later slide) 

ª  Click Finish to create the project 

Project Type & Toolchain 

Synchronized Projects 



ª  If prompted, switch to the C/C++  
Perspective after creating the files 
 
 

ª  You should now see the “shallow” project in your 
workspace 
 

ª  Project is 
synchronized 
with remote 
host 

Project successfully created 

Sync-18 

Expand the 
project root 
to see the 
project’s 
contents 

Synchronized Projects 



Synchronized Project 

ª  Back in the Project 
Explorer, decorator on 
project icon indicates 
synchronized project 

ª  Double-+  icon 
 
 
 

ª  C Project w/o Sync 
 

ª  Synchronized Project 
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Synchronized Project Menu 
ª  Synchronized projects are indicated 

with a “synchronized” icon 
ª  Right click on project to access 

Synchronize menu 
ª  Sync Active Now will manually 

synchronize the active configuration 
ª  Set Active can be used to select the 

active configuration 
ª  Manage… is used to create new 

configurations to synchronize to 
different target systems 

ª  Sync All Now will manually 
synchronizes all configurations 

Sync-20 Synchronized Projects 

ª  Auto-Sync (Global) will enable or 
disable automatic synchronization 

ª  Auto-Sync Settings can be used to 
select which configurations will be 
synchronized 

ª  Filter… is used to change the filter 
settings for the project 



Manage Configurations 
ª  Used to manage synchronize 

configurations 
ª  Use Set Active to change the active 

configuration (shown in bold in the 
list of configurations) 

ª  Use Add to add a new configuration in 
order to synchronize to a different 
target system 

ª  Other configuration information, such 
as the default build configuration, can 
also be changed 

 

Sync-21 Synchronized Projects 

By default, there will be a configuration for the 
target system (active) and a Local configuration. 
The Local configuration can be used to build a 
local copy of the project if desired. 



Synchronize Filters 

ª If not all files in the remote project should be 
synchronized, a filter can be set up 
ª For example, it may not be desirable to synchronize 

binary files, or large data files 
ª Filters can be created at the same time as the 

project is created 
ª Click on the Modify File Filtering… button in the 

New Project wizard 
ª Filters can be added later 

ª Right click on the project and select 
Synchronization>Filter… 
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Synchronize Filter Dialog 

ª  Files can be filtered individually 
by selecting/unselecting them in 
the File View at the top 

ª  Include or exclude files based on 
paths and expressions 
 
 
 
 
 
 
 

ª  Suggestion: add filter for 
‘shallow’ so the executable, built 
on remote machine, doesn’t get 
synced back 
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Synchronized Project Properties 
ª  Synchronized configurations 

can also be managed through 
the project properties 

ª  Open the project properties 
by right-clicking on the 
project and selecting 
Properties 
ª  Select Synchronize 

ª  This is the same as using the 
Synchronize>Manage… 
menu 
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Forcing a Resync 
ª  If Auto-sync is set, the project 

should automatically resync with 
remote system when things 
change 

ª  Sometimes you may need to  
do it explicitly 

ª  Right click on project and select 
Synchronization>Sync Active 
Now 
 

ª  Status area in lower right shows 
when Synchronization occurs 
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Remote Terminal 
ª  There is a remote terminal that can be used to provide a 

shell from within Eclipse 
ª  If not in your workbench: 

ª  Select Window>Show View>Other… 
ª  Choose Terminal from the Terminal folder 

ª  In the Terminal view, click on the Connect button 
ª  It will use the previously configured connection from the 

dropdown, or create a new one 
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ª  If you need to change remote connection 
information (such as username or 
password), use the Remote 
Environments view  
 

Changing Remote Connection Information 

Sync-27 

ª  Stop the remote 
connection first 

ª  Right-click and 
select Edit ª  Note: Remote Host may be stopped 

ª  Any remote interaction starts it 
ª No need to restart it explicitly 

Synchronized Projects 



Converting a Local 
C/C++/Fortran Project 

 to a 
Synchronized Project 

 
The following slides are for reference.  

Our project is already a Synchronized Project. 

Sync-28 Synchronized Projects 



Converting To Synchronized 

If source files exist on the local machine and you wish to 
convert it to a Synchronized Project on a remote 
system… 

ª  Select File>New>Other… 
ª  Open the Remote folder 
ª  Select Convert to  

Synchronized Project 
ª  Click Next> 
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Convert Projects Wizard 
ª  For Project to convert 

ª  Choose your local project 
ª  For Connection name: click on 

New… 
ª  Unless you already have a connection 

ª  Enter information for: 
ª  Target name 
ª  Host name of remote system 
ª  User ID 
ª  Password 

ª  Click Finish to close it 
ª  The connection name will  

appear in the Connection 
list 
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Convert Projects Wizard (2) 
Back in the conversion wizard dialog, 

we specify where the remote files 
will be stored 

ª  Enter a directory name in the 
Remote Directory field:  
select Browse… 
ª  Sample: /u/ac/trainXX/shallow  

Typing a new directory name creates it 
ª  This should normally be an empty directory 

– since local files will be copied there 
ª  Project files will be copied under this 

directory 

ª  Click Finish 
ª  The project should synchronize 

automatically 
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Exercise 
1.  Create a synchronized project 

ª  Your login information and source directory will be 
provided by the tutorial instructor 

2.  Observe that the project files are copied to your 
workspace 

3.  Open a file in an editor, add a comment, and 
save the file 

4.  Observe that the file is synchronized when you 
save the file 
ª  Watch lower-right status area; confirm on host system 

Synchronized Projects Sync-32 



Optional Exercise 
1.  Modify Sync filters to not bring the *.o files and 

your executable back from the remote host  
ª  Rebuild and confirm the files don’t get copied 

Synchronized Projects Sync-33 



Eclipse CVS – “Team” Features 
ª Objective 

ª Learn how to use Eclipse source code repository 
features on your project 

ª Contents 
ª How the files look in the Project Explorer 
ª Handling changes 
ª Comparing files (diffs) 

 
ª This module assumes project was created in 

previous module 

CVS Source Code Repository CVS-0 



“Team” Features 

ª Eclipse supports integration with multiple 
version control systems (VCS) 
ª CVS, SVN, Git, and others 
ª Collectively known as “Team” services 

ª Many features are common across VCS 
ª Compare/merge 
ª History 
ª Check-in/check-out 

ª Some differences 
ª Version numbers 
ª Branching 

CVS-1 CVS Source Code 
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Two meanings for ‘Synchronize’ 

ª PTP’s synchronize 
ª Copy files in synchronized projects between local and 

remote to mirror them 
 

ª Team synchronize 
ª Show differences between local project and source 

code repository versions 

Basic-2 CVS Source Code 
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CVS Features 

ª Shows version numbers next to 
each resource 

ª Marks resources that have 
changed 
ª Can also change color (preference 

option) 
ª Context menu for Team 

operations 
ª Compare to latest, another 

branch, or history 
ª Synchronize* whole project (or 

any selected resources) 
CVS-3 CVS Source Code 

Repository 

* Team synchronize 



How to tell that you’ve 
changed something 

ª Open “calc.c” 
ª Add comment at line 40 
ª Save file 
ª File will be marked “>” 

to indicate that it has 
been modified 
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Comparing single file 
with what’s in the repository 

ª  Right-click on “calc.c” and 
select Compare 
With>Latest from HEAD 
ª  Even if you didn’t create project 

from CVS, you can try Compare 
With>Local History…  

ª  Compare editor will open 
showing differences 
between local (changed) 
file and the original 

ª  Buttons allow changes to 
be merged from right to 
left 

ª  Can also navigate between 
changes using buttons 
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Comparing your project 
with what’s in the repository 

ª  Right-click on project 
name (or any subset)  
and select 
Team>Synchronize 
with Repository 

ª  Team Synchronizing 
perspective will open 

ª  List of changed files 
appears 

ª  Double-click on a file to 
see the diff viewer 

ª  Buttons allow changes to 
be merged from right to 
left 

ª  Can also navigate between 
changes using buttons 
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Revert To The Latest Version  

To replace your project contents to the current 
contents of the project in the src code repo, 

ª Right-click on the “shallow” project 
… and select Replace With>Latest from HEAD 

ª Review the resources that will be replaced, 
then click OK 
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Exercise 
ª Check out the shallow project from CVS as a 

synchronized project - as described in this 
module 

CVS Source Code Repository CVS-8 

Optional Exercise 
1.  Name every person who modified the Makefile 
2.  Identify which parts of the Makefile changed 

since revision 1.3 
 

Hint: Right-click the Makefile and select Team > Show History.  
Both of these can be done from the History view. 



Editor Features 
ª Objective 

ª Learn about Eclipse editor features 

ª Contents 
ª Saving 
ª Editor markers 
ª Setting up include paths 
ª Code analysis 
ª Content assistance and templates 
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Editors 
ª  An editor for a resource (e.g. a file) opens when you  

double-click on a resource 
ª  The type of editor depends on the type of the resource 

ª  .c files are opened with the  
C/C++ editor by default 

ª  You can use Open With to  
use another editor 

ª  In this case the default 
editor is fine (double-click) 
 
 

ª  Some editors do not just edit raw text 
ª  When an editor opens on a resource, it stays open across 

different perspectives 
ª  An active editor contains menus and toolbars specific to that 

editor 
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Saving File in Editor 

ª When you change a file in the editor,  
an asterisk on the editor’s title bar 
indicates unsaved changes 
 
 
 

ª Save the changes by using  
Command/Ctrl-S or File>Save 
 

ª Undo last change using Command/Ctrl Z 
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Editor and Outline View 
ª  Double-click on 

source file  
ª  Editor will open in 

main view 

ª  Outline view is 
shown for file in 
editor 

ª  Console shows 
results of build, 
local runs, etc. 
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Source Code Editors & Markers 

ª  A source code editor is a 
special type of editor for 
manipulating source 
code 

ª  Language features are 
highlighted 

ª  Marker bars for showing 
ª  Breakpoints 
ª  Errors/warnings 
ª  Task Tags, Bookmarks 

ª  Location bar for 
navigating to interesting 
features in the entire file Icons: 
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Include Paths (1) 
ª  In order for editor and build features to work properly, Eclipse needs to know where 

your include files are located 
ª  The build environment on the remote host knows your include files etc., but we must 

tell Eclipse so that indexing, search, completion, etc. will know where things are 
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ª  Open Project Properties 
ª  Expand C/C++ General 
ª  Select Preprocessor 

Include Paths 
ª  Click GNU C, then CDT 

User Setting Entries, 
then click Add… 

ª  In upper right, select 
File System Path in 
pulldown 

ª  Check Contains System 
Headers 

ª   A UNC-style path specifies  
//<connection>/<path> 

ª  Enter Path 
//trestles/opt/openmpi/
gnu/ib/include 

ª  Select OK 
 

 
 

                 

                 



Include Paths (2) 

ª After adding include directory, it should 
appear in the list 

 
 
ª  Add second value: 

 
//trestles/usr/include 

... the same way 
 
 
 
You should have 
two entries: 
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Include Paths (3) 

ª Select OK 
ª The C/C++ Indexer should run 

ª Lower right status area indicates it 
 
 

ª If not force it via Project Properties>Index>Rebuild 
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Code Analysis (Codan) 
ª If you see bug icons in the editor marker bar, they 

are likely suggestions from Codan 
ª  If include files are set correctly, they should not appear. 

ª Code checkers can flag possible errors, even if 
code is technically correct 

ª To turn them off, use Preferences 
Window > Preferences or Mac: Eclipse > Preferences 
  C/C++ > Code Analysis  
and uncheck  
all problems 
 

ª  Select OK to 
close  
Preferences 

ª If icons don’t disappear: 
Right mouse on Project >  
Run C/C++ Code Analysis 
ª You can also enable/disable 
this per project in Project 
Properties Uncheck all Editor Features Editor-8 



Line Numbers 

ª  Text editors can show line numbers in the 
left column 

ª  To turn on line 
numbering: 
ª  Right-mouse click in 

the editor marker bar 
(at editor left edge) 

ª  Click on Show Line 
Numbers 
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ª  On demand hyperlink 
ª  In main.c line 135: 
ª  Hold down Command/Ctrl key 

e.g. on call to initialise 
ª  Click on initialise to navigate 

to its definition in the header file 
(Exact key combination  
depends on your OS) 

ª  E.g. Command/Ctrl and click on 
initialise 

ª  Open declaration 
ª  Right-click and select Open 

Declaration will also open the 
file in which the element is 
declared 

ª  E.g. in main.c line 29 right-click 
on decs.h and select Open 
Declaration 

Navigating to Other Files 

Note: may need to left-click 
before right-click works Editor Features Editor-10 



ª  Note: remote includes must be set up 
correctly for this to work 

ª  On demand hyperlink 
ª  In main.c line 73: 
ª  Ctrl-click on fprintf 
ª  stdio.h on remote system opens 

ª  Open declaration (or F3) 
ª  In main.c, right-click and select  

Open Declaration e.g on <stdio.h> 
ª  File from remote system is opened.  

ª  Hover over editor name tab to see remote 
location. 

Navigating to Remote Files 
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Content Assist & Templates 
ª  Type an incomplete function name e.g. “get” into the editor, 

and hit ctrl-space  
ª  Select desired completion value with cursor or mouse 

 

Hit ctrl-space again 
for code templates  ª  Code Templates: type 

‘for’ and Ctrl-space 
 

More info on code templates later 
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Hover Help 

ª Hover the mouse over a program element in 
the source file to see additional information 
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Inactive code 

ª Inactive code will appear grayed out in the 
CDT editor 
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Exercise 
1.  Open an editor by double clicking on a source file in the 

Project Explorer 
2.  Use the Outline View to navigate to a different line in 

the editor 
3.  Back in main.c, turn on line numbering 
4.  In main.c, ctrl-click on line 99, master_packet, should 

navigate to its definition in the file 
5.  In worker.c, line 132, hover over variable p to see info 
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Optional Exercise 
1.  Type “for”, then activate content assist 

ª  Select the for loop with temporary variable template, insert it, 
then modify the template variable 

ª  Surround the code you just inserted with “#if 0” and “#endif” and 
observe that it is marked as inactive 

ª  Save the file 
2.  What do these keys do in the editor? 

ª  Ctrl+L;  Ctrl+Shift+P  (do it near some brackets) 
ª  Ctrl+Shift+/;     
ª  Ctrl+Shift+Y  and Ctrl+Shift+X    (do it on a word or variable name 

e.g.) 
ª  Alt+Down; Alt+Up 

3.  To make sure you didn’t do any damage, 
ª  Select any source files you changed and do rightmouse > replace with ..  

ª  (if you made project from CVS) ….Latest from HEAD 
ª  (If you made project from remote files) … Local History …. 

ª  Observe that your changes are gone.   
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MPI Programming 
ª Objective 

ª Learn about MPI features for your source files 

ª Contents 
ª Using Editor features for MPI 
ª MPI Help features 
ª Finding MPI Artifacts 
ª MPI New Project Wizards 
ª MPI Barrier Analysis 

MPI Programming MPI-0 



MPI-Specific Features 

ª  PTP’s Parallel Language Development Tools (PLDT) has 
several features specifically for developing MPI code 
ª Show MPI Artifacts 
ª Code completion / Content Assist 
ª Context Sensitive Help for MPI 
ª Hover Help 
ª MPI Templates in the editor 
ª MPI Barrier Analysis 

 
ª PLDT has similar features for OpenMP, UPC, 

OpenSHMEM, OpenACC 
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ª In Project Explorer, select a project, folder, or a 
single source file 
ª  The analysis will be run on the selected resource(s) 

MPI-2 

Show MPI Artifacts 

-2 

ª  Run the analysis by 
clicking on drop-
down menu next to 
the analysis button 

ª  Select  Show MPI 
Artifacts 
 

MPI Programming 
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MPI Artifact View 
ª  Markers indicate the 

location of artifacts in 
editor 

ª  The MPI Artifact View 
lists the type and location 
of each artifact 

ª  Navigate to source code 
line by double-clicking on 
the artifact 

ª  Run the analysis on 
another file (or entire 
project!) and its markers 
will be added to the view 

ª  Click on column headings 
to sort  

ª  Remove markers via 

MPI-3 MPI Programming 
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MPI Editor Features 
ª  Code completion will show all 

the possible MPI keyword 
completions 

ª  Enter the start of a keyword 
then press <ctrl-space> 

-4 

ª  Hover over MPI API 
ª  Displays the function 

prototype and a 
description 

 

MPI Programming 
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Context Sensitive Help 
ª  Click mouse, then press help 

key when the cursor is within a 
function name 
ª  Windows: F1 key 
ª  Linux: ctrl-F1 key 
ª  MacOS X: Help key or 

Help�Dynamic Help 
ª  A help view appears (Related 

Topics) which shows 
additional information 
(You may need to click on MPI 
API in editor again, to 
populate) 

ª  Click on the function name to 
see more information 

ª  Move the help view within your 
Eclipse workbench, if you like, 
by dragging its title tab 

-5 

Some special 
info has been 
added for MPI 
APIs 

MPI Programming 
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MPI Templates 

ª Example:  
    MPI send-receive 

ª Enter:  
   mpisr <ctrl-space> 

ª Expands to a send-receive 
pattern 

ª Highlighted variable names 
can all be changed at once 

ª Type mpi <ctrl-space> <ctrl-
space> to see all templates 
 
 

Add more templates using Eclipse preferences! 
C/C++>Editor>Templates 
Extend to other common patterns 

-6 

ª Allows quick entry of common patterns in MPI programming 
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MPI Barrier Analysis 
ª  Verify barrier 

synchronization in C/MPI 
programs 

ª  For verified programs, lists 
barrier statements that 
synchronize together 
(match) 

ª  For synchronization errors, 
reports counter example 
that illustrates and 
explains the error  

MPI-7 

Local files only 
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MPI Barrier Analysis (2) 

MPI-8 

Run the Analysis: 
ª In the Project 

Explorer, select the 
project (or directory, 
or file) to analyze 
 
 

ª Select the MPI 
Barrier Analysis 
action in the pull-
down menu 
 

MPI Programming 



MPI Barrier Analysis (3) 

ª No Barrier Errors are found (no pop-up 
indicating error) 

ª Two barriers are found 
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MPI Barrier Analysis Views 

MPI Barriers view 

Simply lists the barriers 

Like MPI Artifacts view, 
double-click to navigate 
to source code line (all 
3 views) 

Barrier Matches view 
Groups barriers that 
match together in a 
barrier set – all 
processes must go 
through a barrier in the 
set to prevent a 
deadlock 

Barrier Errors view  

If there are errors, a 
counter-example 
shows paths with 
mismatched number 
of barriers  
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Barrier Errors 

ª Let’s cause a barrier mismatch error 
ª Open worker.c in the editor by double-clicking 

on it in Project Explorer 
ª At about line 125, 

enter a barrier: 
ª Type MPI_B 
ª Hit Ctl-space 
ª Select MPI_Barrier 
ª Add communicator 

arg MPI_COMM_WORLD   and closing semicolon 
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Barrier Errors (2) 

ª Save the file 
ª Ctl-S (Mac Command-S) or File > Save 
ª Tab should lose asterisk indicating file saved 

 
 
 
 

ª Run barrier analysis on shallow project again 
ª Select shallow 

project in Project 
Explorer first 
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Barrier Errors (3) 

ª Barrier Error is found 
ª Hit OK to dismiss dialog 

 
ª Code diverges on line 87 

ª One path has 2 barriers, other has 1 

MPI-13 

Double-click 
on a row in 
Barrier Errors 
view to find 
the line it 
references in 
the code 
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Fix Barrier Error 

ª Fix the Barrier Error  
before continuing 

ª Double-click on the 
barrier in worker.c 
to quickly navigate 
to it 

ª Remove the line and save the file 
ª Re-run the barrier analysis to check that it has 

been fixed 
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Remove Barrier Markers 

ª Run Barrier Analysis again to remove the error 
ª Remove the Barrier Markers via the “X” in one 

of the MPI Barrier views 
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MPI New Project Wizards 

ª Quick way to make a simple MPI project 
ª File > New > C Project 

 
ª “MPI Hello World” 

is good for trying out 
Eclipse for MPI 
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MPI New Project Wizards (2) 

ª Next> and fill in (optional) Basic Settings 
 

MPI-17 

ª Next> and fill in MPI Project 
                           Settings 
ª Include path set in MPI 
Preferences can be added to 
project 
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MPI New Project Wizards (3) 

ª Select Finish and “MPI Hello World” project 
is created 
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MPI Preferences 

ª Settings for MPI New Project wizards 
ª MPI Include paths, if set in MPI 

Preferences, are added in MPI New 
Project Wizard 
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Exercise 

1.  Find MPI artifacts in ‘shallow’ project 
ª  Locate all the MPI communication (send/receive) 

calls 
2.  Use content assist to add an api call 

ª  E.g., Type MPI_S, hit ctl-space 
3.  Use hover help 
4.  Use a template to add an MPI code template 

ª  On a new line, type mpisr and ctl-space… 
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Optional Exercise 

1.  Insert an MPI_Barrier function call into one of 
your source files using content assist 
ª  E.g. Line 125 of worker.c 

2.  Save the file 
3.  Run Barrier Analysis on the project 
4.  Locate the source of the barrier error and 

remove the statement 
5.  Re-run barrier analysis to observe that the 

problem has been fixed 
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Configuring SSH Tunnel 

Tunnel-0 SSH Tunnel 



Configure the  
Synchronized Project - 

SSH tunnel (1) 

SSH Tunnel Tunnel-1 

ª  If your machine access requires ssh access through a frontend/
intermediate node, set up an ssh tunnel before configuring the 
project - from command line or e.g. Windows PuTTY, e.g. 
ssh   -L  <port>:<target-host> <userid>@<frontend-host> 
(For details see http://wiki.eclipse.org/PTP/FAQ) 

 
ª  When you configure the connection for the project  

ª  Connection: New… 
 

ª  The connection will use 
the port for the ssh tunnel 
(details on next slide) 



Configure connection to  
remote host – SSH Tunnel (2) 

SSH Tunnel Tunnel-2 

ª  In Target Environment Configuration 
dialog, enter target name,  
and host information 
ª  1. Specify Target name  
ª  2. If using a tunnel, select 

Localhost and enter userid and 
password for remote system 
ª  For direct access, just 

select Remote Host, enter 
hostname, userid, password 

ª  3. select the Advanced button 
to specify the port 

ª  Select Finish 

2. 

Specify port for tunnel 

1. 

3. 



Building a Project 

ª Objective 
ª Learn how to build an MPI program on a remote 

system 
ª Contents 

ª How to change build settings  
ª How to start a build and view build output 
ª How to clean and rebuild a project 
ª How to do environment configuration with modules 
ª How to create build targets 

Build-0 Building a Project 



Build Configurations 
ª  A build configuration provides the 

necessary information to build the 
project 

ª  The build configuration 
information is specified in the 
project properties 

ª  Projects can have multiple build 
configurations, each configuration 
specifies a different set of options 
for a build 

ª  Open the properties by right-
clicking on the project name in the 
Project Explorer view and 
selecting Properties (bottom of 
the context menu list) 

Build-1 Building a Project 

Note: Fortran projects are a superset of 
C/C++ projects, so they have properties 
for both 



Build Properties (1) 

Build-2 Building a Project 

ª  C/C++ Build 
ª  Main properties page 
ª  Configure the build command 
ª  Default is “make” but this can be changed to 

anything 
ª  Build Variables 

ª  Create/manage variables that can be used in other 
build configuration pages 

ª  Environment 
ª  Modify/add environment variables passed to build 

ª  Logging 
ª  Enable/disable build logging 



Build Properties (2) 

Build-3 Building a Project 

ª  Settings 
ª  Binary parser selection (used to display binaries in 

Project Explorer) 
ª  Error parser selection (used to parse the output from 

compiler commands) 
ª  Tool Chain settings (managed projects only) 

ª  Tool Chain Editor 
ª  Allows the tools in a particular tool chain to be 

modified 
ª  XL C/C++ Compiler 

ª  Compiler settings for XL C/C++ compilers (if installed) 
 

ª  C/C++ General/Preprocessor Include Paths… 
ª  Set include paths here 



Selecting Build Configuration 

ª  Multiple build configurations may be available 
ª  Synchronized projects will usually have a remote and a local build configuration 
ª  Build configurations for different architectures 

ª  The active build configuration will be used when the build button 
is selected 

ª  The Build Configurations project context menu can be used to 
change the active configuration 
ª  Right click on project, then select the build configuration from the Build 

Configurations > Set Active menu  
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Building Synchronized Projects 
ª  When the build button is selected, the 

“active” build configuration will be built 
on the remote system specified by the 
“active” synchronize configuration 

ª  The build and synchronize configurations 
are independent 
ª  It is possible to change which build 

configuration is active, but make sure this 
makes sense on the remote system specified in 
the synchronize configuration  

ª  Right mouse on Project,  
Synchronize > Manage… 

ª  A build configuration can be associated 
with a synchronize configuration, so that 
it is automatically selected when the 
synchronize configuration is changed 
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Configuring the Build Environment 
ª  If the remote system has an 

environment system (such as 
Modules) installed, a custom 
set of modules can be 
configured for building C/C++ 
projects 

ª  In the Manage Synchronize 
Configurations dialog, select 
the configuration you wish to 
change 

ª  Check Use an environment 
management system to 
customize the remote build 
environment 
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Build Environment (2) 
ª  Select a module from the 

Available Modules list and 
click the Add-> button to add 
them to the Selected 
Modules list 

ª  Use the <-Remove button to 
remove modules from the 
Selected Modules list 

ª  Use the Filter list field to 
quickly find modules with a 
given name 

ª  Use the Up and Down 
buttons to change the order of 
the Selected Modules 

ª  Click Select Defaults to load 
only those modules that are 
present in a new login shell 

 
Build-7 Building a Project 

We’ll do this for tutorial in a few slides… 



Build Environment (3) 

ª  When you build the project, Eclipse will 
ª  Open a new Bash login shell 
ª  Execute module purge 
ª  Execute module load for each selected module 
ª  Run make 

ª  Module commands are displayed in the Console view during build 
ª  Beware of modules that must be loaded in a particular order, or 

that contain common paths like /bin or /usr/bin 
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Build Environment (4) 
ª  For this tutorial, we 

want to use gcc and 
Open MPI 

ª  To get to this dialog: Right 
mouse on Project, 
Synchronize > Manage… 

ª  Navigate to gnu in 
Available Modules 
and select Add -> 

ª  Navigate to 
openmpi_ib and 
select Add -> 

ª  Assure the 
order matches this 
ª  If not, use Up/Down 

buttons 
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Start with original‘shallow’ 

ª Start with original ‘shallow’ code: 
ª Project checked out from CVS: 

ª Right mouse on project,   
Replace with > Latest from HEAD 
 
 
 
Also see Compare With … 

ª Other project: 
ª Right mouse on project, 

Restore from local history – finds deleted files 
ª Right mouse on file, Compare With  

or Replace With 

Build-10 Building a Project 

Changed file: 



Starting the Build 
ª  Select the project in Project Explorer 

ª  Click on the     hammer button in toolbar to run a build 
using the active build configuration 
 
 
 
 

ª  By default, the Build Configuration assumes there is a 
Makefile (or makefile) for the project 
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ª  Build output will be visible in console 

Viewing the Build Output 

Build-12 Building a Project 



Build Problems 

ª  Build problems will be 
shown in a variety of 
ways 
ª  Marker on file 
ª  Marker on editor line 
ª  Line is highlighted 
ª  Marker on overview ruler 
ª  Listed in the Problems 

view  
 

ª  Double-click on line in 
Problems view to go 
to location of error in 
the editor 
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Forcing a Rebuild 
ª  If no changes have been made,  

make doesn’t think a build is needed 
e.g. if you only change the Makefile 
 

ª  In Project Explorer, right click on 
project; Select Clean Project 
 

ª  Build console will display results 
 

 
 

ª  Rebuild project by clicking on  
build button again 
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Forcing a Resync 
ª  Project should resync with remote 

system when things change 
ª  Sometimes you may need to  

do it explicitly 
ª  Right mouse on project, 

Synchronize>Sync Active Now 
 

ª  Status area in lower right shows 
when Synchronization occurs 
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ª  By default 
ª  The build button will run “make all” 
ª  Cleaning a project will run “make clean” 

ª  Sometimes, other build targets are 
required 

ª  Open Make Target view 
ª  Select project and click on New 

Make Target button 
ª  Enter new target name 
ª  Modify build command if desired 
ª  New target will appear in view 
ª  Double click on target to activate 

Creating Make Targets 
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Exercise 

1.  Start with your ‘shallow’ project 
2.  Build the project 
3.  Edit a source file and introduce a compile error 

ª  In main.c, line 97, change ‘;’ to ‘:’ 
ª  Save, rebuild, and watch the Console view 
ª  Use the Problems view to locate the error 
ª  Locate the error in the source code by double 

clicking on the error in the Problems view 
ª  Fix the error 

4.  Rebuild the project and verify there are no build errors 

Building a Project 
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Optional Exercise 

1.  Open the Makefile in Eclipse.  Note the line starting with 
“tags:” – this defines a make target named tags. 

2.  Open the Outline view while the Makefile is open.  What icon 
is used to denote make targets in the Outline? 

3.  Right-click the tags entry in the Outline view.  Add a Make 
Target for tags. 

4.  Open the Make Target view, and build the tags target. 
 
 

5.  Rename Makefile to Makefile.mk 
6.  Attempt to build the project; it will fail 
7.  In the project properties (under the C/C++ Build category), 

change the build command to:  make –f Makefile.mk 
8.  Build the project; it should succeed 

Building a Project 



Running an Application 
ª Objective 

ª Learn how to run an MPI program on a remote system 

ª Contents 
ª Creating a run configuration 
ª Configuring the application run 
ª Monitoring the system and jobs 
ª Controlling jobs 
ª Obtaining job output 
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Run-2 

ª  Open the run configuration  
dialog Run>Run 
Configurations… 

ª  Select Parallel Application 
ª  Select the New button 

 
Or, just double-click on  
Parallel Application 
to create a new one  

Creating a Run Configuration 

Note: We use “Launch Configuration” as a generic term to refer to either a 
“Run Configuration” or a “Debug Configuration”, which is used for debugging. 

Running an Application 
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Set Run Configuration Name 
ª  Enter a name for this run configuration 

ª  E.g. “shallow” 

ª  This allows you to easily re-run the 
same application 

ª  If the “shallow” project was selected 
when the dialog was opened, its name 
will be automatically entered 
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Configuring the Target System 
ª  In Resources tab, select a 

Target System Configuration 
that corresponds to your target 
system 
ª  Use edu.sdsc.trestles.torque.batch 

ª  Target system configurations can 
be generic or can be specific to a 
particular system 

ª  Use the specific configuration if 
available, or the generic 
configuration that most closely 
matches your system 

ª  You can type text in the box to 
filter the configurations in the 
list 
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Configure the Connection 
ª  Choose a connection to 

use to communicate with 
the target system 

ª  If no connection has been 
configured, click on the 
New button to create a 
new one 
ª  Fill in connection information, 

then click ok 

ª  The new connection 
should appear in the 
dropdown list 

ª  Select the connection you 
already have to 
trestles.sdsc.edu 

ª  Select toggle if you don’t 
want to see popup again 
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Resources Tab 
ª  The content of the 

Resources tab will vary 
depending on the target 
system configuration 
selected  

ª  This example shows the 
TORQUE configuration 

ª  For TORQUE, you will 
normally need to select 
the Queue and the 
Number of nodes 

ª  For parallel jobs, choose 
the MPI Command and 
the MPI Number of 
Processes 
 
See next slide 
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Resources Tab (2) 
ª  For this tutorial, use the following values 

ª  Queue: shared 
ª  Number of nodes: 1:ppn=5 
ª  MPI Command: mpirun 
ª  MPI Number of Processes: 5 
ª  Leave other fields alone 
 

ª  Configure modules for running the application 
ª  Click on the Modules to Load: Configure… button 
ª  Select the same modules used to build 

ª  gnu 
ª  openmpi_ib 
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Viewing the Job Script 
ª  Some target 

configurations will 
provide a View Script  
button 

ª  Click on this to view the 
job script that will be 
submitted to the job 
scheduler 

ª  Batch scheduler 
configurations should 
also provide a means of 
importing a batch script 
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Application Tab 

ª  Select the Application tab 
ª  Choose the Application 

program by clicking the 
Browse button and locating 
the executable on the remote 
machine  
ª  Use the same “shallow” 

executable 
ª  Select Display output from 

all processes in a console 
view 
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Arguments Tab (Optional) 
ª  The Arguments tab lets 

you supply command-line 
arguments to the 
application  

ª  You can also change the 
default working directory 
when the application 
executes 
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Environment Tab (Optional) 
ª  The Environment tab 

lets you set environment 
variables that are passed 
to the job submission 
command 

ª  This is independent of the 
Environment Management 
(module/softenv) support 
described on previous 
slide 
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Synchronize Tab (Optional) 
ª  The Synchronize tab lets 

you specify upload/
download rules that are 
execute prior to, and after 
the job execution 

ª  Click on the New 
upload/download rule 
buttons to define rules 

ª  The rule defines which file 
will be uploaded/
downloaded and where it 
will be put 

ª  Can be used in 
conjunction with program 
arguments to supply input 
data to the application 
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Common Tab (Optional) 
ª  The Common tab is 

available for most launch 
configuration types (not 
just Parallel Application) 

ª  Allows the launch 
configuration to be 
exported to an external 
file 

ª  Can add the launch 
configuration to the 
favorites menu, which is 
available on the main 
Eclipse toolbar 
 
 

ª  Select Run to launch 
the job 
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Run 

ª Select Run to launch the job 
ª You may be asked to switch to the System 

Monitoring Perspective 
 
 
 
 
 

ª Select Remember my decision so you 
won’t be asked again 

ª Select Yes to switch and launch the job 
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System Monitoring Perspective 
ª  System view 
 
ª  Jobs running 

on system 
 
ª  Active jobs 
 
ª  Inactive jobs 
 
 
ª  Messages 
 
 
ª  Console  
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Moving views 

ª The System Monitoring Perspective overlaps 
the Active Jobs and Inactive Jobs views 

ª To split them apart and see both at once,  
drag the tab for the Inactive Jobs view to 
the lower half of its area, and let go of mouse 
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System Monitoring 

ª  System view, with 
abstraction of system 
configuration 
 

ª  Hold mouse button 
down on a job in 
Active Jobs view to 
see where it is 
running in System 
view 

 
ª  Hover over node in 

System view to see 
job running on node 
in Active Jobs view 
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One node with 
16 cores 
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ª  Job initially appears in 

Inactive Jobs view 
ª  Moves to the Active Jobs 

view when execution begings 
ª  Returns to Inactive Jobs 

view on completion 
ª  Status refreshes  

automatically every 60 sec 
ª  Can force refresh with menu 
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ª  Right click on a job to open 
context menu 

ª  Actions will be enabled IFF 
ª  The job belongs to you 
ª  The action is available on the 

target system 
ª  The job is in the correct state for 

the action 
 

ª  When job has COMPLETED, it 
will remain in the Inactive 
Jobs view 
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ª  After status changes to 

COMPLETED, the output is 
available 
ª  Right-click on the job  
ª  Select Get Job Output to display 

output sent to standard output 
ª  Select Get Job Error to retrieve 

output sent to standard error 
 

ª  Output/Error info shows in 
Console View 
 

ª  Jobs can be removed by 
selecting Remove Job Entry 
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Obtaining Job Output 



Add a Monitor 

ª You can monitor other systems too 
ª In Monitors view, select the ‘+’ button to 

add a monitor 
 
 
 

ª Choose monitor type and connection; 
create a new connection if necessary 
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Double click 
new monitor 
to start 
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Exercise 

1.  Start with your ‘shallow’ project 
2.  Create a run configuration 
3.  Complete the Resources tab 
4.  Select the executable in the Application tab 
5.  Submit the job 
6.  Check the job is visible in the Inactive Jobs view, 

moves to the Active Jobs view when it starts running 
(although it may be too quick to show up there), then 
moves back to the Inactive Jobs view when completed 

7.  View the job output 
8.  Remove the job from the Inactive Jobs view 
 

Running an Application 



Fortran 
ª Objectives 

ª Learn how to create and convert Fortran projects 
ª Learn to use Fortran-specific editing features 
ª Learn about Fortran-specific properties/preferences 

ª Contents 
ª Fortran projects 
ª Using the Fortran editor 
ª Fortran project properties and workbench preferences 

ª Prerequisites 
ª Basics (for exercises) 
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Ralph Johnson’s research group at UIUC used to meet at Pho-Tran… 



…which became the name of their Fortran IDE. 



Configuring Fortran Projects 
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Project Properties 

ª  Right-click Project 
ª  Select Properties… 

 

ª Project properties are settings 
that can be changed for each 
project 

ª  Contrast with 
workspace preferences, 
which are the same 
regardless of what 
project is being edited 
ª  e.g., editor colors 
ª  Set in Window� 

Preferences 
(on Mac, Eclipse� 
Preferences) 

ª  Careful! Dialog is 
very similar 
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Converting to a Fortran Project 

ª Are there categories labeled Fortran General 
and Fortran Build in the project properties? 

No Fortran categories 

ª If not, the project is not a Fortran Project 
ª Switch to the Fortran Perspective 
ª In the Fortran Projects view, right-click on the 

project, and click Convert to Fortran Project 
ª Don’t worry; it’s still a C/C++ project, too 

ª Every Fortran project is also a C/C++ Project 

Do this 
once 
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Project Location 

ª  How to tell where a project 
resides? 

ª  In the project properties 
dialog, select the 
Resource category 
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Error Parsers 

ª Are compiler errors not appearing in the 
Problems view? 
ª Make sure the correct error parser is enabled 
ª In the project properties, navigate to 

C++ Build�Settings or Fortran Build�Settings 
ª Switch to the Error Parsers tab 
ª Check the error parser(s) for your compiler(s) 
 

Do this 
once 
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Fortran Source Form Settings 
ª Fortran files are either free form or fixed form; 

some Fortran files are preprocessed (#define, #ifdef, etc.) 
 
ª  Source form determined by filename extension 
ª  Defaults are similar to most Fortran compilers: 

   

    Fixed form:  .f  .fix  .for  .fpp  .ftn  .f77 
   

    Free form:  .f08  .f03  .f95  .f90   < unpreprocessed 
 .F08  .F03  .F95  .F90   < preprocessed 

     

ª Many features will not work if filename extensions 
are associated with the wrong source form 
(outline view, content assist, search, refactorings, etc.) 
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Fortran Source Form Settings 

ª  In the project 
properties, select 
Fortran General� 
Source Form   

ª  Select source form 
for each filename 
extension 

ª  Click OK 

Do this 
once 
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Enabling Fortran Advanced Features 

ª Some Fortran features are disabled by default  
ª Must be explicitly enabled 

ª In the project properties dialog, 
select Fortran General � Analysis/Refactoring 

ª Click Enable 
Analysis/ 
Refactoring 

ª Close and re-open 
any Fortran editors 

ª This turns on the 
“Photran Indexer” 
ª Turn it off if it’s slow 

Do this 
once 
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Exercise 

1.  Convert shallow to a Fortran project 

2.  Make sure errors from the GNU Fortran 
compiler will be recognized 

3.  Make sure *.f90 files are treated as 
“Free Form” which is unpreprocessed 

4.  Make sure search and refactoring will work in 
Fortran 
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Advanced Editing 
 

Code Templates 
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Code Templates 
(C/C++ and Fortran) 

ª Auto-complete common code patterns 
ª For loops/do loops, if constructs, etc. 
ª Also MPI code templates 

 
ª Included with content assist proposals 

(when Ctrl-Space is pressed) 
ª E.g., after the last line in tstep.f90, type “sub” and  

press Ctrl-Space 
ª Press Enter to insert the template 
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Code Templates (2) 
(C/C++ and Fortran) 

ª After pressing enter to insert the code 
template, completion fields are highlighted 
 
 
 
 
 
 

ª Press Tab to move between completion fields 
ª Changing one instance of a field changes all 

occurrences 
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Exercise 

ª  Open tstep.f90 and retype the last loop nest 
ª  Use the code template to complete the do-loops 

ª  Use content assist to complete variable names 
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Custom Code Templates 
(Fortran) 

ª Customize code templates in Window �  
Preferences � Fortran � Templates 

ª Can import/export templates to XML files 
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Search & Refactoring 
ª Objectives 

ª Develop proficiency using Eclipse’s textual and 
language-based search and navigation capabilities 

ª Introduce common automated refactorings 

ª Contents 
ª Searching 
ª Refactoring and Transformation 

ª Prerequisites 
ª Basics 
ª Fortran 
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Find/Replace within Editor 

ª Simple Find within editor buffer 
ª Ctrl-F (Mac: Command-F) 
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Mark Occurrences 
(C/C++ Only) 

ª Double-click on a variable in the CDT editor 
ª All occurrences in the source file are 

highlighted to make locating the variable 
easier 

ª Alt-shift-O to turn off (Mac: Alt-Cmd-O) 
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Language-Based Searching 
(C/C++ and Fortran) 

Advanced-3 Advanced Features 

ª  “Knows” what things can 
be declared in each 
language (functions, 
variables, classes, 
modules, etc.) 

ª  E.g., search for every call 
to a function whose name 
starts with “get” 
   

ª  Search can be project- or 
workspace-wide 



Find References 
(C/C++ and Fortran) 

ª Finds all of the places where a variable, 
function, etc., is used 
ª Right-click on an identifier in the editor 
ª Click References�Workspace 

or References�Project 
 
 
 

ª Search view 
shows matches 
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Open Declaration 
(C/C++ and Fortran) 

ª  Jumps to the declaration of 
a variable, function, etc., 
even if it’s in a different 
file 
 

ª  Left-click to select identifier 
ª  Right-click on identifier 
ª  Click Open Declaration 

 
ª  C/C++ only: 

Can also Ctrl-click  
(Mac: Cmd-click) on an 
identifier to “hyperlink” to 
its declaration 
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Goes to its declaration 
in copy.c 



Search – Try It! 

1.  Find every call to MPI_Recv in Shallow. 

2.  In worker.c, on line 42, there is a declaration 
float p[n][m]. 
a)  What is m (local? global? function parameter?) 

b)  Where is m defined? 

c)  How many times is m used in the project? 

3.  Find every C function in Shallow whose name 
contains the word time 
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Refactoring and Transformation 
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Refactoring 

ª  39 automated refactorings in Photran 

(making changes to source code that don’t affect the behavior of the program) 
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Refactoring Caveats 

ª Photran can only refactor free form code that 
is not preprocessed 
ª Determined by Source Form settings 

(recall from earlier that these are configured in  
Project Properties: Fortran General�Source Form) 

Advanced-9 Advanced Features 

ª Refactor menu will be empty if 
ª  Refactoring not enabled in project properties 

(recall from earlier that it is enabled in  
Project Properties: Fortran General�Analysis/Refactoring) 

ª  The file in the active editor is fixed form 
ª  The file in the active editor is preprocessed 

✔ Free Form, Unpreprocessed: .f08 .f03 .f95 .f90 

✖ Free Form, Preprocessed: .F08 .F03 .F95 .F90 

✖ Fixed Form: .f .fix .for .fpp .ftn .f77 



Rename Refactoring 
(also available in Fortran) 

ª Changes the name of a variable, function, etc., 
including every use 
(change is semantic, not textual, and can be workspace-wide) 
   

ª Only proceeds if the new name will be legal 
(aware of scoping rules, namespaces, etc.) 

ª Switch to C/C++ Perspective 
ª Open a source file 
ª In the editor, click on a 

variable or function name 
ª Select menu item 

Refactor�Rename 
ª Or use context menu 

ª Enter new name 
Advanced-10 Advanced Features 

In Java (Murphy-Hill et al., ICSE 2008): 



Rename in File 
(C/C++ Only) 
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ª  Position the caret 
over an identifier. 

ª  Press Ctrl-1 
(Command-1 on Mac). 

ª  Enter a new name.  
Changes are 
propagated within 
the file as you type. 



ª  Moves statements into a new function, replacing the 
statements with a call to that function 

ª  Local variables are passed as arguments 

Extract Function Refactoring 

ª  Select a sequence of 
statements 

ª  Select menu item 
Refactor� 
Extract Function… 

ª  Enter new name 

(also available in Fortran - “Extract Procedure”) 
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ª  Fortran does not require variable declarations 
(by default, names starting with I-N are integer variables; others are reals) 

ª  This adds an IMPLICIT NONE statement and adds explicit 
variable declarations for all implicitly declared variables 

Introduce IMPLICIT NONE Refactoring 

ª  Introduce in a single file by 
opening the file and selecting 
Refactor�Coding Style� 
Introduce IMPLICIT NONE… 

ª  Introduce in multiple files by 
selecting them in the Fortran 
Projects view, right-clicking on 
the selection, and choosing 
Refactor�Coding 
Style�Introduce IMPLICIT 
NONE… 
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ª  Interchange Loops   CAUTION: No check for behavior preservation 

ª  Swaps the loop headers in a two-loop nest 
ª  Select the loop nest, click menu item Refactor�Do Loop�  

Interchange Loops (Unchecked)…  

Loop Transformations 
(Fortran only) 

Advanced-14 Advanced Features 

Old version traverses 
matrices in row-major order 

New version traverses 
in column-major order 
(better cache performance) 



Loop Transformations 
(Fortran only) 
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ª  Unroll Loop 
ª  Select a loop, click Refactor�Do Loop�Unroll Loop…  

do i = 1, 10 
  print *, 10*i 
end do 

do i = 1, 10, 4 
  print *, 10*i 
  print *, 10*(i+1) 
  print *, 10*(i+2) 
  print *, 10*(i+3) 
end do 

Unroll 4× 



Refactoring & Transformation – 
Exercises 

In tstep.f90… 

1.  In init.c, extract the printf statements at 
the bottom of the file into a new function 
called print_banner 

2.  In worker.c, change the spellings of 
neighbour_send and neighbour_receive 
to American English 

3.  In tstep.f90, make the (Fortran) tstep 
subroutine IMPLICIT NONE 

Advanced-16 Advanced Features 



NCSA/XSEDE Features 
ª Objectives 

ª Install NCSA’s GSI auth and XSEDE support plug-ins 
ª Become familiar with the System menu 

ª Contents 
ª Capabilities 
ª Installation 

ª Prerequisites 
ª (none) 

Advanced Features: NCSA/XSEDE  NCSA-0 



Additional Plug-ins from NCSA 

ª NCSA publishes additional plug-ins can be 
added onto an existing PTP installation 

ª Contribute a System menu to the menu bar 
with XSEDE- and NCSA-specific commands 
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System Menu 

ª  Open Web content in Eclipse: 
 
ª  Open XSEDE User Portal 

 
ª  Open User Guide for a machine 

 
 

ª  Open an SSH terminal 
(as an Eclipse view) 

NCSA-2 Advanced Features: NCSA/XSEDE  

Eclipse-integrated SSH terminals are provided 
by the Remote System Explorer (RSE), one of 
the features that is included in the Eclipse for 
Parallel Application Developers package. 



System Menu 

ª  Shortcuts for common PTP tasks: 
 
ª  Add Remote Environment adds a 

Remote Tools connection for a 
particular machine 
 

ª  Add System Monitor opens the 
System Monitoring perspective and 
begins monitoring a particular 
machine 
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System Menu 

ª  The plug-in is preconfigured with 
information about XSEDE and 
NCSA resources 
 

ª  The bottom four commands 
generally prompt for a system 
 

ª  Select System can be used to 
eliminate this prompt, so these 
commands always act on a 
particular system 
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MyProxy Logon 

ª  MyProxy Logon allows you 
to authenticate with a 
MyProxy server 
ª  Often myproxy.teragrid.org 

ª  It stores a “credential,” which 
is usually valid for 12 hours 

ª  During these 12 hours, SSH 
connections to XSEDE 
resources will not require a 
password; they can use the 
stored credential 
ª  However, you must enter the 

correct username for that 
machine! 
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Installation 

1.  Click Help > Install New Software 
2.  Click Add to open the Add Repository dialog 
3.  In the Location field, enter 

 

     http://forecaster.ncsa.uiuc.edu/updates/kepler 
 

and then click OK to close the Add dialog. 
§  Or, if you copied ncsa-update-size.zip from a USB 

drive, click Archive, select that file, and click OK. 
4.  Select the following: 

ª GSI Authentication and MyProxy Logon Support 
ª NCSA and XSEDE System Support 

5.  Click Next and complete the installation 
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Parallel Debugging 

Parallel Debugging 

ª Objective 
ª Learn the basics of debugging parallel programs 

ª Contents 
ª Launching a debug session 
ª The Parallel Debug Perspective 
ª Controlling sets of processes 
ª Controlling individual processes 
ª Parallel Breakpoints 
ª Terminating processes 
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Debugging Setup 

ª  Debugging requires interactive access to the application 
ª  Can use any of the -Interactive target configurations 

ª  Torque-Generic-Interactive 
ª  PBS-Generic-Interactive 
ª  OpenMPI-Generic-Interactive 
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Create a Debug Configuration 
ª  A debug configuration is 

essentially the same as a run 
configuration (like we used 
in the Running an Application 
module) 

ª  It is possible to re-use an 
existing configuration and 
add debug information 

ª  Use the drop-down next to 
the debug button (bug icon) 
instead of run button 

ª  Select Debug 
Configurations… to open 
the Debug Configurations 
dialog 

Parallel Debugging Debug-2 



Create a New Configuration 

ª  Select the existing 
configuration 

ª  Click on the new button to 
create a new configuration 
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Configure the Resources Tab 

ª  Select the new 
target system 
configuration 

ª  Choose the queue 
ª  Make sure number of 

nodes is correct 
ª  Make sure the 

mpirun command is 
selected 

ª  Select the number of 
processes (in this 
case use 5) 

ª  Configure modules if 
required 
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Configure the Application Tab (Optional) 

ª  Select Application tab 
ª  Make sure the Project is 

correct 
ª  Select the application 

executable 
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Configure the Debug Tab (Optional) 

ª  Select Debugger tab 
ª  Debugger will stop at 

main() by default 
ª  By default the built-in 

SDM will be used 
ª  Override this if you want to 

use your own SDM 

 
ª  Click on Debug to launch 

the program 
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Exercise 

1.  Open the debug configuration dialog 
2.  Create a new configuration 
3.  Select the edu.sdsc.trestles.torque.interactive.openmpi 

target configuration 
4.  Configure the Debug tab 

ª  Queue: shared 
ª  Number of nodes: 1:ppn=5 
ª  MPI Command: mpirun 
ª  MPI Number of Processes: 5 

5.  Launch the debugger 
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ª  Parallel Debug 
view shows job 
and processes 
being debugged 
 

ª  Debug view shows 
threads and call 
stack for individual 
processes 

ª  Source view 
shows a current 
line marker for all 
processes 

The Parallel Debug Perspective (1) 
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The Parallel Debug Perspective (2) 
 
ª  Breakpoints view 

shows breakpoints 
that have been set 
(more on this later) 

ª  Variables view 
shows the current 
values of variables 
for the currently 
selected process in 
the Debug view  

ª  Outline view (from 
CDT) of source 
code 
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Stepping All Processes 
ª  The buttons in the 

Parallel Debug View 
control groups of 
processes 

ª  The Step Over button 
will step all processes 
one line 

ª  The process icons will 
change to green 
(running), then back to 
yellow (suspended) 

ª  Yhe current line marker 
will move to the next 
source line 
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Stepping An Individual Process 
ª  The buttons in the 

Debug view are used 
to control an 
individual process, in 
this case process 0 

ª  The Step Over button 
will control just the 
one process 

ª  There are now two 
current line markers, 
the first shows the 
position of process 0, 
the second shows the 
positions of processes 
1-4 
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Process Sets (1) 

ª  Traditional debuggers apply operations to a single 
process 

ª  Parallel debugging operations apply to a single process 
or to arbitrary collections of processes  

ª  A process set is a means of simultaneously referring to 
one or more processes 
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Process Sets (2) 

ª  When a parallel debug session is first started, all 
processes are placed in a set, called the Root set  

ª  Sets are always associated with a single job 
ª  A job can have any number of process sets 
ª  A set can contain from 1 to the number of processes in 

a job 
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Operations On Process Sets 
ª  Debug operations on the 

Parallel Debug view 
toolbar always apply to the 
current set: 
ª  Resume, suspend, stop, 

step into, step over, step 
return 

ª  The current process set is 
listed next to job name 
along with number of 
processes in the set 

ª  The processes in process 
set are visible in right hand 
part of the view 

Root set = all processes 
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Create set Remove  
from set 

Delete 
set 

Change 
current set 

Managing Process Sets 

ª  The remaining icons in the toolbar of the Parallel 
Debug view allow you to create, modify, and delete 
process sets, and to change the current process set 
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Creating A New Process Set 
ª  Select the processes in 

the set by clicking and 
dragging, in this case, 
the last three 

ª  The Create Set button 
enables a new process 
set to be created 

ª  The set can be given a 
name, in this case 
workers 

ª  The view is changed to 
display only the 
selected processes 
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Stepping Using New Process Set 
ª  With the workers set 

active, the Step Over 
button will now 
operated on only these 
processes 

ª  Only the first line 
marker will move 

ª  After stepping a couple 
more times, two line 
markers will be visible, 
one for the single 
master process, and 
one for the 4 worker 
processes 
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Process Registration 

ª Process set commands apply to groups of 
processes 

ª For finer control and more detailed 
information, a process can be registered and 
isolated in the Debug view 

ª Registered processes, including their stack 
traces and threads, appear in the Debug view 

ª Any number of processes can be registered, 
and processes can be registered or  
un-registered at any time 
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Process Registration (2) 
ª  By default, process 0 was 

registered when the debug 
session was launched 

ª  Registered processes are 
surrounded by a box and 
shown in the Debug view 

ª  The Debug view only shows 
registered processes in the 
current set 

ª  Since the “workers” set 
doesn’t include process 0, it 
is no longer displayed in the 
Debug view 
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Registering A Process 
ª  To register a process, 

double-click its process 
icon in the Parallel 
Debug view or select a 
number of processes and 
click on the register 
button 

 

ª  To un-register a process, 
double-click on the 
process icon or select a 
number of processes and 
click on the unregister 
button 

Individual 
(registered) 
processes 

Groups (sets) 
of processes 
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Current Line Marker 

ª The current line marker is used to show the 
current location of suspended processes 

ª In traditional programs, there is a single 
current line marker (the exception to this is 
multi-threaded programs)  

ª In parallel programs, there is a current line 
marker for every process 

ª The PTP debugger shows one current line 
marker for every group of processes at the 
same location 
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Multiple processes marker  
 
Registered process marker 
  
Un-registered process marker 

 

Colors And Markers 

 
 

ª  The highlight color depends on 
the processes suspended at 
that line: 
ª  Blue: All registered process(es) 
ª  Orange: All unregistered 

process(es) 
ª  Green: Registered or unregistered 

process with no source line (e.g. 
suspended in a library routine) 

ª  The marker depends on the 
type of process stopped at that 
location 

ª  Hover over marker for more 
details about the processes 
suspend at that location 
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Exercise 

1.  From the initial debugger session, step all processes 
until the current line is just after MPI_Init (line 68) 

2.  Create a process set called “workers” containing 
processes 1-4 

3.  Step the “worker” processes twice, observe two line 
markers 

4.  Hover over markers to see properties 
5.  Switch to the “root” set 
6.  Step only process 0 twice so that all processes are now 

at line 71 (hint – use the debug view) 
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ª  Apply only to processes in the particular set that is 
active in the Parallel Debug view when the breakpoint 
is created 

ª  Breakpoints are colored depending on the active 
process set and the set the breakpoint applies to: 
ª Green indicates the breakpoint set is the same  

as the active set. 
ª  Blue indicates some processes in the breakpoint set are 

also in the active set (i.e. the process sets overlap)  
ª  Yellow indicates the breakpoint set is different from the 

active set (i.e. the process sets are disjoint) 
ª  When the job completes, the breakpoints are 

automatically removed 

Breakpoints 
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Creating A Breakpoint 
ª  Select the process set that 

the breakpoint should apply 
to, in this case, the workers 
set 

ª  Double-click on the left edge 
of an editor window, at the 
line on which you want to set 
the breakpoint, or right click 
and use the Parallel 
Breakpoint�Toggle 
Breakpoint context menu 

ª  The breakpoint is displayed 
on the marker bar 
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Hitting the Breakpoint 
ª  Switch back to the Root set 

by clicking on the Change 
Set button 

ª  Click on the Resume button 
in the Parallel Debug view 

ª  In this example, the three 
worker processes have hit the 
breakpoint, as indicated by 
the yellow process icons and 
the current line marker 

ª  Process 0 is still running as its 
icon is green 

ª  Processes 1-4 are suspended 
on the breakpoint 
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More On Stepping 
ª  The Step buttons are only 

enabled when all processes 
in the active set are 
suspended (yellow icon) 

ª  In this case, process 0 is still 
running 

ª  Switch to the set of 
suspended processes (the 
workers set) 

ª  You will now see the Step 
buttons become enabled 
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Breakpoint Information 

ª Hover over breakpoint icon 
ª Will show the sets this breakpoint applies to 

ª Select Breakpoints view 
ª Will show all breakpoints in all projects 
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ª Use the menu in the breakpoints view to group 
breakpoints by type 

ª Breakpoints sorted by breakpoint set (process 
set) 

Breakpoints View 
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ª  Apply to all processes and all jobs 
ª  Used for gaining control at debugger startup 
ª  To create a global breakpoint 

ª  First make sure that no jobs are selected (click in white 
part of jobs view if necessary) 

ª Double-click on the left edge of an editor window 
ª Note that if a job is selected, the breakpoint will apply to 

the current set 

Global Breakpoints 
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Exercise 

1.  Select the “worker” process set 
2.  Create a breakpoint by double-clicking on right hand 

bar at line 88 (worker function) 
3.  Hover over breakpoint to see properties 
4.  Switch to “root” process set 
5.  Observer breakpoint color changes to blue 
6.  Resume all processes 
7.  Observe “worker” processes at breakpoint, and process 

0 still running (green icon) 
8.  Switch to “worker” process set 
9.  Step “worker” processes over worker() function 
10. Observe output from program 
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Terminating A Debug Session 
ª  Click on the Terminate 

icon in the Parallel 
Debug view to 
terminate all processes 
in the active set 

ª  Make sure the Root set 
is active if you want to 
terminate all processes 

ª  You can also use the 
terminate icon in the 
Debug view to 
terminate the currently 
selected process 
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Cancelling The Job 
ª  Interactive jobs will continue 

until the reservation time has 
expired 

ª  You can cancel the job once 
the debug session is finished 

ª  Locate the job in the Active 
Jobs view 
ª  Use the view menu to filter for 

only your jobs if there are too 
many 

ª  Right click on the job and 
select Cancel Job 
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Exercise 

1.  Switch to the “root” set 
2.  Terminate all processes 
3.  Switch to the System Monitoring perspective 
4.  Right-click on your running job and select Cancel 
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Optional Exercise 

1.  Launch another debug job 
2.  Create a breakpoint at line 71 in main.c 
3.  Resume all processes 
4.  Select the Variables view tab if not already selected 
5.  Observe value of the “tid” variable 
6.  Register one of the worker processes 
7.  Select stack frame of worker process in Debug view 
8.  Observe value of the “tid” variable matches worker 

process 
9.  Switch to the breakpoints view, change grouping 
10. Terminate all processes 
11. Switch to the System Monitoring perspective and 

cancel the job 
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Performance Tuning  
and Analysis Tools 

ª Objective 
ª Become familiar with tools integrated with PTP, to help 

enhance performance of parallel applications 
ª Contents 

ª Overview of ETFw and Performance Tools 
 

 
 

Performance and Analysis 
Tools 
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PTP/External Tools Framework 
formerly “Performance Tools Framework” 

Goal: 
ª Reduce the “eclipse plumbing”  

necessary to integrate tools 
ª Provide integration for 

instrumentation, measurement, and 
analysis for a variety of performance 
tools 

 
 

ª  Dynamic Tool Definitions:  
Workflows & UI 

ª  Tools and tool workflows are specified in an XML file 
ª  Tools are selected and configured in the launch 

configuration window 
ª  Output is generated, managed and analyzed as 

specified in the workflow 
ª  One-click ‘launch’ functionality 
ª  Support for development tools such as TAU, PPW and 

others. 
ª  Adding new tools is much easier than developing a full 

Eclipse plug-in 
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SAX and JAXB Tool Definitions 

ª Prior implementations of ETFW used a simple SAX 
based schema to define tool workflows 

ª By default workflows now use the more powerful 
JAXB schema that defines PTP’s resource 
manager 

ª Legacy workflows can still be loaded by selecting 
the SAX parser in PTP options 
ª Window->Preferences-> 

Parallel Tools->External Tools 
 

 
 

Performance and Analysis 
Tools 
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Performance Tuning  
and Analysis Tools - TAU 

ª Objective 
ª Become familiar with tools integrated with PTP, to help 

enhance performance of parallel applications 

ª Contents 
ª Performance Tuning and external tools:  

ª PTP External Tools Framework (ETFw), TAU 
Hands-on exercise using TAU with PTP 
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TAU: Tuning and Analysis Utilities 

ª  TAU is a performance evaluation tool 
ª  It supports parallel profiling and tracing  

ª  Profiling shows you how much (total) time was spent in each routine  
ª  Tracing shows you when the events take place in each process along 

a timeline 
ª  TAU uses a package called PDT (Performance Database Toolkit) for 

automatic instrumentation of the source code 
ª  Profiling and tracing can measure time as well as hardware 

performance counters from your CPU (or GPU!) 
ª  TAU can automatically instrument your source code (routines, loops, 

I/O, memory, phases, etc.) 
ª  TAU runs on all HPC platforms and it is free (BSD style license) 
ª  TAU has instrumentation, measurement and analysis tools 

ª  paraprof is TAU’s 3D profile browser 
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TAU Performance System Architecture 
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PTP TAU plug-ins  
http://www.cs.uoregon.edu/research/tau 

ª  TAU (Tuning and Analysis Utilities) 
ª  First implementation of External Tools Framework (ETFw) 
ª  Eclipse plug-ins wrap TAU functions, make them available 

from Eclipse 
ª  Full GUI support for the TAU command line interface 
ª  Performance analysis integrated with development 

environment 
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TAU Integration with PTP 

ª TAU: Tuning and 
Analysis Utilities 
ª Performance data 

collection and analysis 
for HPC codes 

ª Numerous features 
ª Command line interface 

ª The TAU Workflow: 
ª Instrumentation 
ª Execution 
ª Analysis 
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TAU PTP Installation 

ª  This tutorial assumes that the TAU extensions for PTP 
are installed – they are not included in the  
“Eclipse for Parallel Application Developers” 

ª  The installation section (Module 1) shows how to install 
TAU and other features from the PTP update site –  
be sure TAU was selected 
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To confirm: 
ª Help>Install New Software… 
ª Select the link “What is already 
installed” at the bottom of the 
dialog 
ª You should see the TAU 
Extension 



Installing TAU Analysis Tools 

ª  The TAU plugin can use ParaProf for visual analysis and TauDB 
for organization of profiles 

ª  To install these utilities on Mac or Linux platforms:  
ª Download (browser, curl or wget)  

 tau.uoregon.edu/tautools-latest.tgz 
ª tar -zxf tautools-latest.tgz 
ª cd tautools-latest 
ª ./configure 
ª Set path as shown (launch eclipse from this environment) 
ª Run taudb_configure and follow the instructions 

ª  Java WebStart: tau.uoregon.edu/paraprof 
ª  TAU Installation, downloads and instructions: tau.uoregon.edu 
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Assumptions 
ª Obtain and install TAU* 

ª Download at tau.uoregon.edu 
ª  The website includes setup and user guides 

ª Set up the $PATH on the remote machine* 
ª  For TAU you should be able to run ‘which pprof’ on a remote login 

and see a result from your TAU bin directory 
ª On trestles.sdsc.edu this is accomplished by loading the tau module 

in the environment manager for the build and launch configurations 

ª Include ‘eclipse.inc’ in the makefile* 
ª Create an empty eclipse.inc file in the same directory as the 

makefile 
ª  Place ‘include eclipse.inc’ in the makefile after regular compiler 

definitions 
ª  ETFw will modify eclipse.inc to set CC/CXX/FC variables 
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Selective Instrumentation 
ª By default tau provides timing data for each 

subroutine of your application 
ª Selective instrumentation allows you to include/

exclude code from analysis and control additional 
analysis features 
ª  Include/exclude source files or routines 
ª Add timers and phases around routines or arbitrary code 
ª  Instrument loops 
ª Note that some instrumentation features require the PDT 

ª Right click on calc.c, init.c, diag.c go to the Selective 
Instrumention option and select Instrument Loops 

ª Note the creation of tau.selective (refresh if needed) 
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Begin Profile Configuration 

ª The ETFw uses the same run configurations and 
resource managers as debugging/launching 

ª Click on the ‘Run’ menu or the right side of the 
Profile button 

 
 
 
 
ª From the dropdown menu select ‘Profile 

configurations…’ 
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Select Configuration 

ª  Select the shallow configuration 
prepared earlier 

ª  The Resource and Application 
configuration tabs require little or 
no modification 
ª  We are using the same resource 

manager and Torque settings 
ª  Since we are using a makefile project 

the application will be rebuilt in and 
run from the previously selected 
location 
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Performance Analysis tab is 
present in the Profile 
Configurations dialog 



Select Tool/Workflow 

ª Select the Performance Analysis tab and 
choose the TAU tool set in the ‘Select Tool’ 
dropdown box 
ª Other tools may be available, either installed as 

plug-ins or loaded from workflow definition XML files 
ª Configuration sub-panes appear depending on the 

selected tool 
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Tabs may be 
hidden if the 
window is too 
small 
 



Select TAU Configuration 

 
ª Choose the TAU  Makefile tab: 

ª All TAU configurations in  
remote installation are  
available 

ª Check MPI and PDT  
checkboxes to filter listed  
makefiles 

ª Make your selection in the  
Select Makefile: dropdown  
box 

ª Select Makefile.tau-mpi-pdt 
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Choose PAPI Hardware Counters 
ª When a PAPI-enabled TAU 

configuration is selected the PAPI 
Counter tool becomes available 
ª Select the ‘Select PAPI Counters’ 

button to open the tool 
ª Open the PRESET subtree 
ª Select PAPI_L1_DCM (Data cache 

misses) 
ª Scroll down to select PAPI_FP_INS 

(Floating point instructions) 
ª Invalid selections are automatically 

excluded 
ª Select OK 
ª Not available on trestles.sdsc.edu 
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Compiler Options 
ª TAU Compiler Options 

ª Set arguments to TAU compiler scripts 
ª Control instrumentation and 

compilation behavior 
ª Verbose shows activity of compiler 

wrapper 
ª KeepFiles retains instrumented source 
ª  PreProcess handles C type ifdefs in 

fortran 
ª  In the Selective Instrumentation tab 

select Internal then hit Apply 
ª  Scroll to bottom of the Tau Compiler tab 

and activate TauSelectFile to use 
tau.selective 
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Runtime Options 
ª TAU Runtime options 

ª Set environment variables used by 
TAU 

ª Control data collection behavior 
ª Verbose provides debugging info 
ª Callpath shows call stack 

placement of events 
ª Throttling reduces overhead 
ª Tracing generates execution 

timelines 
ª  Set Profile Format to merged 
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Working with Profiles 
ª  Profiles are uploaded to 

selected database 
ª  A text summary may be 

printed to the console 
ª  Profiles may be uploaded to 

the TAU Portal for viewing 
online 
ª tau.nic.uoregon.edu 

ª  Profiles may be copied to 
your workspace and loaded 
in ParaProf from the 
command line.  Select Keep 
Profiles 
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ª  Once your TAU launch is  
configured select ‘Profile’ 
ª  Notice that the project rebuilds with TAU compiler commands 
ª  The project will execute normally but TAU profiles will be generated 
ª  TAU profiles will be processed as specified in the launch configuration. 
ª  If you have a local profile database  the run will show up in the 

Performance Data Management view 
ª Double click the new entry to view in ParaProf 
ª Right click on a function bar and select Show Source Code for 

source callback to Eclipse 
 

Launch TAU Analysis 
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Paraprof 
ª Use ParaProf for profile visualization to identify 

performance hotspots 
ª Inefficient sequential computation  
ª Communication overhead 
ª IO/Memory bottlenecks 
ª Load imbalance 
ª Suboptimal cache performance 

ª Compare multiple trials in PerfExplorer to identify 
performance regressions and scaling issues  

ª To use ParaProf, install TAU from tau.uoregon.edu or 
use Java webstart from tau.uoregon.edu/paraprof  
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Exercise 
ª  Multi-Trial profile comparison 

1.  Edit the shallow Makefile, adding -O3 to CFLAGS and FFLAGS 
2.  Rerun the analysis (Run->Profile Configurations. Hit Profile) 
3.  A second trial, distinguished by a new timestamp, will be 

generated  
ª  It will appear in your Performance Data Manager view if a profile 

database is available 
ª  Also present in the Profile subdirectory of your project directory 
ª  If you do not see a Profile directory right click on your project and go 

to Synchronization->'Sync All Now' 
4.  Load the two trials in paraprof (on the command line: paraprof /

path/to/tauprofile.xml) 
5.  Open Windows->ParaProf Manager 
6.  Expand your database down to reveal all trials 
7.  Right click on each trial and click 'Add Mean to Comparison 

Window' to visualize the two trials side by side  
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Gcov and gprof support in linux tools 
ª Objective 

ª Learn how to use Eclipse-based interfaces to GNU tools 
Gcov and Gprof 

ª Contents 
ª Build with “-pg” for gprof profiling 
ª Build with “-ftest-coverage –fprofile-arcs” for gcov 
ª Run gcov to determine code coverage – which parts of 

your program are logically getting exercised 
ª Run gprof to determined which parts of your program 

are taking most of the execution time 
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Linux Tools 

ª What is Linux Tools? 
ª http://eclipse.org/

linuxtools/ 
ª Builds on CDT for C/C++ 
ª Integrates popular native 

development tools such as 
Valgrind, OProfile, RPM, 
SystemTap, GCov, GProf, 
LTTng, etc. – into Eclipse 
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Linux Tools - Installation 

ª Some of the Linux Tools 
are included with Eclipse 
for Parallel Application 
Developers package 

ª Everything you need for 
this tutorial is in the 
package 

ª To install manually: 
ª  Help > Install New Software 
ª  In Work With: Select Kepler update 

site 
ª  Under Linux Tools, Select the tools 

you want or just select all of them 
ª  Some cannot be installed on all 

non-Linux platforms 
ª  Click Next> … and continue to end of 

installation and restart Eclipse when 
prompted 
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Linux Tools - usage 

ª With a synchronized project, you only need gprof/gcov 
available on the remote system.  (Even the Windows 
client can view the gprof and gcov output files.) 

ª Compiler flags 
ª  -pg  to profile with gprof for the GNU compilers 
ª  -ftest-coverage -fprofile-arcs   for gcov support 

ª  It’s ok to use both at the same time at low optimization settings 

ª Re-run the application 
ª With synchronized projects, remember to re-sync to 

retrieve the resultant files 
ª gprof -s shallow gmon_shallow.*  : creates a 

summary profile (gmon.sum) from MPI programs with a 
profile per rank 
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Linux Tools – click to view 
ª  Double-click gmon.* for gprof view 
ª  Double-click *.gcno or *.gcda for gcov view 
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Linux Tools – click to view 
ª  Double-click gmon.* for gprof view 
ª  Double-click *.gcno or *.gcda for gcov view,  

ª  It will ask for binary file location 
ª  Coverage Result: for Windows, select src file only (do not select the whole 

binary file in the radio button of the dialog box) 
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Windows 
only 

Windows only.  
Mac/Linux can show 
coverage for whole 
file   



Opening a profile with gprof viewer 

Linux-6 Linux Tools 

Note: since we’ve changed filename from ‘gmon.out’  to gmon_shallow.xxx 
we will force the gprof editor to be invoked for the files.   
Use Right mouse > Open With… > Other … and choose Gprof Editor 
 



Gprof tab 
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Double-click on gmon.out file to open 
gprof viewer 



Run code, inspect gcov display 
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Double-click on a source file in gcov view to see code 
coverage highlighted in source file 



Gcov with a production code, unexecuted region 
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gprof with shallow project, MPI 

The Makefile CFLAGS and FFLAGS are modified as shown to 
support profiling and coverage at the same time. 
We have created the Makefile so you should just be able to 
uncomment these lines. 
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Add compiler flags to Makefile 



gprof with shallow project, MPI (2) 

Setup the MPI run configuration with the Environment variable 
GMON_OUT_PREFIX defined with a /full/path/name for your 
individual MPI rank gmon outputs.  By default gmon.out is used but 
MPI doesn't do that well and you end up with a profile that's missing 
most of the information, so by using GMON_OUT_PREFIX, each MPI 
rank adds its process id to its gmon output filename.  
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Modify Run Configuration 
Run > Run Configurations … to modify existing Run Configuration   

Make this the fully qualified path+prefix 
for gmon output. E.g. 
/home/userid/shallow/gmon_shallow 
(Otherwise they end up in a scratch dir) 
 



gprof with shallow project, MPI (3) 
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ª Run from Run Configuration dialog 
 
 
ª See build results in 
   Console 
 
ª See new 
    files in Project Explorer 
    (You may need to  
     force a Sync) 
 
 
 
 
 
 
 
 
 
   



gprof with shallow project, 1 rank 

ª Open gmon file with gprof viewer 

ª Double-click on gmon.out file 
 
    -or-  since gmon_shallow.xxx has non-standard file types …. 

ª Right click on gmon_shallow.xxx file and select  
Rightmouse >Open With… Other…  and select  
Gprof Editor 
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gprof with shallow project, 1 rank (2) 

View gmon data with gprof viewer 
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It's interesting to 
compare the summary 
gmon output to that 
from one of the ranks. 
 
This view shows a 
gmon.out file (you have 
a gmon_shallow.xxx 
file) from a single rank. 
 
	




Gprof with shallow project, summary 
  

Linux-15 Linux Tools 

Aggregate the gmon output – invoke from a terminal: 
     gprof -s shallow gmon_shallow.*  
This creates a gmon.sum file 
 
Force a sync to 
see the file in  
Project Explorer 
 
Double-click to 
open the gmon.sum 
File with the 
gprof viewer 
 



Gprof viewer does not currently  
work well on Windows 
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Windows: gprof with 
shallow project, 
summary, use a 
terminal window to 
create text file 
 
a. Invoke cmd line gprof 
b. Sync to see file 
c. Double-click to view 
txt file 
 
The linuxtools team 
knows about the issue 
with Juno/Kepler and 
they’re working on it. 



Gprof viewer still useful on Windows 
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Windows: Expand the 
gprof tab view of 
gmon.out (copy of one 
of the ranks output). 
 
You can use the chart 
tool to make charts of 
the data in the gprof 
table you select. 
 



Gcov with shallow project 

The gcov view is simlar to the gprof view but keep in mind that you're 
looking at code coverage and not necessarily performance or timing 
information (though there is a relationship...code not executed is 
performing quite well ! ).  Also note that multiple executions will 
accumulate values in the gcov output files until they are removed or 
truncated to zero-length (2nd run to demonstrate this). 
 
Double-click 
on any of the 
*.gcda or *.gcno 
to open this 
gcov viewer 
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Gcov with shallow project,  
integration with CDT editor 

Selecting (double click) a source code line from either the gcov or 
gprof view and you'll see the file and routine highlighted in the  
editor.  Also notice the support for the .f90 file and its routines.   
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Exercise 

Follow directions in previous slides to 
1.  Add the compiler flags to Makefile  
2.  Modify run configuration as described (add gmon 

prefix), and Run 
3.  View gmon and gcov files with gprof and gcov 

viewers 
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Optional Exercise 
1)  Run the shallow application with gcov compiler flags enabled. 
a)    Re-sync with Sync Active Now under Synchronization 
b)    View the tstep.gcno file and note the count, then repeat 1)a-b , 

have the counts changed? 
 
2) Compare the tstep.f90 loops at lines 61, 70, 80 in the gprof and 

gcov displays . 
a)  Change the Makefile to use –O3 with FFLAGS and clean/rebuild/re-

run 
b)  gprof –s shallow gmon_shallow.273*   [your most recent gmon_ 

files from the run you just finished ] 
c)  Re-sync the project 
d)  Does the gprof view of gmon.sum still exactly match up with the 

gcov display?  If not, what happened to the missing loop(s)? 
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Tutorial Wrap-up 

ª Objective 
ª How to find more information on PTP 
ª Learn about other tools related to PTP 
ª See PTP upcoming features 

ª Contents 
ª Links to other tools, including performance tools 
ª Planned features for new versions of PTP 
ª Additional documentation 
ª How to get involved 
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Useful Eclipse Tools 

ª  Linux Tools (autotools, valgrind, Oprofile, Gprof) 
ª  http://eclipse.org/linuxtools (part of Parallel package) 

ª  Python 
ª  http://pydev.org 

ª  Ruby 
ª  http://www.aptana.com/products/radrails 

ª  Perl 
ª  http://www.epic-ide.org 

ª  VI bindings 
ª  Vrapper (open source) - http://vrapper.sourceforge.net 
ª  viPlugin (commercial) - http://www.viplugin.com 
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Online Information 
ª Information about PTP 

ª PTP online help  
ª http://help.eclipse.org 

ª Main web site for downloads, documentation, etc. 
ª http://eclipse.org/ptp 

ª Wiki for designs, planning, meetings, etc. 
ª http://wiki.eclipse.org/PTP 

 
ª Information about Photran 

ª Main web site for downloads, documentation, etc. 
ª http://eclipse.org/photran 
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Mailing Lists 

ª  User Mailing Lists 
ª  PTP 

ª http://dev.eclipse.org/mailman/listinfo/ptp-user 
ª  Photran 

ª  http://dev.eclipse.org/mailman/listinfo/photran 
ª Major announcements (new releases, etc.) - low volume 

ª http://dev.eclipse.org/mailman/listinfo/ptp-announce 

 
ª  Developer Mailing Lists 

ª Developer discussions - higher volume  
ª http://dev.eclipse.org/mailman/listinfo/ptp-dev 
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Getting Involved 

ª See http://eclipse.org/ptp 
ª Read the developer documentation on the wiki 

ª http://wiki.eclipse.org/PTP 
ª Join the mailing lists 
ª Attend the monthly developer meetings 

ª Conf Call Monthly: Second Tuesday, 1:00 pm ET 
ª  Details on the PTP wiki 

ª Attend the monthly user meetings 
ª Teleconf Monthly: 4th Wednesday, 1:00 pm ET 
ª Details on the PTP wiki 
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PTP Tutorial Wrap-Up 

ª Please fill out the feedback form 

ª Your feedback is valuable! 
 

Thanks for attending 
We hope you found it useful 

 
 
 
 
 

ª  
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