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PolarPaint v1.3 by Anbjørn Myren 

Program window layout 

The drawing area is the visible white rectangle in the middle. Workspace tools at the top, and 
toolbar icons and color selection at the left side. Some of the icons have a '!' mark in the bottom-
right corner. That indicates that some settings are available. Use RMB on the icons to enter these 
settings.  

In version 1.3 a menu system is introduced, mainly to access the new animation features. On Amiga 
like systems there is an extra button on the top row labeled ‘RMB’ to toggle the bahaviour of the 
RMB. 

 

 

 

 

 

 

At the bottom of the window there is a status line used to display coordinates for captured brush 
and the size of last drawn shapes. It will also display the RGB value of picked color.(the small version 
of the program use part of this area for some workspace commands) 

Workspaces 

Above the drawing area the workspace tabs are located, by default workspace 1 is active. The 
workspace tab will be highlighted with a white frame to indicate the active workspace. Each 
workspace act as independent drawing areas and have their own separate undo/redo buffers. 

Workspace Commands 

 - Merge - 

This will copy the current workspace image on top of a selected target workspace. Current 
workspace image will be dominate. The background color of the current workspace will be 
transparent during the process. 

 - Mix / Transparent Mix - 

Both these commands will merge current workspace into another with a mix ratio using a 
choosen level of transparency. The difference is that Mix will use one parameter to weight 
the transparency between the two workspaces, while Transparent Mix have the option to 
set the transparency  level independently for each of the workspaces. 

 - Copy -  

Create an identical copy of current workspace image into another workspace. 
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Icons and their usage: 

- Info –  Press the Info icon to display a simplified explanation of the program. Also while the 
Info icon is highlighted any icon can be clicked to display popup-info. 

 - Quit - A quit requestor is displayed. Additionally you will have the option to enable or 
disable Diskbuffer, to be applied at the next session. 

- Load - Lets you load any image file into the current workspace. Most common file formats 
are supported. 

 If the image is larger than the workspace a requester will offer the choice to either scale the 
image to fit the workspace, or to load just a part of the image from user set coordinates. Eg. 
If coordinates x and y are set to 0, the image loaded will be as many pixels as the workspace, 
set from the upper left corner. (1280x720 or 640x480 for the small edition). Setting x and y 
to values exceeding the image pixels width and height will still load the same size, but now 
the part will be from the lower right corner.   
If the option to load a part of the image is used, then a "partloaded" flag will be set internally 
in the program. Note that the partloaded flag will not be retained when quitting the 
program. 

Se save section for how partloaded is handled when saving.  

- Save - Will save the current workspace image into a file. RMB on the save icon brings up a 
file format requestor. 

If the "partloaded" flag is set the user will be offered the option to merge the image into the 
source image and save it with the orginal resolution as a new filename. The partloaded flag 
for the current workspace will be kept until another image is loaded into the workspace. This 
meaning that it is possible to save the partloaded image first without merging it with the 
source, and then save it later again and then merge it with source. 

Important: Partloading does not load the full source image into memory, but it remember 
the path to the source image. Therefore it is important that the source image is not moved, 
overwritten, renamed in case you plan to merge your image with the source image later. 

 

- Undo - Undo the last drawing operation. By default the last 20 operations can be undone. 
RMB to adjust the Undo buffer size. The program will remember this setting (maxundo.txt) 

- Redo - Redo the last undo operation. 

 

- CLS - Clear the screen, either to white or black. Background color will also be set 
accordingly. 

 

- Text - Click mouse to place the text on drawing, by default the word ‘PolarPaint’ is written. 
Use RMB to choose font type, size and style, and to change the text. The Hollywood inbuilt 
font types Sans, Serif and Monospace are available for selection, as well as the option to set 
a custom font. The font name must be entered as the exact name of the font. Note that not 
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all font types are supported and some fonts are available in certain sizes. If the font is not 
supported, it will fallback to use the default Serif font. 

- Transparency - Click the icon to toggle transparency drawing. First time enabling 
transparency brings up the settings. First the level of transparency is set from 1 to 255 (zero 
to disable). A higher number increase the transparency. 

There are two modes for how the transparency is applied, Default or Instant.  

The default mode with process your whole line before applying transparency, making the 
transparency even troughout the line drawn. The line will appear solid while drawing and the 
transparency is applied when releasing the mouse.  

Instant mode will apply transparence as you draw, but will leave "dots" along the line. This is 
because you really is drawing many short connecting lines and the "dots" appear where 
these lines overlap. 

 For Lines, Boxes and Circles the default transparency mode will be used.  

 

– Brush Icon - Capture an area from your drawing into a brush. The mouse pointer will 
change into a cross while capture is active. 

The captured brush can then be used as the drawing pen draw, or simply stamp copies of the 
brush image with a single mouse press. Brush position will be centered according to mouse 
position. Brush is kept in memory until another brush is captured or loaded. 

Dimensions of the last captured brush will be displayed at the bottom status line, as well as 
the upper left corner coordinates from where it was retrieved. 

Right Click on the Icon will let you paste the current brush into a specific x y position. This 
could be useful if you want to apply an effect on a selected area only. Then use the brush to 
select the area and apply the effect to the brush, then paste the brush into same x y pos as it 
was selected. 

- Load Brush - Loads a brush from an image file. 

-  Save Brush - Save the current brush into a file. File format will follow the save file settings. 

Brush Usage 

As mentioned above, the brush will retain in memory until another brush is captured or 
loaded from file. If you press the Brush Capture icon again the pointer change to a cross 
again.  At this point there are two ways to abort capturing: 

1. Press the ESC key. If there is a brush in memory already the program will stay in brush 
mode and the current brush is active. Pointer will return to normal pointer. 

2. Press the left mouse anywhere outside the drawing area, or on any icon to select another 
action. By default the pencil will be activated unless another action is selected. 

Brush mode can also be toggled by pressing Pencil button on/off if there is a brush in 
memory. 
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- Pencil - The  Pencil icon is highlighted to indicate normal drawing mode. LMB draws with 
foreground color, RMB draws the background color. Use RMB on the Pencil icon to set the 
pencil size. 

Technically this drawing operation works like it is drawing lines while constantly polling the 
mouse position. This is the reason that you might experience that drawing a curve might 
look not smooth if moving the mouse to fast. This is most notable on slower systems 

 

- Flood Fill - By default this uses the regular floodfill (the in-built Hollywood command) which 
is the fastest method and will work well in most cases. 

Flood fill does have a threshold setting to enable filling gradients of similar colors. Eg. if you 
have an image saved as a jpeg file you might discover that regular floodfill does not fill all 
areas as expected. 

Use RMB to set the threshold value. If set to zero, threshold is disables and the in-build flood 
fill is used. Any other value will use a custom floodfill function. It works by comparing the 
RGB value of the active color with the area to fill. The higher number, less similar color 
values will be taken into calculation. 

The custom fill operation is much slower than the regular fill, specially on low end 
computers. The way it works it will read the color form pixel by pixel and create a table of 
pixels to fill. 

For lower Threshold values it will process up to 1% of the image area before filling, then 
process the next bacth until done. For Threshold values 30% and higher the processing is 
much slower, so it will then process only a user selectable area size all in one go.  

Processing with high threshold will also consume memory. As a general rule you need a 
system with 64MB RAM to process sizes up to 5% of a 1280x720 image, 128MB up to 50% 
and so on. 

Use ESC to interupt an ongoing floodfill operation. 

The setting is quite sensitive so depending on your image there could be a big difference 
between whole numbers. You can use decimal values, eg. 0.01 or 0.5 so just try until 
satisfied. In some cases you may try to fill with other colors first to gradually get the wanted 
result. 

 

- Multipen drawing –  

With multipen enabled the pen will also be drawn mirrored both vertical and horisontal 
simultaneously, so drawing 4 places at the same time. RMB on the icon allows the user to 
choose only vertical, only horisontal mirroring or both. 

- Spray paint –  same button as mulitpen 

Use RMB to enter settings for density and size of the spray area. 

 

- Replace Color –  This will replace any instance of the selected color in the workspace image. 
Similar to flood fill, but the pixels does not have to be connected. 
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- Rectangle – Rectangles can be drawn in normal mode, filled or with gradient fill. Click the 
icon repeatingly to toggle the mode. For gradient fill you will have the option to set the angle 
for gradinent fill, press RMB on the icon while gradient is active to set angle.  

Click on screen to select the upper left corner of the rectangle (or bottom right corner if 
drawing the other way), then hold and and drag the mouse button until done. A preview 
rectangle will be drawn while moving. Border thinkness will be same as the pen size.  

The shape icons (Rectangle, Ellipse, Circle and Arc does have a XY-mode. When selected the 
user have the option to enter exact coordinates for the shape to be drawn. 

Rectangle, Ellipse and Arc can also be drawn in a rotated state. The rotation angle is set by 
the XY-mode. After an angle is set once the angle is remembered for each shape type so that 
any other rectangle will draw in that angle. Use XY-mode again to reset it to 0. Rectangles 
are ment to be drawn from upper left corner to the right-lower corner to keep the 
coordinates of the starting corner at the correct spot. It is possible to draw a rectangle in any 
direction but this might result in an unexpected offset, specially if the rotation angle is large.  

- Ellipse – Ellipe have the same modes and options as the rectangle. Note that the gradient 
fill angle setting is common for rectangle, ellipse and circle so setting either of them will 
apply for all. To position the Ellipse start with the mouse cursor at the center of the Ellipse 
and drag the mouse to adjust set the size.   

-Line –  Draw a straight line between two selected points. 

 

- Circle – Circle also have the same modes as Rectangle and Ellipse. When drawin a circle the 
mousepointer starting point will be the center of the circle.  

- Arc – The Arc is drawn the same way the ellipse is drawn an ellipse. By default the arc starts 
at 0 degree (3 o’clock), and ends at 270 (upwards). Eg. To draw a C-shaped arc, startangle 
must be 90 and end angle 270, for U-shape 0 and 180. This can be changed in XY-mode. 
There is also a setting for rotating the whole Arc. The Arc is positioned the same way as the 
Ellipse, start with center position and hold mouse button and drag to adjust the size. 

- Effects –  A varity of effects are available. RMB on the icon to select the active effect, LMB 
to apply choosen effect. Select between Emboss, OilPaint, Blur, Edge, Swirl, Gray, 
MonoChrome, Contrast, Invert, Pixelate, Charcoal and Rotate (default action is rotate 90). 

For OilPaint and CharCoal the effect level can be set from 1 to 30. Higher number takes 
longer time to process. 

Pixelize have a pixel size setting from 1 to 100. 

Contrast have the option to Increase or Decrease the Contrast. 

Swirl and Roatate can be set between -360 to 360, negative values will give a right 
(clockwise) rotation, positive value for left. 

The remaining effects have default values. 

If the Brush is active, then all Effects will apply to the Brush instead of the workspace image.  

For rotating there is an option to enable smooth filtering while rotating.  
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- Flip – Mirror the current image horizontally or vertically. If Brush is active it is the Brush 
that is Flipped. 

 

- Resize –  Scale the current image up or down. New size is set in percent of the original 
image. (Flip and Resize are scaled down to save space, so they might look like one icon) 

 

- Zoom – Will zoom the selected area 8 times. Click the center of the area to zoom in to, then 
edit details before clicking on the zoom icon again to return to normal view. When entering 
Zoom, the original image will be stored in a temporary brush. When exiting Zoom mode the 
original image will be restored with the zoomed edits. Note that the zoomed image will be 
scaled down to fit the original size, so small details may be lost in the scaling process. 

Note. While zoom is active, you can draw and use the Undo / Redo function as normal. Since 
zoomed and normal mode share the same undo-buffering systems odd thing may happen if 
you get past the Undo buffer made from the zoomed image. Then the full size image will 
appear. The program will still consider it is in zoom state so when exiting zoom mode it is the 
image in view that will be scaled down and pasted into the original image. Similar when 
returning to normal mode, the undo buffer may contain zoomed images. 

Usually you should be able to set things straight by using the Undo function, but it is better 
to know how this works to avoid problems. This warning also applies if quitting the program 
while still in zoom mode. If diskbuffer is enabled, it is the zoomed image that will be saved 
and not the full original image. Again you might be saved by the Undo buffer, but the best 
practice is to exit zoom mode before saving or quitting the program. 

New from ver.1.3: Normal drawing operation works like a PixelEditor. This way the details 
you draw in zoomed mode will be retained when exiting zoom. Pixel behavior is 
implemented for basic drawing, lines and boxes only. There is a menu option to toggle Pixel 
mode on or off. 

- Color Picker –  Click the Color Picker icon and then select a new color by clicking at the 
image. Use RMB to select backgound color. 

 

- Color indicator –  This area will show the current selected fore- and background color. 
Clicking the this area brings up a color requestor for custom color selection. Use RMB for 
setting background color. 

 

 

- Color icons –  These are pre-set colors for direct selection of the active color, use 
RMB to set background color. 
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Keyboard Shortcuts 

1 to 8 - select active workspace 

Menu shortcuts  (used for animation menu) 

Menu shortcuts are invoked by an action key, like Right Amiga or Control on windows systems. 

Action + O – Open animation file 

Action + A – Create a new animation 

Action + W – Write to next animiation frame. Will add a new frame if current frame is the last frame. 

Action + U – Write to current animiation frame 

Action + N – Go to Next frame 

Action + P – Go to Previous frame 

Action + G – Write guidelines. Draws thin gray lines to mark the size of the current animation 

 

 

Diskbuffer 

What is it?  
The diskbuffer will store all Undo / Redo operations to disk as well as the workspace images. When 
activated  the user may choose to keep the diskbuffer files when quitting. This way all images in the 
Workspaces is saved with their current undo buffers and the user can continue the work in the next 
session.  
 
How to enable / disable diskbuffer? 
The option to enable or disable the Diskbuffer usage is by using the Quit Requestor. The change will 
have effect after restarting the program. 
 
Why diskbuffer was created. 
Diskbuffer was created to save memory. If diskbuffer is disabled all undo/redo buffering is stored in 
memory and depending on the computer, it may exeed the available amount of RAM, causing the 
program to crash. Diskbuffer allows the program to store these into disk instead. Read below about 
memory requirements, and keep in mind that the larger undo buffer the more HDD space is 
required.  
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Menu  
 
From version 1.3 a menu system is added. Then main reason was to make room for the new 
animation features.  On amiga systems the menu will be disabled when the mouse pointer is moved 
inside the drawing and icons area.  Therefore there is an additional buttom on the top row labeled 
RMB to disable/enable the menu. While the menu is enabled the RMB can not be used for other 
RMB actions like button select or drawing operations. 
 
File > Load – Open an image file 
 
File > Save – Save the image as a file 
 
File > Set Image format – Set the default image format for saving. (PNG, JPEG, IFF, BMP) 
 
File > Quit – Invokes the Quit requestor 
 
Edit > Undo – Undo last drawing operation 
 
Edit > Redo – Redo last Undo operation 
 
Edit > Clear to White – Wipe drawing to white. Sets the pen colors as well. 
 
Edit > Clear to Black – Wipe drawing to black. Sets the pen colors as well. 
 
Edit > Pen Size – Invokes the requestor to change pen size (from 1 to 65 pixel size) 
 
Edit > Text setting – Invokes to Text field settings. Lets you choose font type, size and angle. 
 
Edit > Toggle Zoom – Sets zoom mode (or exit from zoom), and then select area on drawing tp zoom. 
 
Edit > Toggle Pixel Mode – Pixel Mode is enabled by default when in zoom mode, but you can turn it 
off if desired.   
 
Anim > Animation menu described on next page. 
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Animation 

Animation formats supported are AVI, IFF, PNG and GIF. 

The animation features is accessed from the menu. Here is a short description of the items in the 
Anim submenu. 

Open Anim File – Select an existing animation file to work with. Note that you will be working 
directly on the selected file so when writing a frame the file will be changed. If you do not want to 
change the original then be sure to use a copy of the file or use the “save anim as” to create a copy. 

Create Anim – Will prompt for a new file name and also ask what file format and the size of the 
anim. An anim must have minimum 2 frames to be a valid anim file so the new file will be a 2 frame 
anim to start with. The current drawing will be used to fill the first two frames. 

Write to next frame – Writes the current drawing into the next frame.  If you are at the last frame 
then a new frame will be added to the animation 

Update current frame – Will write the current drawing into the current frame. 

Insert frame – Adds a new frame by inserting it either before or after the current frame 

Remove  frame – Will remove the current or last frame from the animation, or multiple frames can 
be entered. The latter option will start by removing the current frame and forward. 

Next / Previous frame – Jump one frame back or forward, or enter the frame number to go to.  
Keyboard shortcuts Action + N or P to navigate. 

Guidelines – Will draw a thin gray line to highlight the size of the animation 

Anim to Sprite – Save the current animation into a image file, similar to how a sprite is stored. The 
user will be prompted for the numbers frames per row. When the animation have many frames it 
may be useful to split the file into rows to restrict the width of the resulting imagefile.  

Sprite to Anim – Select a sprite file and convert it into an animation. You need to know some details 
about the sprite file to get it correctly converted. Like how many frames there are and how many 
frames per row. 

Save anim as – Save a copy of the current animation, also there is an option to choose the animation 
file format. 

Save with delay – Save the animation with the option to set frame delay. Either by specifying custom 
delay for each frame or use the same delay for each frame. 

The delay is set different for certain formats. For avi files the delay is set by adjusting the FPS (Frame 
Per Second) which will give the same delay for each frame. For IFF and GIF individual frame delay in 
ms can be set.  

NOTE: There is currently a bug in the Hollywood avi handling, so with AVI the resulting file will be 
much bigger than IFF, PNG or GIF. File size will be bigger the lower the FPS is set. Also the Hollywood 
inbuilt animation player currently does not support the FPS setting in the avi file and will play in full 
speed. To play an avi file slower, use the menu option “Play Anim (custom delay)” or use an external 
video player.    

Play Animation – Play the anim in a window, optionally play with a custom frame delay. In the latter 
mode you can also set the number of times to play the anim. It is also possible to break the playback 
by closing the playback window if Play with custom delay is used. 
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Animation QUICK start 

1. Select from menu ‘Create new Anim file’ 
2. Now you will get 3 requestors, first one to set the 

size of the animation in pixels, next is to select 
which animation format (avi/iff/png or gif). Finally 
you will be prompted for the file name to save the 
animation as. 

3. Two frames will be created, since this is the 
minimum requirement for a valid animation file. If 
you selected eg. 320x240 pixel size then the 
content of the first two frames will be inherited 
from the upper left 320x240 pixels from from your 
current drawing.  

4. The animation frame 1 will be displayed. Now you may start editing this frame by drawing 
something. Save the changes to the frame by using the menu ‘Update current frame’. 
Optionally use the keyboard shortcut RAmiga + U (Ctrl + U on windows systems) 

5. You might want to use the current frame as a base for the next frame. Then just apply some 
changes you want into the next frame and write it into next frame by selecting ‘Write to next 
frame’ in the menu, or use RAmiga + W. 

6. If you are on the last frame then a new frame will be created every time using RAmiga + W 
7. To see the borders of the animation area, use RAmiga + G to draw a thin frame around it. 

 

Requirements 

The program is developed with Hollywood so the requirements for running the program are beyond 
the typical classic Amiga hardware. 

It requires codesets.library and reqtools.library, both available on Aminet, currently in these 
archives: codesets-6.22.lha, ReqToolsLib.lha 

Minimum free memory of 40MB is required (small version about 32MB), 64MB or more 
recommended. Without using diskbuffer more memory will be needed. With diskbuffer enabled 
some free HDD space is required. 
Each brush initiated will take about 4MB of memory. Opening a new workspace consumes 4 MB 
(1MB for the small edition) per Workspace (unless diskbuffer is used). 
The Undo / Redo system will also require memory since each Undo is a full brush stored in memory.  
If you set the Undo buffer to max (100) and use all 8 Workspaces you will in theory have 800 undo 
operations available. Needless to say this will require massive amounts of RAM. 
 
RTG, minimum 800x600 16bit for the small version, the program window of the normal edition is 
1385x820 which means it will open on a 1400x900 screen but might appear borderless. 
1440x900x16 is the recommended minimum screen size.   

AmigaOS4, MorphOS and Aros x86 and WinUAE should run it fine. For classic 68k a PiStorm setup is 
recommended. It does run on A600GS, but drawing operation performs jerky under the Aros68k 
environment while it works more smooth on a OS39 setup. Future A600GS updates might improve 
this situation. I have not tested on a Vampire setup so I do not know the performance there. 
WarpOS versions are available but untested by me. 
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About PolarPaint 

The history behind PolarPaint is that I had an idea to make a online game drawing / guessing game. 
Soon the drawing part catched my interest and my focus went into the drawing features which after 
a while evolved into a paint program. 
Originally I was targeting Android so that is why there wasnt a title menu bar in the start. to the 
program, and a. 

The name PolarPaint is inspired by the fact that the author lives close to the Polar Circle. 

Please feel free to share your thoughts about the program, or if you have questions or bug reports. 
Contact info: anbjorn.myren@gmail.com 
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Changelog (internal build numbering) 
v81  Fix - Check that filename is not same as input file when saving with  
     delay 
     RMB button change when switching mode 
     Missing filters in save fil requestors 
v80  Menu activation button labeled RMB to toggle the usage of RMB button 
     (menu or draw) 
     Fix: Creating a new anim could crash if the anim was larger than half  
     the workspace area 
     Removed a few overlapping keyboard shortcuts 
     Bugfix, save anim with delay crashed on some systems 
     Anim can now also be created in APNG format 
v79  Animation features added, controlled by menu 
     Added menu for animation features. 
     Disabled Ctrl-C to quit.  
     Pixel mode when drawing in zoomed mode 
     Pixel mode for line drawing in zoomed mode 
     Pixel mode for rectangle drawing in zoomed mode 
v78    Optional smoothening for the rotating effect 
       Added one undo operation before entering zoom mode 
v77    Adjustable Bluring level 
       More detailed Position info when capturing brush. Press "m" to 
       display mouse coordinates, and also center xy coords of brush. 
       Right mouse button on brush icon (if brush is captured) to enter XY 
       coordinates for exact brush paste. 
       Press "s" to apply a smoothening effect. 
r76    Bugfix - quit from info window 
r75    Improved sprayeffect 
r74    Loading size detection bugfix, shortcut keys changed/bugfix, 
r73    Experimental spray effect / multidot 
r72    Brush RMB position fix. Corrected transparency requestor info. 
r71    Bug fixes for the undo/redo system, and shortening repetative code.  
       Now working on A600GS. 
r70    Complete rewrite of the undo / redo stack management system. 
r69    Zoom can now be active on multiple workspaces simultaniously 
       Partly loaded images can be on loaded on multiple workspaces 
       simultaniously 
r68    Rectangle starting point will now compensate for border, also when 
       drawing with rotation.  
       Option to scale down a brush which was captured or loaded while in 
       zoomed mode. 
       Rotate Text object 
       Fix, multiple usage of same brush id (16) 
r67    Arc center and ellipse center gets correct center alligned at any 
       angle, regardless of bordersize 
       New: draw rotated rectangles 
       RGB values for all color change operation shows in status area 
r66    Corrected Arc centering 
r65    New: Draw Arc 
r64    New, Draw lines, circles, ellipses and rectangles by coordinates 
r63    Effects adjustment 
       Improved rotate effect, now centers properly 
       Brush now adjusts to center of brush relative to mouse position 
       Status line now also displays size of imported brushes and size of 
       drawn shapes, and RGB values of pickcolor 
       Fix: RMB to replacecolor required extra leftmouse buttonpress 
       Fix: endselect() in threshold floodfill caused an exit-error  
       Fix: fill shape reset 
r62    Fix: GUI glitches after drawing shapes with gradient 
       Fix: Tranparencydraw with filled shapes now works 
       Improved effect settings 
r61    Handle load errors without force quit 
r60    Brush capture aligned to center of pointer (cross) 
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       Abandon brush capture by ESC or if LMB is pressed outside boundries. 
r59    Improved scaling when loading larger images 
       New: ability to load parts of larger images by coordinates and save 
       merge it with source image and save it in original size. 
       Fixed broken brush toggle by using the pencil button 
       Realigned right side icons, reduced window width to 1385 
r58    New, circle drawing 
       Waitleftmouse in replacecolor function to avoid double action 
       Bugfix: sometimes drawing small ellipse and circles did blank the 
       drawing or rectangles vanish 
r57    New 8x Zoom function to fine edit a selected area 
       Adjusted coordinates for some RMB settings 
r56    Reset textcolor after drawing text 
       Rename variable in drawline + rename in comment  
       Line draw fix (draw straigt lines) 
       Rectangle draw improvement 
r55    Merge floodfill functions 
       Transparent mix now can set transparency for both workspaces 
       seperately 
r54    Fix: Drawing Rectangles, Ellipses and Lines when foreground and 
       background color is the same was not working. 
       Fix: Removed duplicate undos' 
       White CLS, If pen is White, then change pen to Black. 
       Drawing coordinates adjusted (near edges) 
       Deselect active brush capture when click to the left of the drawing 
       area 
r53    RMB For settings (icons updated) 
       New: Gradient fill 
       New: Fill box 
       New: ReplaceColor  
       New: TextObject button 
       Transparency settings changed. 
       Fixed RMB transparency draw 
       New: Multipen draw 
       Black CLS, If pen is Black, then change pen to White. 
r52    FloodFill, different handling for threshold > 49 
       New: PickColor 
       Fix: Save to root (eg. RAM: failed) 
r51 and earlier builds have no recorded log 


