<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE rfc [
 <!ENTITY nbsp    "&#160;">
 <!ENTITY zwsp   "&#8203;">
 <!ENTITY nbhy   "&#8209;">
 <!ENTITY wj     "&#8288;">
]>
<rfc category="std" submissionType="IETF" docName="draft-ietf-6man-snac-router-ra-flag-08" number="10075" ipr="trust200902"
     xmlns:xi="http://www.w3.org/2001/XInclude" version="3" updates="" obsoletes="" consensus="true"
     sortRefs="true" symRefs="true" tocDepth="3" tocInclude="true" xml:lang="en">
  <front>
    <title abbrev="SNAC Router RA Flag">
      The SNAC Router Flag in ICMPv6 Router Advertisement Messages
    </title>
    <seriesInfo name="RFC" value="10075"/>
    <author initials="J." surname="Hui" fullname="Jonathan Hui">
      <organization>Google LLC</organization>
      <address>
        <postal>
          <street>1600 Amphitheatre Parkway</street>
          <city>Mountain View</city>
          <region>California</region>
          <code>94043</code>
          <country>United States of America</country>
        </postal>
        <email>jonhui@google.com</email>
      </address>
    </author>

    <date year="2026" month="October"/>
    <area>INT</area>
    <workgroup>6man</workgroup>

    <keyword>stub network</keyword>
    <keyword>stub router</keyword>
    <keyword>IPv6</keyword>
    <keyword>Neighbor Discovery</keyword>
    <keyword>RA Flags Option</keyword>

    <abstract>
      <t>This document defines a new flag, the SNAC Router flag, in the Router Advertisement message that can be used to distinguish configuration information sent by Stub Network Auto-Configuring (SNAC) routers from information sent by transit routers.</t>
    </abstract>
  </front>

  <middle>
    <section>
      <name>Introduction</name>
      <t>Per <xref section="2.1" target="RFC2328"/>, networks can either be transit or stub networks. Transit networks are those capable of carrying data traffic that is neither locally originated nor locally destined.</t>

      <t>A Stub Network Auto-Configuring (SNAC) router is an autonomously configuring router that provides IP connectivity between one or more stub networks and one or more transit networks. A common example of a SNAC router is a device that attaches a 6LoWPAN-based network <xref target="RFC4919"/> to a home network, automatically providing IPv6 forwarding between the two networks without explicit operator configuration. This document defines a new IPv6 Neighbor Discovery Router Advertisement (RA) flag, the SNAC Router flag, which SNAC routers use to identify RAs sent by other SNAC routers.</t>

      <t>Readers can refer to <xref target="I-D.ietf-snac-simple"/> for an overview of a set of practices for automatically connecting IPv6 stub networks to transit networks.</t>
    </section>

    <section>
      <name>SNAC Router Flag</name>

      <t>The SNAC Router flag is bit 6 in the RA Flags Extension Option <xref target="RFC5175"/>.</t>

      <t>The SNAC Router flag bit with a value of '1' is reserved for use by SNAC routers. Receipt of an RA with that bit set to '1' indicates that the sending router is a SNAC router. Describing the exact triggers when a SNAC router sets this flag to '1' is out of scope for this document. An example of such considerations is documented in <xref target="I-D.ietf-snac-simple"/>.</t>

      <t>Consistent with <xref section="4.2" target="RFC4861"/>, devices that do not operate as SNAC routers will not set the SNAC Router flag bit to '1', and devices that do not understand the SNAC Router flag will silently ignore it. This means that setting the flag bit to '1' or '0' should not change the behavior of such devices in any way (other than that it is permissible to log and cache the value of the flag bit as part of normal router advertisement processing, where applicable).</t>
    </section>

    <section>
      <name>IANA Considerations</name>

      <t>IANA has allocated a flag from the "IPv6 ND Router Advertisement Flags" registry in the "Internet Control Message Protocol version 6 (ICMPv6) Parameters" registry group <xref target="IANA-RA-FLAGS"/> as specified below:</t>

      <table>
        <thead>
          <tr>
            <th>RA Option Bit</th>
            <th>Description</th>
            <th>Reference</th>
          </tr>
        </thead>
        <tbody>
          <tr>
            <td>6</td>
            <td>S - SNAC Router Flag</td>
            <td>This Document</td>
          </tr>
        </tbody>
      </table>
    </section>

    <section>
      <name>Operational Considerations</name>

      <t>In environments that implement RA-Guard <xref target="RFC7113"/> in a way that filters RAs sent by SNAC routers, devices on the transit network will never receive an RA with the SNAC Router flag bit set to '1'.</t>
    </section>

    <section>
      <name>Security Considerations</name>

      <t>How SNAC routers process RAs is dependent on the SNAC Router flag value.</t>

      <t>The security considerations of IPv6 Neighbor Discovery are documented in Section <xref target="RFC4861" section="11" sectionFormat="bare">Security Considerations</xref> of <xref target="RFC4861"/>. The addition of the SNAC Router flag does not change these considerations.</t>
    </section>
  </middle>

  <back>
    <displayreference target="I-D.ietf-snac-simple" to="AUTO-STUB"/>
    <references>
      <name>References</name>
    <references>
      <name>Normative References</name>
      <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.4861.xml"/>
      <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.5175.xml"/>
    </references>
    <references>
      <name>Informative References</name>
      <reference anchor="IANA-RA-FLAGS" target="https://www.iana.org/assignments/icmpv6-parameters">
      <front>
        <title>IPv6 ND Router Advertisement Flags</title>
        <author fullname="IANA"/>
     </front>
      </reference>
      <xi:include href="https://bib.ietf.org/public/rfc/bibxml3/reference.I-D.draft-ietf-snac-simple-13.xml"/>
      <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.2328.xml"/>
      <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.4919.xml"/>
      <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.7113.xml"/>
    </references>
  </references>
  </back>
</rfc>
