<?xml version='1.0' encoding='UTF-8'?>

<!DOCTYPE rfc [
  <!ENTITY nbsp    "&#160;">
  <!ENTITY zwsp   "&#8203;">
  <!ENTITY nbhy   "&#8209;">
  <!ENTITY wj     "&#8288;">
]>

<rfc xmlns:xi="http://www.w3.org/2001/XInclude" submissionType="IETF" category="std" consensus="true" docName="draft-ietf-pce-sr-bidir-path-25" number="10067" ipr="trust200902" updates="" obsoletes="" tocInclude="true" tocDepth="3" symRefs="true" sortRefs="false" version="3" xml:lang="en">

  <front>
    <title abbrev="PCEP for Associated Bidirectional SR LSP">Path
    Computation Element Communication Protocol (PCEP) Extensions for
    Associated Bidirectional Segment Routing (SR) LSPs</title>
    <seriesInfo name="RFC" value="10067"/>
    <author fullname="Cheng Li" initials="C." role="editor" surname="Li">
      <organization>Huawei Technologies</organization>
      <address>
        <postal>
          <street>Huawei Campus, No. 156 Beiqing Rd.</street>
          <city>Beijing</city>
          <code>100095</code>
          <country>China</country>
        </postal>
        <email>c.l@huawei.com</email>
      </address>
    </author>
    <author fullname="Mach(Guoyi) Chen" initials="M." surname="Chen">
      <organization>Huawei Technologies</organization>
      <address>
        <postal>
          <street>Huawei Campus, No. 156 Beiqing Rd.</street>
          <city>Beijing</city>
          <code>100095</code>
          <country>China</country>
        </postal>
        <email>mach.chen@outlook.com</email>
      </address>
    </author>
    <author fullname="Weiqiang Cheng" initials="W." surname="Cheng">
      <organization>China Mobile</organization>
      <address>
        <postal>
          <country>China</country>
        </postal>
        <email>chengweiqiang@chinamobile.com</email>
      </address>
    </author>
    <author fullname="Rakesh Gandhi" initials="R." role="editor" surname="Gandhi">
      <organization>Cisco Systems, Inc.</organization>
      <address>
        <postal>
          <country>Canada</country>
        </postal>
        <email>rgandhi@cisco.com</email>
      </address>
    </author>
    <author fullname="Quan Xiong" initials="Q." surname="Xiong">
      <organization>ZTE Corporation</organization>
      <address>
        <postal>
          <country>China</country>
        </postal>
        <email>xiong.quan@zte.com.cn</email>
      </address>
    </author>
    <date month="October" year="2026"/>
    <area>RTG</area>
    <workgroup>pce</workgroup>

<keyword>Bidirectional Co-routed SR LSPs</keyword>
<keyword>Reverse SR LSP</keyword>

    <abstract>
      <t>
    Segment Routing (SR) steers packets through a network using the IPv6 or MPLS data planes via source routing. Stateful Path Computation Element Communication Protocol (PCEP) extensions are defined for SR Traffic Engineering (TE) LSPs.
      </t>
      <t>
PCEP supports grouping two RSVP-TE signaled, unidirectional MPLS-TE Label-Switched Paths (LSPs) where a path in each direction in a network is grouped into an associated bidirectional LSP. 
This document extends PCEP support to group two unidirectional SR LSPs into an associated bidirectional SR LSP. The mechanisms defined in this document apply to both stateless and stateful PCEs for PCE-initiated and PCC-initiated LSPs.
      </t>
    </abstract>
  </front>
  <middle>
    <section>
      <name>Introduction</name>
      <t>Segment Routing (SR) <xref target="RFC8402"/> can 
      be used to steer packets through a network employing source routing. 
      SR can be applied to both MPLS (SR-MPLS) and IPv6 (SRv6) data planes.        
      </t>
      <t><xref target="RFC5440"/> describes the Path Computation Element (PCE)
      Communication Protocol (PCEP). 
      <xref target="RFC8231"/> specifies a set of extensions to PCEP to
      enable stateful control of Traffic Engineering (TE) Label Switched Paths
      (LSPs) within and across PCEP sessions. 
      As described in <xref target="RFC4655"/>, a PCE can be either stateful or stateless.
      <xref target="RFC8664"/> specifies extensions to the PCEP for SR networks that
      allow a stateful PCE to compute and initiate SR TE paths, as well as a
      Path Computation Client (PCC) to request, report, or delegate them.
      </t>
      <t>There are features such as directed Bidirectional Forwarding Detection (BFD)
      <xref target="RFC9612"/> and Performance Measurement
      <xref target="RFC9503"/> that require the ingress
      node (PCC) to be aware of the reverse direction SR path. 
      For such features, the reverse SR paths need to be communicated to the ingress
      nodes (PCCs) using PCEP mechanisms. This allows both endpoint 
      nodes to be aware of the forward and reverse SR paths.
      </t>
      <t>An SR Policy <xref target="RFC9256"/> contains one or more Candidate Paths (CPs), which may be computed by a PCE.
      A Candidate Path of an SR Policy can contain one or more Segment Lists (SLs).
      In PCEP messages, an SL is encoded as an Explicit Route Object (ERO) 
      as described in <xref target="RFC8664" section="4.3"/>.

      <xref target="RFC10066"/> defines PCEP extensions for carrying
      multiple SLs in the PCEP messages along with their opposite direction SLs,
      as described in <xref target="RFC10066" sectionFormat="of" section="4.4"/>. 
      </t>
      <t>As per <xref target="RFC8697"/>, TE LSPs can be associated by adding
      them to a common association group by a PCEP peer. 

      <xref target="RFC9059"/> uses the association group object to group two unidirectional
      RSVP-TE LSPs into an associated bidirectional LSP for both stateful and stateless PCE. 

      This document extends this procedure and allows grouping two unidirectional SR LSPs
      into an associated bidirectional SR LSP for co-routed <xref target="RFC9059"/> and non-co-routed paths. 

      This extension also utilizes the procedure 
      defined in <xref target="RFC10066"/> to carry the multiple EROs 
      and the associated reverse path EROs for an SR LSP.

      Note that the association group and the procedure introduced in this document 
      are specific to SR-TE and SRv6 Path Setup Types.
      </t>
    </section>
    <section>
      <name>Terminology</name>
      <t>The reader is assumed to be familiar with the
      terminology defined in <xref target="RFC8231"/>, <xref target="RFC8281"/>, <xref target="RFC8697"/>, <xref target="RFC8408"/>, 
      <xref target="RFC9059"/>, and <xref target="RFC10066"/>.</t>
      <t>This document uses the following terms defined in <xref target="RFC5440"/>: </t>
      <t>
      Explicit Route Object (ERO), Path Computation Client (PCC), Path Computation Element (PCE), 
      Path Computation Element Communication Protocol (PCEP), PCEP peer, and PCEP speaker.</t>
      <t>This document extends the following term defined in <xref target="RFC3031"/>:
Label Switched Path (LSP) - the base PCEP specification <xref target="RFC4655"/> originally defined the 
      PCE architecture for MPLS and GMPLS networks with LSPs instantiated using the 
      RSVP-TE signaling protocol. 
      As specified in <xref target="RFC9603" section="2"/>, the term "LSP"
      used in the PCEP specifications would be equivalent to an SRv6 path
      (represented as a list of SRv6 segments) in the context of supporting
      SRv6 in PCEP using the SRv6 Path Setup Type.
      </t>
      <section>
        <name>Requirements Language</name>
        <t>
    The key words "<bcp14>MUST</bcp14>", "<bcp14>MUST NOT</bcp14>",
    "<bcp14>REQUIRED</bcp14>", "<bcp14>SHALL</bcp14>", "<bcp14>SHALL NOT</bcp14>",
    "<bcp14>SHOULD</bcp14>", "<bcp14>SHOULD NOT</bcp14>",
    "<bcp14>RECOMMENDED</bcp14>", "<bcp14>NOT RECOMMENDED</bcp14>",
    "<bcp14>MAY</bcp14>", and "<bcp14>OPTIONAL</bcp14>" in this document are to be
    interpreted as described in BCP&nbsp;14 <xref target="RFC2119"/> <xref
    target="RFC8174"/> when, and only when, they appear in all capitals, as
    shown here.
        </t>
      </section>
    </section>
    <section>
      <name>Overview</name>
      <t>Associated bidirectional SR LSPs can be created and updated by a Stateful PCE or by a PCC  
      as described in the subsections below for the case when there are no errors encountered and all operations are successful.
      </t>
      <section>
        <name>PCE-Initiated Associated Bidirectional SR LSPs</name>
        <t>High-level steps for creating associated bidirectional SR LSPs by a Stateful PCE are shown in Figures <xref target="fig1" format="counter"/> and <xref target="fig2" format="counter"/>.</t>
	<ul spacing="normal">
          <li><t>Step 1 - Stateful PCE Behavior:</t>

            <t>Stateful PCE creates and updates the SR LSP and the associated reverse SR LSP EROs, 
        for the "Bidirectional SR LSP Association" with the Association ID 1  
        on a PCC via PCInitiate and PCUpd messages, respectively.</t>
<figure anchor="fig1">
  <name>Step 1: PCE-Initiated Associated Bidirectional SR LSP with Forward-Direction LSPs and Reverse-Direction EROs</name>
        <artwork><![CDATA[
                            +-----+
                            | PCE |
                            +-----+
  PCInitiate:               /     \       PCInitiate:
  Tunnel 1 (0)             /       \      Tunnel 2 (0)
  LSP1 (F1, R2)           /         \     LSP2 (F2, R1)
  Association ID 1       /           \    Association ID 1
  (Single LSP)          /             \   (Single LSP)
                       v               v
                  +-----+    LSP1     +-----+
                  |  S  |------------>|  D  |
                  |     |<------------|     |
                  +-----+    LSP2     +-----+
                        <no signaling>]]></artwork>
</figure>
<dl spacing="compact" newline="false">
 <dt>F1 and F2 =</dt><dd>Forward LSP EROs</dd>
 <dt>R1 and R2 =</dt><dd>Reverse LSP EROs</dd>
 <dt>0 =</dt><dd>PLSP-ID</dd>
 <dt>S =</dt><dd>Source</dd>
 <dt>D =</dt><dd>Destination</dd>
</dl></li>

<li><t>Step 2 - PCC Behavior:</t>
            <t>The PCC, upon receiving the PCInitiate for the SR LSP and the associated reverse SR LSP EROs, locally assigns a 
        PCEP-specific Identifier for the LSP (PLSP-ID) <xref target="RFC8231"/> and reports it to the PCE via a PCRpt message.  
            </t>
<figure anchor="fig2">
  <name>Step 2: PCC-Reported Bidirectional SR LSP with Forward-Direction LSPs and Reverse-Direction EROs</name>
        <artwork><![CDATA[
                            +-----+
                            | PCE |
                            +-----+
  PCRpt:                    ^     ^       PCRpt:
  Tunnel 1 (100)           /       \      Tunnel 2 (200)
  LSP1 (F1, R2==F2)       /         \     LSP2 (F2, R1==F1)
  Association ID 1       /           \    Association ID 1
  (Single LSP)          /             \   (Single LSP)
                       /               \
                  +-----+    LSP1     +-----+
                  |  S  |------------>|  D  |
                  |     |<------------|     |
                  +-----+    LSP2     +-----+
                        <no signaling>]]></artwork>
</figure>
<dl spacing="compact" newline="false">
 <dt>F1 and F2 =</dt><dd>Forward LSP EROs</dd>
 <dt>R1 and R2 =</dt><dd>Reverse LSP EROs</dd>
 <dt>100 and 200 =</dt><dd>PLSP-IDs</dd>
 <dt>S =</dt><dd>Source</dd>
 <dt>D =</dt><dd>Destination</dd>
</dl></li>
</ul>
      </section>
      <section>
        <name>PCC-Initiated Associated Bidirectional SR LSPs</name>
        <t>High-level steps for creating associated bidirectional SR LSPs by a PCC are shown in Figures <xref target="fig3" format="counter"/> and <xref target="fig4" format="counter"/>.</t>
	<ul spacing="normal">
          <li><t>Step 1 - PCC Behavior:</t>
            <t>PCC creates and updates an SR LSP for the "Bidirectional SR LSP Association" with the Association ID 2 and 
        reports the change in the association group of an SR
        LSP to PCE(s) via a PCRpt message.</t>
<figure anchor="fig3">
  <name>Step 1: PCC-Initiated Associated Bidirectional SR LSP with Forward-Direction LSP</name>
        <artwork><![CDATA[
                           +-----+
                           | PCE |
                           +-----+
  Report/Delegate:         ^     ^        Report/Delegate:
  Tunnel 1 (100)          /       \       Tunnel 2 (200)
  LSP1 (F1)              /         \      LSP2 (F2)
  Association ID 2      /           \     Association ID 2
                       /             \
                      /               \
                 +-----+    LSP1     +-----+
                 |  S  |------------>|  D  |
                 |     |<------------|     |
                 +-----+    LSP2     +-----+
                       <no signaling>]]></artwork>
		     </figure>

<dl spacing="compact" newline="false">
  <dt>F1 and F2 =</dt><dd>Forward LSP EROs</dd>
  <dt>100 and 200 =</dt><dd>PLSP-IDs</dd>
  <dt>S =</dt><dd>Source</dd>
  <dt>D =</dt><dd>Destination</dd>
</dl></li>
<li><t>Step 2 - Stateful PCE Behavior:</t>
            <t>Stateful PCE updates the SR LSP and the associated reverse SR LSP EROs, for the "Bidirectional SR LSP Association" on a PCC via a PCUpd message. </t>
<figure anchor="fig4">
  <name>Step 2: PCE-Updated Associated Bidirectional SR LSP with Forward-Direction LSPs and Reverse-Direction EROs</name>
        <artwork><![CDATA[
                           +-----+
                           | PCE |
                           +-----+
  PCUpd:                   /     \        PCUpd:
  Tunnel 1 (100)          /       \       Tunnel 2 (200)
  LSP1 (F1, R2==F2)      /         \      LSP2 (F2, R1==F1)
  Association ID 2      /           \     Association ID 2
  (Single LSP)         /             \    (Single LSP)
                      v               v
                 +-----+    LSP1     +-----+
                 |  S  |------------>|  D  |
                 |     |<------------|     |
                 +-----+    LSP2     +-----+
                       <no signaling>]]></artwork>
		     </figure>
<dl spacing="compact" newline="false">
  <dt>F1 and F2 =</dt><dd>Forward LSP EROs</dd>
  <dt>R1 and R2 =</dt><dd>Reverse LSP EROs</dd>
  <dt>100 and 200 =</dt><dd>PLSP-IDs</dd>
  <dt>S =</dt><dd>Source</dd>
  <dt>D =</dt><dd>Destination</dd>
</dl>
          </li>
        </ul>
      </section>
    </section>
    <section>
      <name>PCEP Extensions</name>
      <t>Two unidirectional SR LSPs (one in each
      direction between two nodes in a network) can be associated together by using the
      association group defined in this document for the PCEP messages and employing the 
      procedures defined in <xref target="RFC9059"/> and <xref target="RFC10066"/>.</t>
      <section anchor="double-sided">
        <name>Bidirectional SR LSP Association Group</name>
        <t>For associating two unidirectional SR LSPs, this document defines
        a new Association Type called "Bidirectional SR LSP  
        Association" for the Association Group object (Class-Value 40) as follows: 
        </t>
        <ul spacing="normal">
          <li>
            <t>Association Type (value 8) = Bidirectional SR LSP Association</t>
          </li>
        </ul>
        <t>The handling of the Association ID, Association Source, optional
        Global Association Source and optional Extended Association ID in this
        association are set as defined in <xref target="RFC8697"/>.</t>
        <t><xref target="RFC8697"/> specifies the mechanism for the capability
        advertisement of the Association Types supported by a PCEP speaker by
        defining an ASSOC-Type-List TLV (value 35) to be carried within an
        OPEN object. The PCEP speaker <bcp14>MUST</bcp14> include the "Bidirectional SR LSP 
        Association" type in the ASSOC-Type-List TLV and <bcp14>MUST</bcp14> receive the same
        from the PCEP peer before using it in the PCEP messages.</t>
        <t>An SR LSP <bcp14>MUST NOT</bcp14> be part of more than
        one "Bidirectional SR LSP Association" on a PCE.
        A PCE, upon detecting this condition, <bcp14>MUST NOT</bcp14> send the associated reverse 
        EROs to the ingress node PCC.
        This error condition <bcp14>MUST</bcp14> be logged and an alarm <bcp14>MUST</bcp14> be generated.
        </t>
      </section>
      <section>
        <name>Bidirectional LSP Association Group TLV</name>
        <t>
        A PCEP message for an associated bidirectional SR LSP  
        <bcp14>MAY</bcp14> include the "Bidirectional LSP Association Group TLV" to indicate 
        the co-routed path using the C flag defined in <xref target="RFC9059" section="4.2"/>.
        </t>
        <t>
        As there is no reverse SR LSP instantiated, 
        the Reverse LSP (R flag) <bcp14>MUST NOT</bcp14> be set for an associated bidirectional SR LSP 
        and <bcp14>MUST</bcp14> be ignored. This error condition <bcp14>MUST</bcp14> be logged and an alarm <bcp14>MUST</bcp14> be generated.
        </t>
      </section>
      <section>
        <name>PATH-ATTRIB Object</name>
        <t>
        When a PCE informs an ingress node PCC about the associated reverse SR LSP EROs computed for an SR LSP with  
        the "Bidirectional SR LSP Association", it <bcp14>MUST</bcp14> include 
        the "PATH-ATTRIB" object with the Reverse (R flag) set to 1 to indicate 
        that the ERO is for the reverse direction <xref target="RFC10066"/>.
        </t>
      </section>
      <section>
        <name>MULTIPATH-OPPDIR-PATH TLV</name>
        <t>
        The PCE <bcp14>MAY</bcp14> include 
        the "MULTIPATH-OPPDIR-PATH TLV" to indicate the co-routed path properties (in the N-flag and L-flag) 
        for the reverse ERO <xref target="RFC10066"/> for an SR LSP.
        </t>
        <t>
        The PCC <bcp14>MUST</bcp14> detect the mismatch between the co-routed path properties in the "MULTIPATH-OPPDIR-PATH TLV" for the reverse ERO and
        the co-routed path (C) flag in the "Bidirectional LSP Association Group TLV" for the (forward) SR LSP 
        and log it as an error condition and generate an alarm. 
        </t>
      </section>
    </section>
    <section>
      <name>Additional PCEP Considerations</name>
      <t>Additional considerations for associating bidirectional SR LSPs are summarized in the subsections below.
      </t>
      <section>
        <name>PLSP-ID Usage</name>
        <t>As per <xref target="RFC8231"/>, an ingress node PCC reports a unique PLSP-ID for each LSP of an SR Policy. 
        For an associated bidirectional SR LSP, 
        the PCE will maintain two PLSP-IDs, one from the ingress node PCC and one from the egress node PCC.
        In the examples shown in Figures <xref target="fig2" format="counter"/> and <xref target="fig3" format="counter"/>, the ingress node PCC (node S) reports Tunnel 1, LSP1 to the PCE 
        with PLSP-ID 100 whereas the egress node PCC (node D) reports Tunnel 2, LSP2 to the PCE with PLSP-ID 200.
        </t>
      </section>
      <section>
        <name>Error Handling</name>
        <t>The error handling as described in <xref target="RFC9059" section="5.7"/> 
      continues to apply for the "Bidirectional SR LSP Association".
        </t>
        <t>
      The PCEP Path Setup Type (PST) for SR LSP uses either value "1: Traffic-engineering path is set up using Segment Routing" 
      <xref target="RFC8664"/> or "3: Traffic engineering path is set up using SRv6" <xref target="RFC9603"/>. 
      If a PCEP speaker receives a non-SR LSP PST value for the "Bidirectional 
      SR LSP Association", the PCEP speaker <bcp14>MUST</bcp14> return a PCErr message with 
      Error-Type = 26 (Association Error) and Error-value = "16: Path Setup Type not supported" <xref target="RFC9059"/>.
        </t>
      </section>
    </section>
    <section anchor="Security">
      <name>Security Considerations</name>
      <t>The security considerations described in <xref target="RFC5440"/>,
      <xref target="RFC8231"/>, <xref target="RFC8281"/>, <xref target="RFC8408"/>, <xref target="RFC9059"/>,  
      and <xref target="RFC10066"/> apply to the extensions defined in this document as well.</t>
      <t>A new Association Type for the Association object, 
      "Bidirectional SR LSP Association", is introduced in this
      document. Additional security considerations related to LSP associations
      due to a malicious PCEP speaker are described in <xref target="RFC8697"/> and apply to this Association Type. Hence, securing
      the PCEP session using Transport Layer Security (TLS) <xref target="RFC8253"/>, <xref target="RFC9916"/>, 
      as per the recommendations and best current practices in <xref target="RFC9325"/> is <bcp14>RECOMMENDED</bcp14>.
      </t>
    </section>
    <section anchor="Manage">
      <name>Operational Considerations</name>
      <t>The manageability requirements and considerations listed in <xref target="RFC5440"/>, <xref target="RFC8231"/>, <xref target="RFC8281"/>, <xref target="RFC8697"/>,  
      and <xref target="RFC10066"/> apply to the PCEP protocol extensions defined in this
      document. In addition, the operational requirements and considerations listed in this
      section apply.</t>
      <section>
        <name>Control of Function and Policy</name>
        <t>The mechanisms defined in this document do not imply any new control or
        policy requirements. 
        </t>
      </section>
      <section>
        <name>Information and Data Models</name>
        <t><xref target="RFC7420"/> describes the PCEP MIB; there are no new
        MIB Objects defined for LSP associations.
        </t>
        <t>
        The PCEP YANG module <xref target="RFC9826"/> defines a data model for LSP associations.
        However, it does not include information for associated bidirectional SR LSPs.
        It can be extended to include data related to the associated bidirectional SR LSPs, such as:</t>
        <ul spacing="normal">
          <li>Indication of whether the associated bidirectional SR LSPs are supported</li>
          <li>Enablement and disablement of the bidirectional SR LSP association</li>
          <li>Counters for the successfully associated bidirectional SR LSPs</li>
          <li>Counters for the SR LSPs that failed to form a bidirectional association</li>
	</ul>
      </section>
      <section>
        <name>Liveness Detection and Monitoring</name>
        <t>Mechanisms defined in this document do not imply any new liveness
    detection and monitoring requirements as they are performed independently on both sides of a bidirectional SR LSP, 
    using the forward and reverse LSP paths of the bidirectional SR LSP.
    However, the monitoring on both sides of a bidirectional SR LSP needs to be correlated at the management level to ensure that
    the bidirectional service carried by the bidirectional SR LSP is operational.  
        </t>
      </section>
      <section>
        <name>Verify Correct Operations</name>
        <t>Mechanisms defined in this document do not imply any new operation
        verification requirements.
        </t>
      </section>
      <section>
        <name>Requirements on Other Protocols</name>
        <t>Mechanisms defined in this document do not imply any new
        requirements on other protocols.</t>
      </section>
      <section>
        <name>Impact on Network Operations</name>
        <t>Associating two SR LSPs to form an associated bidirectional SR LSP requires an operator to ensure that 
        the correct LSP associations are employed on both sides of the bidirectional SR LSP.
        Tools such as directed BFD <xref target="RFC9612"/> and Performance Measurement
        <xref target="RFC9503"/> can be used to verify the correct operation of a bidirectional SR LSP.
        </t>
      </section>
    </section>
    <section anchor="IANA">
      <name>IANA Considerations</name>
      <section>
        <name>Association Type</name>
        <t>IANA has registered the following Association Type 
        for the Association Group object (Class-Value 40) in the "ASSOCIATION Type Field" registry <xref target="RFC8697"/> within the "Path Computation Element Protocol (PCEP) Numbers" registry group (see <eref target="https://www.iana.org/assignments/pcep" brackets="angle"/>): </t>
        

	<table>
	  <thead>
	    <tr>
	      <th>Type</th>
              <th>Name</th>
              <th>Reference</th>
	    </tr>
	  </thead>
	  <tbody>
	    <tr>
	      <td>8</td>
              <td>Bidirectional SR LSP Association</td>
	      <td>RFC 10067</td>
	    </tr>
	  </tbody>
	</table>

      </section>
    </section>
  </middle>
  <back>
    <references>
      <name>References</name>
      <references>
        <name>Normative References</name>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.2119.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.3031.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.5440.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8174.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8231.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8253.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8281.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8402.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8408.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8664.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8697.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9059.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9256.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9325.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9603.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9916.xml"/>
<!-- draft-ietf-pce-multipath: RFC-to-be 10066 -->

        <reference anchor="RFC10066" target="https://www.rfc-editor.org/info/rfc10066">
          <front>
            <title>Path Computation Element Communication Protocol (PCEP) Extensions for Signaling
              Multipath Information</title>
            <author fullname="Mike Koldychev" initials="M." surname="Koldychev" role="editor">
              <organization>Ciena Corporation</organization>
            </author>
            <author fullname="Samuel Sidor" initials="S." surname="Sidor" role="editor">
              <organization>Cisco Systems.</organization>
            </author>
            <date month='October' year='2026' />
          </front>
          <seriesInfo name="RFC" value="10066" />
          <seriesInfo name="DOI" value="10.17487/RFC10066" />
        </reference>

      </references>
      <references>
        <name>Informative References</name>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.4655.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.7420.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9503.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9612.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9826.xml"/>
      </references>
    </references>
    <section numbered="false">
      <name>Acknowledgments</name>
      <t>
    Many thanks to <contact fullname="Marina Fizgeer"/>, <contact fullname="Adrian Farrel"/>, <contact fullname="Andrew Stone"/>, <contact fullname="Tarek
    Saad"/>, <contact fullname="Samuel Sidor"/>, and <contact fullname="Mike Koldychev"/> for the detailed review of this document and
    for providing many useful comments. 
    Also, thank you, <contact fullname="John Scudder"/>, for the RtgDir Early review, <contact fullname="Carlos Pignataro"/> for the OpsDir review, 
    <contact fullname="Dhruv Dhody"/> for the Shepherd review, <contact fullname="Ketan Talaulikar"/> for the WG AD review, <contact fullname="Meral Shirazipour"/> for Genart review, and <contact fullname="Mohamed Boucadair"/>, 
    <contact fullname="Éric Vyncke"/>, <contact fullname="Deb Cooley"/>, <contact fullname="Mahesh Jethanandani"/>, <contact fullname="Mike Bishop"/>, and <contact fullname="Gunter Van de Velde"/> for the IESG review, which helped 
    improve this document.</t>
    </section>
    <section numbered="false">
      <name>Contributors</name>
      <t>The following people have substantially contributed to this document:</t>

 <contact fullname="Dhruv Dhody">
   <organization>Huawei Technologies</organization>
   <address>
     <postal>
       <street>Divyashree Techno Park, Whitefield</street>
       <city>Bangalore</city><region>Karnataka</region><code>560066</code>
       <country>India</country>
     </postal>
     <email>dhruv.ietf@gmail.com</email>
   </address>
 </contact>

 <contact fullname="Zhenbin Li">
   <organization>Huawei Technologies</organization>
   <address>
     <postal>
       <street>Huawei Campus, No. 156 Beiqing Rd.</street>
       <city>Beijing</city><code>100095</code>
       <country>China</country>
     </postal>
     <email>lizhenbin@huawei.com</email>
   </address>
 </contact>

 <contact fullname="Jie Dong">
   <organization>Huawei Technologies</organization>
   <address>
     <postal>
       <street>Huawei Campus, No. 156 Beiqing Rd.</street>
       <city>Beijing</city><code>100095</code>
       <country>China</country>
     </postal>
     <email>jie.dong@huawei.com</email>
   </address>
 </contact>
    </section>
    
  </back>
</rfc>
