<?xml version='1.0' encoding='utf-8'?>
<!DOCTYPE rfc [
  <!ENTITY nbsp    "&#160;">
  <!ENTITY zwsp   "&#8203;">
  <!ENTITY nbhy   "&#8209;">
  <!ENTITY wj     "&#8288;">
]>
<?xml-stylesheet type="text/xsl" href="rfc2629.xslt" ?>
<!-- generated by https://github.com/cabo/kramdown-rfc version 1.7.43 (Ruby 2.5.9) -->
<rfc xmlns:xi="http://www.w3.org/2001/XInclude" ipr="trust200902" docName="draft-ietf-ntp-roughtime-19" category="exp" consensus="true" submissionType="IETF" xml:lang="en" number="10049" tocInclude="true" sortRefs="true" symRefs="true" version="3">
  <!-- xml2rfc v2v3 conversion 3.34.1 -->
  <link href="https://datatracker.ietf.org/doc/draft-ietf-ntp-roughtime-19" rel="prev"/>
  <front>
    <title abbrev="Roughtime">Roughtime: A Protocol for Rough Time Synchronization</title>
    <seriesInfo name="RFC" value="10049"/>
    <author fullname="Watson Ladd" initials="W." surname="Ladd">
      <organization>Akamai Technologies</organization>
      <address>
        <email>watsonbladd@gmail.com</email>
      </address>
    </author>
    <author fullname="Marcus Dansarie" initials="M." surname="Dansarie">
      <organization>Netnod</organization>
      <address>
        <email>marcus@dansarie.se</email>
        <uri>https://orcid.org/0000-0001-9246-0263</uri>
      </address>
    </author>
    <date year="2026" month="October"/>
    <area>INT</area>
    <workgroup>ntp</workgroup>
    <keyword>timing</keyword>
    <keyword>authenticity</keyword>
    <keyword>roughtime</keyword>
    <abstract>
      <?line 51?>

<t>This document describes Roughtime, an experimental protocol that aims
to achieve two things: secure, rough time synchronization (even for
clients without any idea of what time it is) and a format for
clients to report any inconsistencies they observe between timeservers.
This document specifies the on-wire protocol required for these goals
and discusses aspects of the ecosystem needed for it to work.</t>
    </abstract>
  </front>
  <middle>
    <?line 60?>

<section anchor="introduction">
      <name>Introduction</name>
      <t>Time synchronization is essential to Internet security as many
security protocols and other applications require it <xref target="RFC0738"/>.
Unfortunately, widely deployed protocols such as the Network Time
Protocol (NTP) <xref target="RFC5905"/> lack essential security features, and even
newer protocols like Network Time Security (NTS) <xref target="RFC8915"/> lack
mechanisms to observe that the servers behave correctly. Furthermore,
clients may lack even a basic idea of the time, creating bootstrapping
problems as time is required for X.509 certificate validation.</t>
      <t>The primary design goal of Roughtime is to permit devices to obtain a
rough idea of the current time from a fairly static configuration and
to enable them to report any inconsistencies they observe between
servers. The configuration consists of a list of servers and their
associated long-term keys, which ideally remain unchanged throughout a
server's lifetime. This makes the long-term public keys the roots of
trust in Roughtime. With a sufficiently long list of trusted servers
and keys, a client will be able to acquire authenticated time with
high probability, even after long periods of inactivity. Proofs of
malfeasance constructed by chaining together responses from different
trusted servers can be used to prove misbehavior by a server and,
after analysis, can result in revoking trust in that particular key.</t>
      <t>Unlike Khronos <xref target="RFC9523"/>, Roughtime produces external evidence that
time servers are reporting incompatible times. This requires changes to
the format of the timestamps and hence cannot be a mere extension to
NTP.</t>
      <t>Operational experience is needed to evaluate the viability of using
Roughtime for secure time bootstrapping in Internet-connected systems.
This includes the need for experience with maintaining a Roughtime
ecosystem with services that maintain and distribute lists of trusted
servers and process malfeasance reports. To facilitate the experiments
necessary to gain that experience, this document is limited to
describing the Roughtime on-wire protocol. Apart from describing the
server list and malfeasance report formats, this document does not
describe the ecosystem, nor the means by which the server list is
maintained and distributed or the policies to apply to such a list.</t>
    </section>
    <section anchor="conventions">
      <name>Conventions</name>
      <t>The key words "<bcp14>MUST</bcp14>", "<bcp14>MUST NOT</bcp14>", "<bcp14>REQUIRED</bcp14>", "<bcp14>SHALL</bcp14>", "<bcp14>SHALL
NOT</bcp14>", "<bcp14>SHOULD</bcp14>", "<bcp14>SHOULD NOT</bcp14>", "<bcp14>RECOMMENDED</bcp14>", "<bcp14>NOT RECOMMENDED</bcp14>",
"<bcp14>MAY</bcp14>", and "<bcp14>OPTIONAL</bcp14>" in this document are to be interpreted as
described in BCP 14 <xref target="RFC2119"/> <xref target="RFC8174"/> when, and only when, they
appear in all capitals, as shown here.</t>
      <?line -18?>

</section>
    <section anchor="protocol-overview">
      <name>Protocol Overview</name>
      <t>Roughtime is a protocol for authenticated, rough time synchronization
that enables clients to provide cryptographic proof of server
malfeasance. It does so by having responses from servers include a
signature over a value derived from the client's request, which
includes a nonce. This provides cryptographic proof that the response
was issued after the server received the client's request. The derived
value included in the server's response is the root of a Merkle tree
<xref target="Merkle"/> that includes the hash value of the client's request as
the value of one of its leaf nodes. This tree enables the server to
amortize the relatively costly signing operation over a number of
client requests.</t>
      <section anchor="single-server-mode">
        <name>Single Server Mode</name>
        <t>At its most basic level, Roughtime is a one-round protocol in which a
completely fresh client requests the current time and the server sends
a signed response. The response includes a timestamp and a radius used
to indicate the server's certainty about the reported time.</t>
        <t>The client's request contains a nonce that the server incorporates
into its signed response. The client can verify the server's
signatures and -- provided that the nonce has sufficient
entropy -- this proves that the signed response could only have
been generated after the nonce.</t>
      </section>
      <section anchor="multi-server-mode">
        <name>Multi-server Mode</name>
        <t>When using multiple servers, a client can detect, cryptographically
prove, and report inconsistencies between different servers.</t>
        <t>A Roughtime server guarantees that the timestamp included in the
response to a request is generated after the reception of the request
and prior to the transmission of the associated response. If the time
response from a server is not consistent with time responses from
other servers, this indicates server error or intentional malfeasance
that can be reported and potentially used to impeach the server.</t>
        <t>Proofs of malfeasance are constructed by chaining requests to
different Roughtime servers. Details on proofs and malfeasance
reporting are provided in <xref target="roughtime-clients"/>. For the reporting to
result in impeachment, an additional mechanism is required that
provides a review and impeachment process. Defining such a mechanism
is beyond the scope of this document. A simple option could be an
online forum where a court of human observers evaluate cases after
reviewing input reports.</t>
      </section>
    </section>
    <section anchor="message-format">
      <name>Message Format</name>
      <t>Roughtime messages are maps consisting of one or more (tag, value)
pairs. They start with a header, which contains the number of pairs,
the value offsets, and the tags. The header is followed by a message
values section, which contains the values associated with the tags in
the header. Messages are formatted according to <xref target="figmessage"/> as
described in the following subsections.</t>
      <t>In some cases, messages are recursive, i.e., the value of a tag can
itself be a Roughtime message.</t>
      <figure anchor="figmessage">
        <name>Roughtime Message</name>
        <artwork><![CDATA[
 0                   1                   2                   3
 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                   Number of pairs, N (uint32)                 |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                                                               |
.                                                               .
.                     N-1 offsets (uint32)                      .
.                                                               .
|                                                               |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                                                               |
.                                                               .
.                        N tags (uint32)                        .
.                                                               .
|                                                               |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                                                               |
.                                                               .
.                           N values                            .
.                                                               .
|                                                               |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
]]></artwork>
      </figure>
      <section anchor="data-types">
        <name>Data Types</name>
        <section anchor="uint32">
          <name>uint32</name>
          <t>A uint32 is a 32-bit unsigned integer. It is serialized with the least
significant byte first.</t>
        </section>
        <section anchor="uint64">
          <name>uint64</name>
          <t>A uint64 is a 64-bit unsigned integer. It is serialized with the least
significant byte first.</t>
        </section>
        <section anchor="type-tag">
          <name>Tag</name>
          <t>Tags are used to identify values in Roughtime messages. A tag is a
sequence of four octets. Each tag sequence starts with one to four
capital ASCII letters (A-Z) <xref target="RFC0020"/> followed by zero to three
padding zero octets. Throughout this document, tags are referred to by
their ASCII string representation. However, they are registered and
sorted as uint32 values, where the least significant byte is the first
octet in the sequence.</t>
          <t>For example, the ASCII string "NONC" would correspond to the uint32
0x434e4f4e, which is serialized as {0x4e, 0x4f, 0x4e, 0x43}. "VER"
would correspond to 0x00524556 and be serialized as
{0x56, 0x45, 0x52, 0x00}.</t>
        </section>
        <section anchor="timestamp">
          <name>Timestamp</name>
          <t>A timestamp is a representation of UTC time as a uint64 count of
seconds since 00:00:00 on 1 January 1970 (the Unix epoch), assuming
every day has 86400 seconds. This is a constant offset from the NTP
timestamp in seconds. Leap seconds do not have an unambiguous
representation in a timestamp, and this has implications for the
attainable accuracy and setting of the RADI tag (see
<xref target="response-srep"/>).</t>
        </section>
      </section>
      <section anchor="header">
        <name>Header</name>
        <t>As illustrated in <xref target="figmessage"/>, the first four bytes of the header
is the uint32 number of tags <tt>N</tt>, and hence of (tag, value) pairs. The
following <tt>4*(N-1)</tt> bytes are offsets, each a uint32, and the last
<tt>4*N</tt> bytes in the header are tags.</t>
        <t>The offsets array is considered to have an implicitly encoded value of
0 as its zeroth entry. Its members refer to the positions of the tag
values in the message values section. All offsets are multiples of
four.</t>
        <t>The members of the offsets and tags arrays, as well as the message
values section are sorted in ascending order by the tag's uint32
value. As a consequence, the offset array is also sorted in ascending
order. A tag <bcp14>MUST NOT</bcp14> appear more than once in a header.</t>
        <t>The first post-header byte, i.e., the first byte of the message values
section, is at offset 0. The value associated with the ith tag begins
at offset[i] and ends at offset[i+1]-1, with the exception of the last
value, which ends at the end of the message. Values <bcp14>MAY</bcp14> have zero
length. All lengths and offsets are in bytes.</t>
      </section>
    </section>
    <section anchor="protocol-details">
      <name>Protocol Details</name>
      <t>As described in <xref target="protocol-overview"/>, clients initiate time
synchronization by sending requests containing a nonce to servers who
send signed time responses in return. Roughtime packets can be sent
between clients and servers either as UDP datagrams or via TCP
streams. Servers <bcp14>SHOULD</bcp14> support both the UDP and TCP transport modes.</t>
      <t>Roughtime packets are formatted according to <xref target="figpack"/> and as
described here. The first field is a uint64 with the value
0x4d49544847554f52 ("ROUGHTIM" in ASCII). The second field is a uint32
and contains the length of the third field. The third and last field
contains a Roughtime message as specified in <xref target="message-format"/>.</t>
      <figure anchor="figpack">
        <name>Roughtime Packet</name>
        <artwork><![CDATA[
 0                   1                   2                   3
 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                  0x4d49544847554f52 (uint64)                  |
|                        ("ROUGHTIM")                           |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                    Message length (uint32)                    |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                                                               |
.                                                               .
.                      Roughtime message                        .
.                                                               .
|                                                               |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
]]></artwork>
      </figure>
      <t>Roughtime request and response packets <bcp14>MUST</bcp14> be transmitted in a single
datagram when the UDP transport mode is used. Setting the packet's
Don't Fragment bit <xref target="RFC0791"/> is <bcp14>OPTIONAL</bcp14> in IPv4 networks. Setting
it may cause packets to get dropped, but not setting it could lead to
long delays due to reconstruction and dropped fragments.</t>
      <t>A Roughtime packet could exceed the maximum deliverable length of a
packet on a particular path, making Roughtime queries over UDP
impossible on that path. A client <bcp14>SHOULD</bcp14> attempt to use the TCP
transport mode for Roughtime queries to a server if it does not
receive responses to its UDP queries.</t>
      <t>Clients <bcp14>MUST</bcp14> implement exponential backoff in establishing TCP
connections and making requests over UDP. It is <bcp14>RECOMMENDED</bcp14> that
clients use an initial retry interval of 1 second, a maximum interval
of 24 hours, and a base of 1.5. Therefore, the minimum interval, in
seconds, before retrying after <tt>n</tt> failures is <tt>min(1.5^(n-1),
86400)</tt>. Guidance for implementers considering other values can be
found in <xref section="3.1.3" sectionFormat="of" target="RFC8085"/>.</t>
      <t>Clients <bcp14>MUST NOT</bcp14> reset the retry interval until they receive a
properly signed response.</t>
      <t>Multiple requests and responses can be exchanged over an established
TCP connection. Clients <bcp14>MAY</bcp14> send multiple outstanding requests and
servers <bcp14>MAY</bcp14> send responses out of order. The connection <bcp14>SHOULD</bcp14> be
closed by the client when it has no more requests to send and has
received all expected responses. Either side <bcp14>SHOULD</bcp14> close the
connection in response to synchronization, format,
implementation-defined timeouts, or other errors.</t>
      <t>All requests and responses contain the VER tag. It contains a list of
one or more uint32 version numbers. The version of Roughtime specified
by this document has version number 1.</t>
      <section anchor="requests">
        <name>Requests</name>
        <t>A request contains the tags VER, NONC, and TYPE. It <bcp14>SHOULD</bcp14> include the
tag SRV. Unknown tags <bcp14>MUST</bcp14> be ignored by the server. Requests not
containing the three mandatory tags <bcp14>MUST</bcp14> be ignored. A future version
of this protocol may mandate additional tags in the message and assign
them semantic meaning.</t>
        <t>The size of the request message <bcp14>SHOULD</bcp14> be at least 1024 bytes when the
UDP transport mode is used. To attain this size, the ZZZZ tag is added
to the message. A reason for sending request messages smaller could be
to use the UDP transport mode over paths with low maximum deliverable
length. However, responding to request messages shorter than 1024
bytes is <bcp14>OPTIONAL</bcp14> and servers <bcp14>MUST NOT</bcp14> send responses larger than the
request messages they are replying to; see <xref target="amplification-attacks"/>.</t>
        <section anchor="request-ver">
          <name>VER</name>
          <t>In a request, the VER tag contains a list of uint32 version numbers.
The VER tag <bcp14>MUST</bcp14> include at least one Roughtime version supported by
the client and <bcp14>MUST NOT</bcp14> contain more than 32 version numbers. The
version numbers and tags included in the request <bcp14>MUST</bcp14> be compatible
with each other and the packet contents.</t>
          <t>The version numbers <bcp14>MUST NOT</bcp14> repeat and <bcp14>MUST</bcp14> be sorted in ascending
numerical order.</t>
          <t>Servers <bcp14>MUST</bcp14> ignore any unknown version numbers in the list supplied
by the client. If the list contains no version numbers supported by
the server, it <bcp14>MAY</bcp14> respond with another version or ignore the request
entirely; see <xref target="response-srep"/>.</t>
        </section>
        <section anchor="nonc">
          <name>NONC</name>
          <t>The value of the NONC tag is a 32-byte nonce. It <bcp14>SHOULD</bcp14> be generated
in a manner indistinguishable from random. RFC 4086 <xref target="BCP106"/>
contains specific guidelines regarding this. <xref target="measurement-sequence"/>
describes how to securely generate nonces when querying multiple
servers in sequence.</t>
        </section>
        <section anchor="type">
          <name>TYPE</name>
          <t>The TYPE tag is used to unambiguously distinguish between request and
response messages. In a request, it <bcp14>MUST</bcp14> contain a uint32 with value
0. Requests containing a TYPE tag with any other value <bcp14>MUST</bcp14> be ignored
by servers.</t>
        </section>
        <section anchor="srv">
          <name>SRV</name>
          <t>The SRV tag is used by the client to indicate which long-term public
key it expects to verify the response with. The value of the SRV tag
is <tt>H(0xff || public_key)</tt> where <tt>public_key</tt> is the server's
long-term, 32-byte Ed25519 public key, and <tt>H</tt> is SHA-512 truncated to
the first 32 bytes.</t>
        </section>
        <section anchor="zzzz">
          <name>ZZZZ</name>
          <t>The ZZZZ tag is used to expand the request to the minimum required
length. Its value is all zero bytes.</t>
        </section>
      </section>
      <section anchor="responses">
        <name>Responses</name>
        <t>The server begins the request handling process with a set of long-term
keys. It resolves which long-term key to use with the following
procedure:</t>
        <ol spacing="normal" type="1"><li>
            <t>If the request contains a SRV tag, then the server looks up the
long-term key indicated by the SRV value. If no such key exists,
then the server <bcp14>MUST</bcp14> ignore the request.</t>
          </li>
          <li>
            <t>If the request contains no SRV tag, but the server has just one
long-term key, it <bcp14>SHOULD</bcp14> select that key. Otherwise, if the server
has multiple long-term keys, then it <bcp14>MUST</bcp14> ignore the request.</t>
          </li>
        </ol>
        <t>A response contains the tags SIG, NONC, TYPE, PATH, SREP, CERT, and
INDX. The structure of a response message is illustrated in
<xref target="figresponse"/>.</t>
        <figure anchor="figresponse">
          <name>Roughtime Response Message Structure</name>
          <artwork><![CDATA[
|--SIG
|--NONC
|--TYPE
|--PATH
|--SREP
|  |--VER
|  |--RADI
|  |--MIDP
|  |--VERS
|  |--ROOT
|--CERT
|  |--SIG
|  |--DELE
|  |  |--PUBK
|  |  |--MINT
|  |  |--MAXT
|--INDX
]]></artwork>
        </figure>
        <t>No mechanism for reporting errors -- such as wrong request format,
unsupported version, or unknown SRV value -- back to the client is
provided. This is based on experience from the NTP protocol, where
Kiss-o'-Death packets (see <xref section="7.4" sectionFormat="of" target="RFC5905"/>) are used to
indicate errors. The existence of this unauthenticated protocol
feature in NTP makes it possible for on-path attackers to make a
client stop using authenticated modes or certain servers altogether
(see <xref section="5.4" sectionFormat="of" target="RFC8633"/> and Sections <xref target="RFC8915" section="8.3" sectionFormat="bare"/> and <xref target="RFC8915" section="8.7" sectionFormat="bare"/> of <xref target="RFC8915"/>). Considering the protocol's dependence on multiple
independent servers for security, error reporting functionality has
been excluded from this version of Roughtime.</t>
        <section anchor="sig">
          <name>SIG</name>
          <t>In general, a SIG tag value is a 64-byte Ed25519 signature
<xref target="RFC8032"/> over a concatenation of a context string
and the entire value of a tag. All context strings include a
terminating zero byte.</t>
          <t>The SIG tag in the root of a response is a signature over the SREP
value using the public key contained in CERT and the context string
"Roughtime v1 response signature".</t>
        </section>
        <section anchor="nonc-1">
          <name>NONC</name>
          <t>The NONC tag contains the nonce of the message being responded to.</t>
        </section>
        <section anchor="type-1">
          <name>TYPE</name>
          <t>In a response, the TYPE tag <bcp14>MUST</bcp14> contain a uint32 with value 1.
Responses containing a TYPE tag with any other value <bcp14>MUST</bcp14> be ignored
by clients.</t>
        </section>
        <section anchor="path">
          <name>PATH</name>
          <t>The PATH tag value is a multiple of 32 bytes long and represents a
path of 32-byte hash values in the Merkle tree used to generate the
ROOT value as described in <xref target="merkle-tree"/>. In the case where a
response is prepared for a single request and the Merkle tree contains
only the root node, the size of PATH is zero.</t>
          <t>The PATH <bcp14>MUST NOT</bcp14> contain more than 32 hash values. The maximum length
of PATH is normally limited by the maximum size of the response
message; see Sections <xref target="requests" format="counter"/> and <xref target="amplification-attacks" format="counter"/>. Server
implementations <bcp14>MUST</bcp14> select a maximum Merkle tree height (see
<xref target="merkle-tree"/>) that ensures this.</t>
        </section>
        <section anchor="response-srep">
          <name>SREP</name>
          <t>The SREP tag contains a signed response. Its value is a Roughtime
message with the tags VER, RADI, MIDP, VERS, and ROOT.</t>
          <t>The VER tag, when used in a response, contains a single uint32 version
number. It <bcp14>SHOULD</bcp14> be one of the version numbers supplied by the client
in its request; see <xref target="request-ver"/>. The server <bcp14>MUST</bcp14> ensure that the
version number corresponds with the rest of the packet contents.</t>
          <t>The RADI tag value is a uint32 representing the server's estimate of
the accuracy of MIDP in seconds. Servers <bcp14>MUST</bcp14> ensure that the true
time is within <tt>(MIDP-RADI, MIDP+RADI)</tt> at the moment of processing.
The value of RADI <bcp14>MUST NOT</bcp14> be zero. Since leap seconds cannot be
unambiguously represented by Roughtime timestamps, servers <bcp14>MUST</bcp14> take
this into account when setting the RADI value during leap second
events. Servers that do not have any leap second information <bcp14>SHOULD</bcp14>
set the value of RADI to at least 3. Failure to do so will impact the
observed correctness of Roughtime servers and can lead to malfeasance
reports.</t>
          <t>The MIDP tag value is the timestamp of the moment of processing.</t>
          <t>The VERS tag value contains a list of uint32 version numbers supported
by the server, sorted in ascending numerical order. It <bcp14>MUST</bcp14> contain
the version number specified in the VER tag. It <bcp14>MUST NOT</bcp14> contain more
than 32 version numbers.</t>
          <t>The ROOT tag contains a 32-byte value of a Merkle tree root as
described in <xref target="merkle-tree"/>.</t>
        </section>
        <section anchor="cert">
          <name>CERT</name>
          <t>The CERT tag contains a public key certificate signed with the
server's private long-term key. Its value is a Roughtime message with
the tags SIG and DELE, where SIG is a signature over the DELE value
with the context string "Roughtime v1 delegation signature".</t>
          <t>The DELE tag contains a delegated public key certificate used by the
server to sign the SREP tag. Its value is a Roughtime message with the
tags PUBK, MINT, and MAXT. The purpose of the DELE tag is to enable
separation of a long-term public key from keys on devices exposed to
the public Internet.</t>
          <t>The PUBK tag contains a temporary 32-byte Ed25519 public key that
is used to sign the SREP tag.</t>
          <t>The MINT tag is the minimum timestamp for which the key in PUBK is
trusted to sign responses. MIDP <bcp14>MUST</bcp14> be more than or equal to MINT for
a response to be considered valid.</t>
          <t>The MAXT tag is the maximum timestamp for which the key in PUBK is
trusted to sign responses. MIDP <bcp14>MUST</bcp14> be less than or equal to MAXT for
a response to be considered valid.</t>
        </section>
        <section anchor="indx">
          <name>INDX</name>
          <t>The INDX tag value is a uint32 determining the position of NONC in the
Merkle tree used to generate the ROOT value as described in
<xref target="merkle-tree"/>.</t>
        </section>
      </section>
      <section anchor="merkle-tree">
        <name>The Merkle Tree</name>
        <t>A Merkle tree <xref target="Merkle"/> is a binary tree where the value of each
non-leaf node is a hash value derived from its two children. The root
of the tree is thus dependent on all leaf nodes.</t>
        <t>In Roughtime, each leaf node in the Merkle tree represents one
request. Leaf nodes are indexed left to right, beginning with zero.</t>
        <t>The values of all nodes are calculated from the leaf nodes and up
towards the root node using the first 32 bytes of the output of the
SHA-512 hash algorithm <xref target="RFC6234"/>. For leaf nodes, the byte 0x00 is
prepended to the full value of the client's request packet, including
the "ROUGHTIM" header, before applying the hash function. For all
other nodes, the byte 0x01 is concatenated with first the left and
then the right child node value before applying the hash function.</t>
        <t>The value of the Merkle tree's root node is included in the ROOT tag
of the response.</t>
        <t>The index of a request leaf node is included in the INDX tag of the
response.</t>
        <t>The values of all sibling nodes in the path between a request leaf
node and the root node are stored in the PATH tag so that the client
can reconstruct and validate the value in the ROOT tag using its
request packet. These values are each 32 bytes and are stored one
after the other with no additional padding or structure. The order in
which they are stored is described in the following subsection.</t>
        <section anchor="check-algorithm">
          <name>Root Value Validity Check Algorithm</name>
          <t>This section describes how to compute the value of the root of the
Merkle tree from the values in the tags PATH, INDX, and NONC. The bits
of INDX are ordered from least to most significant. <tt>H(x)</tt> denotes the
first 32 bytes of the SHA-512 hash digest of <tt>x</tt>, and <tt>||</tt> denotes
concatenation.</t>
          <t>The algorithm maintains a current value <tt>h</tt>. At initialization, <tt>h</tt> is
set to <tt>H(0x00 || request_packet)</tt>. For each step of the algorithm,
let node be the next 32 bytes in PATH. If the current bit in INDX is 0
then <tt>h = H(0x01 || h || node)</tt>, else <tt>h = H(0x01 || node || h)</tt>.
When no more entries remain in PATH, <tt>h</tt> is compared to the value of
the root of the Merkle tree contained in ROOT. If they are equal, the
algorithm succeeds. If they are not, or if any of the remaining bits
of INDX is non-zero, the algorithm fails.</t>
        </section>
      </section>
      <section anchor="validity-of-response">
        <name>Validity of Response</name>
        <t>A client <bcp14>MUST</bcp14> check the following properties when it receives a
response. We assume the long-term server public key is known to the
client through other means.</t>
        <t>The signature in CERT was made with the long-term key of the server.</t>
        <t>The MIDP timestamp lies in the interval specified by the MINT and MAXT
timestamps.</t>
        <t>The INDX and PATH values prove a hash value derived from the request
packet was included in the Merkle tree with value ROOT using the
algorithm in <xref target="check-algorithm"/>.</t>
        <t>The signature of SREP in SIG validates with the public key in DELE.</t>
        <t>A response that passes these checks is said to be valid. Validity of a
response does not prove that the timestamp's value in the response is
correct, but merely that the server guarantees that it signed the
timestamp and computed its signature during the time interval
<tt>(MIDP-RADI, MIDP+RADI)</tt>.</t>
      </section>
    </section>
    <section anchor="integration-into-ntp">
      <name>Integration into NTP</name>
      <t>We assume that there is a bound <tt>phi</tt> on the frequency error in the
clock on the machine. Let <tt>delta</tt> be the time difference between the
clock on the client and the clock on the server, and let <tt>sigma</tt>
represent the error in the measured value of delta introduced by the
measurement process. Given a measurement taken at a local time <tt>t</tt>, we
know the true time is in <tt>(t-delta-sigma, t-delta+sigma)</tt>. After <tt>d</tt>
seconds have elapsed we know the true time is within
<tt>(t-delta-sigma-d*phi, t-delta+sigma+d*phi)</tt>.</t>
      <t>This bound can be used as a simple and effective means to limit the
error an attacker can introduce into NTP or Precision Time Protocol
(PTP) measurements. For example, an NTP client can ensure that its
observation intervals fall entirely within this range or can reject
measurements that fall outside.</t>
      <t>An application that needs to verify X.509 certificates (which requires
knowledge of the current time) but lacks an accurate and trusted time
source can use Roughtime to obtain a time estimate. In particular,
securely establishing NTS-protected NTP time synchronization requires
verification of the NTS-KE server's certificate, which is not possible
if the client has no idea of the current time (see <xref section="8.5" sectionFormat="of" target="RFC8915"/>). In that case, a Roughtime time estimate can be used for
certificate validation.</t>
      <t>If an NTP server uses a Roughtime server as a time source for
synchronization (and not only for filtering its NTP measurements), the
root dispersion <bcp14>SHOULD</bcp14> include the server's RADI value, and root delay
<bcp14>SHOULD</bcp14> include the interval between sending the Roughtime request and
receiving the response.</t>
    </section>
    <section anchor="grease">
      <name>Grease</name>
      <t>The primary purpose of grease is to prevent protocol ossification,
which could prohibit future protocol extensions and development
<xref target="RFC9170"/>. In Roughtime, grease is also intended to ensure that
clients validate signatures. To grease the Roughtime protocol, servers
<bcp14>SHOULD</bcp14> send back a fraction of responses with any of the following:
lack of mandatory tags, version numbers not in the request, undefined
tags, or invalid signatures together with incorrect times. Clients
<bcp14>MUST</bcp14> properly ignore undefined tags and reject invalid responses.
Servers <bcp14>MUST NOT</bcp14> send back responses with incorrect times and valid
signatures. Either signature in the response (i.e., of the SREP or DELE tag) <bcp14>MAY</bcp14> be invalid for this application.</t>
    </section>
    <section anchor="roughtime-clients">
      <name>Roughtime Clients</name>
      <section anchor="necessary-configuration">
        <name>Necessary Configuration</name>
        <t>To carry out a Roughtime measurement, a client needs a list of
servers, a minimum of three of which are operational and not run by
the same parties. Roughtime clients <bcp14>SHOULD</bcp14> regularly update their view
of which servers are trustworthy in order to benefit from the
detection of misbehavior (see <xref target="server-lists"/>). Clients <bcp14>SHOULD</bcp14> also
have a means of reporting to the provider of such a list, such as an
operating system or software vendor, a malfeasance report as described
in <xref target="malfeasance-reporting"/>.</t>
      </section>
      <section anchor="measurement-sequence">
        <name>Measurement Sequence</name>
        <t>The client randomly selects at least three servers from the list, and
sequentially queries them. To ensure that all possible inconsistencies
can be detected, it is necessary for clients to repeat the query
sequence twice with the servers in the same order.</t>
        <t>The first probe uses a nonce that is randomly generated. The second
query uses <tt>H(resp || rand)</tt> where <tt>rand</tt> is a random 32-byte value
and <tt>resp</tt> is the entire response to the first probe, including the
"ROUGHTIM" header. Each subsequent query uses <tt>H(resp || rand)</tt> for
the previous response and a different 32-byte <tt>rand</tt> value. <tt>H(x)</tt> and
<tt>||</tt> are defined as in <xref target="check-algorithm"/>.</t>
        <t>For each pair of responses <tt>(i, j)</tt>, where <tt>i</tt> was received before
<tt>j</tt>, the client <bcp14>MUST</bcp14> check that <tt>MIDP_i-RADI_i</tt> is less than or equal
to <tt>MIDP_j+RADI_j</tt>. If these checks pass, the times are consistent
with causal ordering. The measurement succeeds if the validity checks
described in <xref target="validity-of-response"/> are successful, the times
reported are consistent with causal ordering, and the delay between
request and response is within an implementation-dependent maximum
value.</t>
        <t>If the validity checks are successful, but at least one of the
responses is not consistent with causal ordering, there has been a
malfeasance. In case of detected malfeasance, clients <bcp14>SHOULD</bcp14>, if it is
technically possible, generate a malfeasance report (see
<xref target="malfeasance-reporting"/>), alert the user, and make another
measurement. See <xref target="protocol-details"/> for guidance on backoff when
making repeated measurements.</t>
      </section>
      <section anchor="server-lists">
        <name>Server Lists</name>
        <t>To facilitate regular updates of lists of trusted servers, a common
server list format is specified here. Support for the common server
list format is <bcp14>OPTIONAL</bcp14> and clients <bcp14>MAY</bcp14> instead implement their own
mechanisms for configuring server lists.</t>
        <t>A server list is a JSON object <xref target="RFC8259"/> that contains the key
"servers". Server list objects <bcp14>MAY</bcp14> also contain the keys "sources" and
"reports". Appendix A contains an example server list in the
format described here.</t>
        <t>Server lists have the "application/roughtime-server+json" media
type.</t>
        <t>The value of the "servers" key is a list of server objects, each
containing the keys "name", "version", "publicKeyType", "publicKey",
and "addresses".</t>
        <t>The value of "name" is a string that contains a server name suitable
for display to a user.</t>
        <t>The value of "version" is an integer that indicates the highest
Roughtime version number supported by the server.</t>
        <t>The value of "publicKeyType" is a string indicating the signature
scheme used by the server. The value for servers supporting version 1
of Roughtime is "ed25519".</t>
        <t>The value of "publicKey" is a string that is base64-encoded <xref target="RFC4648"/> 
and represents the long-term public key of the server in a format
consistent with the value of "publicKeyType".</t>
        <t>The value of "addresses" is a list of address objects. An address
object contains the keys "protocol" and "address". The value of
"protocol" is either "tcp" or "udp", indicating the transport mode to
use. The value of "address" is a string indicating a host and a port
number, separated by a colon character, for example
"roughtime.example.com:5319". The host part is either an IPv4 address,
an IPv6 address, or a fully qualified domain name (FQDN). IPv4
addresses are specified in dotted decimal notation. IPv6 addresses
<bcp14>MUST</bcp14> conform to the "Text Representation of Addresses" (<xref section="2.2" sectionFormat="of" target="RFC4291"/>)
and <bcp14>MUST NOT</bcp14> include zone identifiers <xref target="RFC9844"/>. To disambiguate
IPv6 addresses from ports when zero compression happens, IPv6
addresses are encapsulated within []. The port part is a decimal
integer representing a valid port number, i.e., in the range 0-65535.</t>
        <t>The value of "sources", if present, is a list of strings indicating
where updated versions of the list may be acquired using the HTTP GET
method <xref target="RFC9110"/>. Each string is a URL <xref target="RFC3986"/> pointing to a
list in the format specified here. The URI scheme <bcp14>MUST</bcp14> be HTTPS
<xref target="RFC9110"/>.</t>
        <t>The value of "reports", if present, is a string indicating a URL
<xref target="RFC3986"/> where malfeasance reports can be sent by clients using
the HTTP POST method. The URI scheme <bcp14>MUST</bcp14> be HTTPS <xref target="RFC9110"/>.</t>
      </section>
      <section anchor="malfeasance-reporting">
        <name>Malfeasance Reporting</name>
        <t>A malfeasance report is cryptographic proof that a sequence of
responses arrived in that order. It can be used to demonstrate that at
least one server sent the wrong time.</t>
        <section anchor="malfeasance-report-structure">
          <name>Malfeasance Report Format</name>
          <t>A malfeasance report is a JSON object <xref target="RFC8259"/> that contains the
key "responses". Its value is a list of response objects, sorted in
the order received. Each response object contains the keys "rand",
"publicKey", "request", and "response". The values of all four keys
are represented as strings that are base64-encoded <xref target="RFC4648"/>.
Appendix B contains an example malfeasance report in the format
described here.</t>
          <t>Malfeasance reports have the "application/roughtime-malfeasance+json"
media type.</t>
          <t>The "rand" key <bcp14>MAY</bcp14> be omitted from the first response object in the
list. In all other cases, its value is the 32-byte value used to
generate the request nonce value from the previous response packet.</t>
          <t>The value of "publicKey" is the long-term key that the server was
expected to use for deriving the response signature.</t>
          <t>The value of "request" is the transmitted request packet, including
the "ROUGHTIM" header.</t>
          <t>The value of "response" is the received response packet, including the
"ROUGHTIM" header.</t>
        </section>
        <section anchor="reporting">
          <name>Reporting</name>
          <t>When the client's list of servers has an associated URL for
malfeasance reports, it <bcp14>SHOULD</bcp14> send a malfeasance report to that URL
when malfeasance is detected (see <xref target="measurement-sequence"/>) and it is
technically feasible to do so. Malfeasance reports are sent using the
HTTP POST method <xref target="RFC9110"/>.</t>
          <t>Since the failure of a popular Roughtime server can cause numerous
clients to send malfeasance reports at the same time, clients <bcp14>MUST</bcp14> use
exponential backoff to prevent overloading the server receiving the
reports. It is <bcp14>RECOMMENDED</bcp14> that clients use an initial retry interval
of 10 seconds, a maximum interval of 24 hours, and a base of 1.5.
Therefore, the minimum interval, in seconds, before retrying after <tt>n</tt>
failures is <tt>min(10 * 1.5^(n-1), 86400)</tt>.</t>
          <t>Clients <bcp14>MUST NOT</bcp14> send malfeasance reports in response to signature
verification failures or any other protocol errors.</t>
          <t>As described in <xref target="introduction"/>, the operational rules for acceptance
or rejection of a particular malfeasance report are beyond the scope
of this document.</t>
        </section>
      </section>
    </section>
    <section anchor="security-considerations">
      <name>Security Considerations</name>
      <section anchor="confidentiality">
        <name>Confidentiality</name>
        <t>This protocol does not provide any confidentiality. Given the nature
of timestamps, such impact is minor.</t>
      </section>
      <section anchor="integrity-and-authenticity">
        <name>Integrity and Authenticity</name>
        <t>The Roughtime protocol only provides integrity and authenticity
protection for data contained in the SREP tag. Accordingly, new tags
<bcp14>SHOULD</bcp14> be added to the SREP tag whenever possible.</t>
      </section>
      <section anchor="generating-private-keys">
        <name>Generating Private Keys</name>
        <t>Although any random 256-bit string can be used as a private Ed25519
key, it has a high risk of being vulnerable to small-subgroup attacks
and timing side-channel leaks. For this reason, all private keys used
in Roughtime <bcp14>MUST</bcp14> be generated following the procedure described in
<xref section="5.1.5" sectionFormat="of" target="RFC8032"/>.</t>
      </section>
      <section anchor="private-key-compromise">
        <name>Private Key Compromise</name>
        <t>The compromise of a PUBK's private key, even past MAXT, is a problem,
as the private key can be used to sign invalid times that are in the
range MINT to MAXT, and thus violate the good-behavior guarantee of
the server. To protect against this, it is necessary for clients to
query multiple servers in accordance with the procedure described in
<xref target="measurement-sequence"/>.</t>
      </section>
      <section anchor="quantum-resistance">
        <name>Quantum Resistance</name>
        <t>Since the only supported signature scheme, Ed25519, is not quantum
resistant, the Roughtime version described in this document will not
survive the advent of quantum computers. A later version will have to
be devised and implemented before then. The use of a single version
number as the negotiation point rather than defining a suite of acceptable
signatures is intended to prevent fragmentation and misconfiguration.</t>
      </section>
      <section anchor="maintaining-lists-of-servers">
        <name>Maintaining Lists of Servers</name>
        <t>The infrastructure and procedures for maintaining a list of trusted
servers and adjudicating violations of the rules by servers is not
discussed in this document and is essential for security.</t>
      </section>
      <section anchor="amplification-attacks">
        <name>Amplification Attacks</name>
        <t>UDP protocols that send responses significantly larger than requests,
such as NTP, have previously been leveraged for amplification attacks.
To prevent Roughtime from being used for such attacks, servers <bcp14>MUST
NOT</bcp14> send response packets larger than the request packets sent by
clients.</t>
      </section>
    </section>
    <section anchor="privacy-considerations">
      <name>Privacy Considerations</name>
      <t>This protocol is designed to obscure all client identifiers. Servers
necessarily have persistent long-term identities essential to
enforcing correct behavior. Generating nonces in a nonrandom manner
can cause leaks of private data or enable tracking of clients as they
move between networks.</t>
    </section>
    <section anchor="operational-considerations">
      <name>Operational Considerations</name>
      <t>It is expected that clients identify a server by its long-term public
key. In multi-tenancy environments, where multiple servers may be
listening on the same IP or port space, the protocol is designed so
that the client indicates which server it expects to respond. This is
done with the SRV tag. Additional recommendations for clients are
listed in <xref target="roughtime-clients"/>.</t>
    </section>
    <section anchor="iana-considerations">
      <name>IANA Considerations</name>
      <section anchor="service-name-and-transport-protocol-port-number-registry">
        <name>Service Name and Transport Protocol Port Number Registry</name>
        <t>IANA has allocated the following entry in the "Service
Name and Transport Protocol Port Number Registry":</t>
        <dl>
          <dt>Service Name:</dt>
          <dd>
            <t>roughtime</t>
          </dd>
          <dt>Transport Protocol:</dt>
          <dd>
            <t>tcp, udp</t>
          </dd>
          <dt>Assignee:</dt>
          <dd>
            <t>IESG &lt;iesg@ietf.org&gt;</t>
          </dd>
          <dt>Contact:</dt>
          <dd>
            <t>IETF Chair &lt;chair@ietf.org&gt;</t>
          </dd>
          <dt>Description:</dt>
          <dd>
            <t>Roughtime time synchronization</t>
          </dd>
          <dt>Reference:</dt>
          <dd>
            <t>RFC 10049</t>
          </dd>
          <dt>Port Number:</dt>
          <dd>
            <t>5319</t>
          </dd>
        </dl>
      </section>
      <section anchor="roughtime-versions-registry">
        <name>Roughtime Versions Registry</name>
        <t>IANA has created a new registry titled "Roughtime
Versions" in a new "Roughtime" registry group. Entries have the
following fields:</t>
        <dl>
          <dt>Version ID (<bcp14>REQUIRED</bcp14>):</dt>
          <dd>
            <t>A 32-bit unsigned integer</t>
          </dd>
          <dt>Version Name (<bcp14>REQUIRED</bcp14>):</dt>
          <dd>
            <t>A short text string naming the version being identified</t>
          </dd>
          <dt>Reference (<bcp14>REQUIRED</bcp14>):</dt>
          <dd>
            <t>A reference to a relevant specification document</t>
          </dd>
        </dl>
        <t>The policy for allocation of new entries is IETF Review <xref target="RFC8126"/>.</t>
        <t>The initial contents of this registry are specified below.</t>
        <table anchor="tab-versions">
          <name>Initial Contents of the Roughtime Versions Registry</name>
          <thead>
            <tr>
              <th align="left">Version ID</th>
              <th align="left">Version Name</th>
              <th align="left">Reference</th>
            </tr>
          </thead>
          <tbody>
            <tr>
              <td align="left">0x0</td>
              <td align="left">Reserved</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="left">0x1</td>
              <td align="left">Roughtime version 1</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="left">0x2-0x7fffffff</td>
              <td align="left">Unassigned</td>
              <td align="left"> </td>
            </tr>
            <tr>
              <td align="left">0x80000000-0xbfffffff</td>
              <td align="left">Reserved for Experimental Use</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="left">0xc0000000-0xffffffff</td>
              <td align="left">Reserved for Private Use</td>
              <td align="left">RFC 10049</td>
            </tr>
          </tbody>
        </table>
        <t>Private and Experimental Use are defined in <xref target="RFC8126"/>. The
experimental range is intended for testing and evaluating new versions
of the Roughtime protocol. Such tests may be conducted over the open
Internet.</t>
      </section>
      <section anchor="roughtime-tags-registry">
        <name>Roughtime Tags Registry</name>
        <t>IANA has created a new registry titled "Roughtime Tags" in
a new "Roughtime" registry group. Entries have the following
fields:</t>
        <dl>
          <dt>Tag (<bcp14>REQUIRED</bcp14>):</dt>
          <dd>
            <t>A 32-bit unsigned integer in hexadecimal format.</t>
          </dd>
          <dt>ASCII Representation (<bcp14>REQUIRED</bcp14>):</dt>
          <dd>
            <t>The ASCII representation of the tag
in accordance with <xref target="type-tag"/> of this document.</t>
          </dd>
          <dt>Reference (<bcp14>REQUIRED</bcp14>):</dt>
          <dd>
            <t>A reference to a relevant specification
document.</t>
          </dd>
        </dl>
        <t>The policy for allocation of new entries in this registry is
Specification Required <xref target="RFC8126"/>.</t>
        <t>The initial contents of this registry are specified below.</t>
        <table anchor="tab-tags">
          <name>Initial Contents of the Roughtime Tags Registry</name>
          <thead>
            <tr>
              <th align="right">Tag</th>
              <th align="left">ASCII Representation</th>
              <th align="left">Reference</th>
            </tr>
          </thead>
          <tbody>
            <tr>
              <td align="right">0x00474953</td>
              <td align="left">SIG</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="right">0x00524556</td>
              <td align="left">VER</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="right">0x00565253</td>
              <td align="left">SRV</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="right">0x434e4f4e</td>
              <td align="left">NONC</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="right">0x454c4544</td>
              <td align="left">DELE</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="right">0x45505954</td>
              <td align="left">TYPE</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="right">0x48544150</td>
              <td align="left">PATH</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="right">0x49444152</td>
              <td align="left">RADI</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="right">0x4b425550</td>
              <td align="left">PUBK</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="right">0x5044494d</td>
              <td align="left">MIDP</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="right">0x50455253</td>
              <td align="left">SREP</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="right">0x53524556</td>
              <td align="left">VERS</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="right">0x544e494d</td>
              <td align="left">MINT</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="right">0x544f4f52</td>
              <td align="left">ROOT</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="right">0x54524543</td>
              <td align="left">CERT</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="right">0x5458414d</td>
              <td align="left">MAXT</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="right">0x58444e49</td>
              <td align="left">INDX</td>
              <td align="left">RFC 10049</td>
            </tr>
            <tr>
              <td align="right">0x5a5a5a5a</td>
              <td align="left">ZZZZ</td>
              <td align="left">RFC 10049</td>
            </tr>
          </tbody>
        </table>
      </section>
      <section anchor="media-type-registry">
        <name>Media Type Registry</name>
        <section anchor="media-type-for-roughtime-server-list">
          <name>Media Type for Roughtime Server List</name>
          <t>IANA has allocated the following entry in the "Media Types"
registry.</t>
          <dl>
            <dt>Type name:</dt>
            <dd>
              <t>application</t>
            </dd>
            <dt>Subtype name:</dt>
            <dd>
              <t>roughtime-server+json</t>
            </dd>
            <dt>Required parameters:</dt>
            <dd>
              <t>N/A</t>
            </dd>
            <dt>Optional parameters:</dt>
            <dd>
              <t>N/A</t>
            </dd>
            <dt>Encoding considerations:</dt>
            <dd>
              <t>Encoding considerations are identical to
those specified for the "application/json" media type, see
<xref target="RFC8259"/>.</t>
            </dd>
            <dt>Security considerations:</dt>
            <dd>
              <t><xref target="security-considerations"/> of
RFC 10049.</t>
            </dd>
            <dt>Interoperability considerations:</dt>
            <dd>
              <t>N/A</t>
            </dd>
            <dt>Published specification:</dt>
            <dd>
              <t><xref target="server-lists"/> of RFC 10049.</t>
            </dd>
            <dt>Applications that use this media type:</dt>
            <dd>
              <t>Roughtime clients (RFC 10049) that update their lists of Roughtime servers.</t>
            </dd>
            <dt>Fragment identifier considerations:</dt>
            <dd>
              <t>N/A</t>
            </dd>
            <dt>Additional information:</dt>
            <dd>
              <t><br/>
              </t>
              <dl spacing="compact">
                <dt>Deprecated alias names for this type:</dt>
                <dd>
                  <t>N/A</t>
                </dd>
                <dt>Magic number(s):</dt>
                <dd>
                  <t>N/A</t>
                </dd>
                <dt>File extension(s):</dt>
                <dd>
                  <t>N/A</t>
                </dd>
                <dt>Macintosh file type code(s):</dt>
                <dd>
                  <t>N/A</t>
                </dd>
              </dl>
            </dd>
            <dt>Person &amp; email address to contact for further information:</dt>
            <dd>
              <t>See Authors' Addresses section of RFC 10049.</t>
            </dd>
            <dt>Intended usage:</dt>
            <dd>
              <t>COMMON</t>
            </dd>
            <dt>Restrictions on usage:</dt>
            <dd>
              <t>N/A</t>
            </dd>
            <dt>Author:</dt>
            <dd>
              <t>See Authors' Addresses section of RFC 10049.</t>
            </dd>
            <dt>Change controller:</dt>
            <dd>
              <t>Internet Engineering Task Force</t>
            </dd>
          </dl>
        </section>
        <section anchor="media-type-for-roughtime-malfeasance">
          <name>Media Type for Roughtime Malfeasance</name>
          <t>IANA has allocated the following entry in the "Media Types"
registry.</t>
          <dl>
            <dt>Type name:</dt>
            <dd>
              <t>application</t>
            </dd>
            <dt>Subtype name:</dt>
            <dd>
              <t>roughtime-malfeasance+json</t>
            </dd>
            <dt>Required parameters:</dt>
            <dd>
              <t>N/A</t>
            </dd>
            <dt>Optional parameters:</dt>
            <dd>
              <t>N/A</t>
            </dd>
            <dt>Encoding considerations:</dt>
            <dd>
              <t>Encoding considerations are identical to
those specified for the "application/json" media type, see
<xref target="RFC8259"/>.</t>
            </dd>
            <dt>Security considerations:</dt>
            <dd>
              <t><xref target="security-considerations"/> of RFC 10049.</t>
            </dd>
            <dt>Interoperability considerations:</dt>
            <dd>
              <t>N/A</t>
            </dd>
            <dt>Published specification:</dt>
            <dd>
              <t><xref target="malfeasance-report-structure"/> of RFC 10049.</t>
            </dd>
            <dt>Applications that use this media type:</dt>
            <dd>
              <t>Roughtime clients
(RFC 10049) use this media type to report cryptographic proof
that a Roughtime server has sent the wrong time.</t>
            </dd>
            <dt>Fragment identifier considerations:</dt>
            <dd>
              <t>N/A</t>
            </dd>
            <dt>Additional information:</dt>
            <dd>
              <t><br/>
              </t>
              <dl spacing="compact">
                <dt>Deprecated alias names for this type:</dt>
                <dd>
                  <t>N/A</t>
                </dd>
                <dt>Magic number(s):</dt>
                <dd>
                  <t>N/A</t>
                </dd>
                <dt>File extension(s):</dt>
                <dd>
                  <t>N/A</t>
                </dd>
                <dt>Macintosh file type code(s):</dt>
                <dd>
                  <t>N/A</t>
                </dd>
              </dl>
            </dd>
            <dt>Person &amp; email address to contact for further information:</dt>
            <dd>
              <t>See Authors' Addresses section of RFC 10049.</t>
            </dd>
            <dt>Intended usage:</dt>
            <dd>
              <t>COMMON</t>
            </dd>
            <dt>Restrictions on usage:</dt>
            <dd>
              <t>N/A</t>
            </dd>
            <dt>Author:</dt>
            <dd>
              <t>See Authors' Addresses section of RFC 10049.</t>
            </dd>
            <dt>Change controller:</dt>
            <dd>
              <t>Internet Engineering Task Force</t>
            </dd>
          </dl>
        </section>
      </section>
    </section>
  </middle>
  <back>
    <references anchor="sec-combined-references">
      <name>References</name>
      <references anchor="sec-normative-references">
        <name>Normative References</name>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.2119.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8174.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.0020.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.0791.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8085.xml"/>
        <referencegroup anchor="BCP106" target="https://www.rfc-editor.org/info/bcp106">
          <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.4086.xml"/>
        </referencegroup>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8032.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.6234.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8259.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.4648.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.4291.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9110.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.3986.xml"/>
      </references>
      <references anchor="sec-informative-references">
        <name>Informative References</name>
        <reference anchor="Merkle" target="https://doi.org/10.1007/3-540-48184-2_32">
          <front>
            <title>A Digital Signature Based on a Conventional Encryption Function</title>
            <author initials="R. C." surname="Merkle" fullname="Ralph C. Merkle">
              <organization>Elxsi</organization>
            </author>
            <date year="1988"/>
          </front>
          <seriesInfo name="DOI" value="10.1007/3-540-48184-2_32"/>
          <refcontent>Advances in Cryptology - CRYPTO '87, Lecture Notes in Computer Science, vol. 293, pp. 369-378</refcontent>
        </reference>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.0738.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.5905.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8915.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9523.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8633.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9170.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9844.xml"/>
        <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8126.xml"/>
      </references>
    </references>
    <?line 1132?>

    <section numbered="false" anchor="appendix-server-list">
      <name>Appendix A. Example Server List</name>
      <t>This appendix presents an example Roughtime server list in the format
described by <xref target="server-lists"/>.</t>
      <artwork><![CDATA[
{
  "servers": [
    {
      "name": "example.com Roughtime server",
      "version": 1,
      "publicKeyType": "ed25519",
      "publicKey": "2O3mkkheDExCuhG+ZNIoWmO/IdCdLzADgUn8SnC4hME=",
      "addresses": [
        {
          "protocol": "udp",
          "address": "roughtime.example.com:5319"
        },
        {
          "protocol": "tcp",
          "address": "roughtime.example.com:5319"
        }
      ]
    },
    {
      "name": "A UDP-only server specified with IP addresses",
      "version": 1,
      "publicKeyType": "ed25519",
      "publicKey": "ZYfeGa94YuG1IZrV3kR9+8/nmZ2lX2XyHmiSb+wI0OY=",
      "addresses": [
        {
          "protocol": "udp",
          "address": "192.0.2.33:5319"
        },
        {
          "protocol": "udp",
          "address": "[2001:db8::2:33]:5319"
        }
      ]
    }
  ],
  "sources": [
    "https://www.example.net/roughtime/ecosystem.json",
    "https://www.example.org/roughtime/ecosystem.json"
  ],
  "reports":  "https://www.example.net/roughtime/malfeasance"
}
]]></artwork>
    </section>
    <section numbered="false" anchor="appendix-malfeasance-report">
      <name>Appendix B. Example Malfeasance Report</name>
      <t>This appendix presents an example Roughtime malfeasance report in the
format described by <xref target="malfeasance-report-structure"/>. The report
provides sufficient information to prove that the server with the
public key <tt>lRhHag6fn2wZQ6idy10ChgpRgks3gvdMM2hWNeJNgXg=</tt> responded
with a time that is inconsistent with the times reported by the two
other servers.</t>
      <artwork><![CDATA[
{
  "responses": [
    {
      "publicKey": "FnDyLV/68ephhLdFJbdEGCdkVvpXDaVe5PYvRDdlOOY=",
      "request": "Uk9VR0hUSU0ABAAABQAAAAQAAAAkAAAARAAAAEgAAABWRVIAU1JW
AE5PTkNUWVBFWlpaWgEAAACf4gKLPdPfiNTv93lrhNqYgyehDgMyHFmA1BrAhM1QEDBh9l
BlN6LUye6zghiqSWMwyNm0IucxQxW3zTMrwj4dAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
==",
      "response": "Uk9VR0hUSU2UAQAABwAAAEAAAABgAAAAZAAAAGQAAADAAAAAWAE
AAFNJRwBOT05DVFlQRVBBVEhTUkVQQ0VSVElORFhBWL64CToGs4v/4UtfN/80HLFiA09vG
IDRP/zTjcTj8/1DlZWCsVja6RlfwaYnc1wfJqThfhcuSDonrTGyKngBMGH2UGU3otTJ7rO
CGKpJYzDI2bQi5zFDFbfNMyvCPh0BAAAABQAAAAQAAAAIAAAAEAAAABQAAABWRVIAUkFES
U1JRFBWRVJTUk9PVAEAAAADAAAAQ0u4aQAAAAABAAAAc86AWYB/O3Kxzsx4d5P5cbSOftJ
UA8bWVtVrQ3tc+b0CAAAAQAAAAFNJRwBERUxFI2B5tbj5ePjVKYE0PAL1NmgZOAsqh/E2f
rom9Ol5BAnVcLje0C6exbXY8hE3dRvYV01Alru8Ocle+jOZT5r8AwMAAAAgAAAAKAAAAFB
VQktNSU5UTUFYVKqljhhqi4A54vW20e+slwViPyxybNnqKXzimIiIUHQMaBCvaQAAAADYy
d9pAAAAAAAAAAA="
    },
    {
      "publicKey": "l9cdSuR8dFxtG9aJo9pWzUXaX8pftNG4UDC45Qk3znc=",
      "rand": "v/DirVBRQLGtictYD7mN3px02UlMT4J3haTRomt1NNM=",
      "request": "Uk9VR0hUSU0ABAAABQAAAAQAAAAkAAAARAAAAEgAAABWRVIAU1JW
AE5PTkNUWVBFWlpaWgEAAABFCvadUKPN/U9OXqFalVFnv/EhsAuPPpBYfo5MDULZKv335k
bNTZcsYLM96o77yLbvvRk1fm2TQB4yKxbP1jzeAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
==",
      "response": "Uk9VR0hUSU2UAQAABwAAAEAAAABgAAAAZAAAAGQAAADAAAAAWAE
AAFNJRwBOT05DVFlQRVBBVEhTUkVQQ0VSVElORFj+2I02cCBAfDYzP+8znW6bICqVrAF23
xNLfM+Qycmkpfp1+BQSb4l/6mRll66l2VIfPSQzigl2V5OJgQzGEBcG/ffmRs1Nlyxgsz3
qjvvItu+9GTV+bZNAHjIrFs/WPN4BAAAABQAAAAQAAAAIAAAAEAAAABQAAABWRVIAUkFES
U1JRFBWRVJTUk9PVAEAAAADAAAAw/m2aQAAAAABAAAAS8ROJoXIPSlO9yN+uREb+/UiOJJ
qCjx3VWZ/vD2FqBMCAAAAQAAAAFNJRwBERUxFw0MFQMiDoHySot8rlnV83Vqaa3qTrAY15
W1TzqNuAurOvreNw08BfUwxF7BQ/b/JCwCQcqtD5uRYsvikvuyLCwMAAAAgAAAAKAAAAFB
VQktNSU5UTUFYVCQs/eCxtWjVrXyse0SeojyZdNFkOwe3B3nLHtHJZK/9gRCvaQAAAADxy
d9pAAAAAAAAAAA="
    },
    {
      "publicKey": "lRhHag6fn2wZQ6idy10ChgpRgks3gvdMM2hWNeJNgXg=",
      "rand": "lMvMVoLsakxc5ZmMzEFQ8hh1FaDo2gCXXIX/L4QPSxQ=",
      "request": "Uk9VR0hUSU0ABAAABQAAAAQAAAAkAAAARAAAAEgAAABWRVIAU1JW
AE5PTkNUWVBFWlpaWgEAAADmAab6GlTSr3xRmwwwvRjW6EKRhtyWYYWZHZIGnF8w2b4DuI
ICvoCWTwCaupBfcOEwV+RqBWB6L1JUGn+ot8+9AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
==",
      "response": "Uk9VR0hUSU2UAQAABwAAAEAAAABgAAAAZAAAAGQAAADAAAAAWAE
AAFNJRwBOT05DVFlQRVBBVEhTUkVQQ0VSVElORFg8MlhdCJeQ2qzN6b9q646W9kB+XmAdS
g7ToU1gj3AD8AP8eCHfduMBE0E8j4/LqWIr72zWQx8Y1U/1uxs97yMAvgO4ggK+gJZPAJq
6kF9w4TBX5GoFYHovUlQaf6i3z70BAAAABQAAAAQAAAAIAAAAEAAAABQAAABWRVIAUkFES
U1JRFBWRVJTUk9PVAEAAAADAAAAw/m2aQAAAAABAAAA6ho4+0Cml+VJbqU7hsF717uusV2
HYvRbU9CdjJE/Zn0CAAAAQAAAAFNJRwBERUxFM9Fvq8T9kOrxcS7jviCPHe44HX/75Je1h
afPJ0f8NoASy29EgD7C0c/LMxXiXxEwyuxYTPN9oseAr9XIt68uDwMAAAAgAAAAKAAAAFB
VQktNSU5UTUFYVMxBDiNG247IO4onsGcjFHsA3vP+arl+s0lBLhXw0c1RlBCvaQAAAAAEy
t9pAAAAAAAAAAA="
    }
  ]
}
]]></artwork>
    </section>

<section numbered="false" anchor="acknowledgments">
      <name>Acknowledgments</name>
      <t><contact fullname="Aanchal Malhotra"/> and <contact fullname="Adam Langley"/> authored early draft versions of this
document. <contact fullname="Daniel Franke"/>, <contact fullname="Sarah Grant"/>, <contact fullname="Erik Kline"/>, <contact fullname="Martin Langer"/>, <contact fullname="Ben Laurie"/>, <contact fullname="Peter Löthberg"/>, <contact fullname="Michael McCourt"/>, <contact fullname="Hal Murray"/>, <contact fullname="Tal Mizrahi"/>,
<contact fullname="Ruben Nijveld"/>, <contact fullname="Christopher Patton"/>, <contact fullname="Thomas Peterson"/>, <contact fullname="Rich Salz"/>, <contact fullname="Dieter Sibold"/>, <contact fullname="Ragnar Sundblad"/>, <contact fullname="Kristof Teichel"/>, <contact fullname="Luke Valenta"/>, <contact fullname="David Venhoek"/>,
<contact fullname="Ulrich Windl"/>, and the other members of the NTP Working Group
contributed comments and suggestions as well as pointed out errors. We
also acknowledge the helpful comments and suggestions provided by the
Last Call reviewers and members of the IESG.</t>
    </section>
  </back>

</rfc>
